
GIAÙO TRÌNH THIEÁT KEÁ WEB :  PHAÀN LYÙ THUYEÁT - TÖÏ HOÏC MACROMEDIA FLASH 5.0 BAÈNG HÌNH AÛNH                 CHÖÔNG 1 
 

 
 

TOÅNG QUAN VEÀ FLASH 5 
 
VUØNG LAØM VIEÄC TRONG FLASH   

Khi baïn laøm vieäc trong Flash, baïn coù theå taïo ra moät ñoaïn phim baèng caùch veõ moät aûnh 
hay nhaäp vaøo moät aûnh veõ, saép xeáp noù trong moät Stage, vaø laøm chuyeån ñoäng aûnh vôùi thanh thöôùc 
thôøi gian Timeline. Baïn taïo ra vuøng chuyeån caûnh trong ñoaïn phim baèng caùch duøng caùc Action 
(haønh vi) ñeå taïo ra ñoaïn phim traû lôøi laïi caùc söï kieän theo nhieàu caùch ñaëc bieät. Khi ñoaïn phim 
ñöôïc taïo xong, baïn coù theå xuaát noù thaønh ñoaïn phim Flash Player vaø xem chuùng trong Flash 
Player, hoaëc trình chieáu ñoaïn phim trong chöông trình Flash Player ñoäc laäp vôùi Flash.   

Baïn coù theå xem moät ñoaïn phim taïo ra trong Flash theo nhöõng caùch sau ñaây:  

 Trong caùc trình duyeät Internet nhö Netscape Navigator,  Microsoft Internet Explorer. 
Caùc trình duyeät naøy coù theå duøng vôùi Flash Player. 

 Vôùi ñieàu khieån Flash ActiveX trong Microsoft Office, Microsoft Internet Explorer  
ñoái vôùi Windows vaø caùc moâi tröôøng maùy chuû ActiveX  khaùc. 

 Trong Flash Player, moät trình öùng duïng ñoäc laäp. 

 Nhö moät chöông trình chieáu phim ñoäc laäp, file cuûa ñoaïn phim coù theå ñöôïc  phaùt maø 
khoâng caàn phaàn meàm Flash Player. 

AÛNH TRONG  FLASH  

Flash  cung caáp nhieàu phöông phaùp ñeå taïo ra aûnh goác vaø xuaát aûnh goác naøy sang  nhieàu 
chöông trình öùng duïng khaùc. Baïn coù theå taïo ra nhieàu ñoái töôïng baèng caùch duøng caùc coâng cuï veõ 
vaø toâ, xaùc ñònh caùc thuoäc tính cuûa caùc ñoái töôïng ñang toàn taïi. Baïn coù theå xem muïc Toång quan 
veà caùc caùch veõ vaø laøm vieäc vôùi caùch choïn maøu. Ngoaøi ra baïn cuõng coù theå ñöa vaøo caùc aûnh ñoà 
hoïa Bitmap hay aûnh Vec-tô töø caùc chöông trình öùng duïng khaùc vaø thay ñoåi aûnh nhaäp naøy vaøo 
trong Flash.  

AÛNH ÑOÀ HOÏA VÔÙI ÑÒNH DAÏNG VECTOR VAØ BITMAP 

Maùy tính hieån thò aûnh vôùi ñònh daïng Vector hay Bitmap. Neáu hieåu roõ hai söï khaùc nhau 
giöõa hai caùch ñònh daïng naøy coù theå giuùp baïn laøm vieäc hieäu quaû hôn. Flash cho pheùp baïn taïo ra 
vaø laøm aûnh chuyeån ñoäng vôùi ñònh daïng Vector. Ngoaøi ra Flash cuõng cho pheùp baïn môû thao taùc 
aûnh vôùi ñònh daïng Vector vaø Bitmap ñaõ taïo ra trong caùc trình öùng duïng khaùc.  

AÛnh vôùi ñònh daïng Vector   

Veõ caùc aûnh Vector baèng caùch söû duïng caùc coâng cuï veõ ñöôøng thaúng vaø ñöôøng cong bao 
goàm caùc thuoäc tính maøu vaø vò trí  goïi laø Vector.  

Ví duï, aûnh chieác laù ñöôïc veõ nhö hình trang beân ñöôïc thöïc hieän bôûi nhöõng ñieåm maø 
ñöôøng thaúng ñi ngang qua, taïo ra hình daïng vieàn ngoaøi cuûa chieác laù. Maøu cuûa chieác laù ñöôïc xaùc 
ñònh bôûi maøu cuûa ñöôøng vieàn vaø maøu cuûa vuøng choïn bao quanh ñöôøng vieàn.  

TUÛ  SAÙCH STK – THEÁ GIÔÙI ÑOÀ HOÏA                                                                                                     BIEÂN SOAÏN : KS PHAÏM QUANG HUY 5 



GIAÙO TRÌNH THIEÁT KEÁ WEB :  PHAÀN LYÙ THUYEÁT - TÖÏ HOÏC MACROMEDIA FLASH 5.0 BAÈNG HÌNH AÛNH                 CHÖÔNG 1 
 

Khi baïn chænh söûa aûnh Vector naøy, baïn haõy thay ñoåi caùc thuoäc 
tính cuûa ñöôøng thaúng vaø ñöôøng cong taïo neân hình daïng cuûa chieác laù. 
Baïn coù theå di chuyeån, thay ñoåi kích thöôùc, thu phoùng, thay ñoåi maøu 
cuûa aûnh vector maø khoâng thay ñoåi ñaëc tính beân ngoaøi cuûa noù. AÛnh 
Vector coù ñoä phaân giaûi maøu ñoäc laäp, ñieàu naøy coù nghóa laø chuùng coù 
theå hieån thò vôùi nhieàu thieát bò xuaát khaùc nhau cho ra caùc ñoä phaân giaûi 
khaùc nhau maø khoâng phaûi thay ñoåi baát kyø ñaëc tính naøo cuûa noù. 

 

AÛnh vôùi ñònh daïng Bitmap   

AÛnh Bitmap söû duïng caùc chaám maøu ñöôïc xeáp ñaët trong moät 
maûng löôùi goïi laø pixel. Chaúng haïn nhö aûnh cuûa chieác laù ñöôïc veõ taïi 
nhöõng  vò trí ñaëc bieät goïi laø pixel (ñieåm aûnh) vaø moãi pixel coù giaù trò 
maøu trong vuøng löôùi, taïo ra moät aûnh theå hieän qua caùc pixel khaùc nhau 
nhö laø moät theå khaûm. Khi baïn hieäu chænh moät aûnh Bitmap, coù nghóa 
baïn  thay ñoåi caùc thuoäc tính pixel khoâng nhö laø caùc aûnh vector laø thay 
ñoåi caùc thuoäc tính ñöôøng thaúng vaø ñöôøng cong.   

 AÛnh Bitmap coù ñoä phaân giaûi phuï thuoäc vì döõ lieäu taïo ra moät aûnh veõ ñöôïc xeáp vaøo löôùi 
coù kích thöôùc ñaëc bieät. Vieäc hieäu chænh aûnh Bitmap coù theå laøm thay ñoåi chaát löôïng aûnh xuaát 
hieän. Ñaëc bieät khi thay ñoåi kích thöôùc aûnh Bitmap coù theå laøm cho caùc goùc bieân cuûa aûnh troâng raát 
thoâ khi caùc ñieåm pixel aûnh ñöôïc phaân boá laïi trong vuøng löôùi. Khi moät aûnh Bitmap xuaát ra thieát 
bò coù ñoä phaân giaûi thaáp hôn ñoä phaân giaûi cuûa aûnh, ñieàu naøy seõ laøm cho chaát löôïng aûnh xuaát ra 
trôû neân nhaït maøu.  

Chuù yù :   Baïn cuõng coù theå ñöa vaøo moät file aâm thanh, baïn coù theå ñöôïc bieát roõ raøng hôn  trong 
muïc “ Toång quan veà caùch theâm aâm thanh vaøo trong Flash”. 

AÛNH CHUYEÅN ÑOÄNG (ANIMATION) TRONG FLASH  

Khi söû duïng Flash, baïn coù theå taïo ra caùc ñoái töôïng chuyeån ñoäng, laøm cho chuùng  xuaát 
hieän, di chuyeån ngang qua khung Stage (nôi trình chieáu) hoaëc laøm thay ñoåi hình daùng (Shape), 
kích thöôùc (Size), maøu saéc (Color), höôùng xoay (Rotation) vaø caùc thuoäc tính khaùc. Baïn coù theå 
taïo ra aûnh chuyeån ñoäng töø frame (khung) naøy sang frame khaùc maø trong moãi khung taïo ra moät 
aûnh rieâng leõ. Ngoaøi ra, baïn cuõng coù theå taïo aûnh chuyeån ñoäng kieåu Tween, trong kieåu naøy caùc 
baïn chæ caàn taïo ra frame ñaàu tieân vaø frame cuoái cuøng sau ñoù Flash taïo tröïc tieáp caùc frame giöõa 
ñeå keát noái frame ñaàu vaø frame cuoái. Baïn cuõng coù theå taïo ra aûnh chuyeån ñoäng xuaát hieän thaønh 
ñoaïn phim thoâng qua duøng caùc leänh trong Set Property Action. Baïn coù theå xem muïc trôï giuùp taïi 
phaàn ActionScript.  

CHUYEÅN CAÛNH ÑOAÏN PHIM TRONG FLASH  

Flash cho pheùp baïn taïo ra caùc vuøng chuyeån caûnh cho ñoaïn phim maø trong ñoù ngöôøi xem 
coù theå söû duïng baøn phím  hay chuoät ñeå nhaûy ñeán töøng phaàn khaùc nhau cuûa ñoaïn phim, di chuyeån 
ñoái töôïng, nhaäp vaøo troâng tin trong caùc maãu vaø thöïc hieän nhieàu thao taùc khaùc. Baïn coù theå taïo ra 
vuøng chuyeån caûnh baèng caùch thieát laäp caùc Action (haønh vi) duøng ActionScript. Ñeå bieát theâm 
thoâng tin veà caùch thieát laäp caùc Action chung nhaát trong  Flash, baïn coù theå tham khaûo muïc “Caùch 
taïo ra vuøng chuyeån caûnh trong ñoaïn phim”.  
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Baïn thieát laäp haønh ñoäng trong baûng Actions khi baïn taïo nuùt, moät Clip hay moät frame. 
Duøng baûng Actions ñieàu khieån trong cheá ñoä Normal Mode, baïn coù theå cheøn vaøo caùc action maø 
khoâng caàn phaûi vieát baát kyø maõ ActionScript naøo.   

Neáu baïn quen thuoäc vôùi caùc ActionScript, baïn coù theå vieát caùc maõ Script cho rieâng baïn. 
Nhöõng muïc chæ daãn coù theå laø ôû trong caùc form cuûa moät action ñôn leû nhö vieäc : höôùng daãn caùch 
ngöøng phaùt moät ñoaïn phim hay moät loaït caùc action, hoaëc khi baïn öôùc löôïng moät ñieàu kieän sau 
ñoù ñeå thöïc thi moät action. Nhieàu action ñoøi hoûi caùc baïn phaûi coù moät ít kinh nghieäm trong vieäc 
laäp trình ñeå thieát laäp chuùng. Caùc action ñoøi hoûi phaûi quen thuoäc vôùi caùc ngoân ngöõ laäp trình vaø 
phaùt trieån ñeán möùc ñoä xa hôn. Baïn coù theå tham khaûo phaàn ngoân ngöõ trôï giuùp maõ ActionScript. 

VUØNG LAØM VIEÄC TRONG FLASH  

Khi taïo vaø chænh söûa ñoaïn phim, baïn coù theå laøm vieäc vôùi nhöõng thuoäc tính quan troïng coù 
teân sau ñaây:  

 Stage : Vuøng hình chöõ nhaät nôi maø ñoaïn phim ñöôïc phaùt. 

 Thanh thöôùc thôøi gian Timeline : Taïi ñaây caùc aûnh taïo ra seõ ñöôïc dieãn hoaït lieân tuïc.   

 
Thanh thöôùc Timeline 

 Symbol (Bieåu töôïng) : Nguoàn taøi nguyeân truyeàn thoâng coù theå duøng laïi trong phim. 

 Cöûa soå Library : Nôi caùc bieåu töôïng ñöôïc thieát laäp. 

 Movie Explorer : Taïo ra moät caùi nhìn toång theå veà ñoaïn phim vaø caáu truùc cuûa noù. 

 
Baûng Movie Explorer 

 Caùc baûng troâi treân vuøng laøm vieäc, cho pheùp baïn thay ñoåi nhieàu thaønh phaàn trong 
ñoaïn phim vaø ñònh caáu hình vuøng laøm vieäc trong Flash sao cho thích hôïp nhaát. 

Vuøng Stage vaø thanh thöôùc thôøi gian Timeline  

Gioáng nhö phim chieáu, ñoaïn phim thöïc hieän trong Flash coù ñoä daøi ñöôïc chia thaønh nhieàu 
frame.Vuøng Stage laø nôi taïo ra noäi dung cho töøng frame rieâng bieät trong ñoaïn phim, veõ aûnh tröïc 
tieáp leân frame ñoù hay xeáp ñaët aûnh nhaäp vaøo.  
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Vuøng  Stage nôi maø baïn taïo ra töøng frame rieâng reõ cho ñoaïn phim 

 

Thanh thöôùc Timeline laø nôi baïn saép xeáp thôøi gian chuyeån ñoäng vaø laép raùp aûnh vaøo trong caùc Layer ñaëc bieät. 
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Thanh thöôùc thôøi gian Timeline laø nôi baïn saép xeáp thôøi gian aûnh chuyeån ñoäng  vaø laép raùp 
aûnh vaøo trong caùc  Layer ñaëc bieät. Trong ñoaïn phim, Timeline hieån thò töøng frame.  

Caùc Layer hoaït ñoäng gioáng nhö caùc taám phim trong suoát, giöõ cho aûnh taùch bieät nhau vì 
vaäy baïn coù theå keát noái nhieàu thaønh phaàn khaùc nhau laïi thaønh moät aûnh coù theå thaáy lieân tuïc.  

 

Ñieàu khieån  bieåu töôïng, gheá vaø höôùng xoay trong ñoaïn phim laø moãi  Layer rieâng bieät 

Caùc Symbol Vaø  Instance  

Caùc Symbol  (bieåu töôïng) laø caùc yeáu toá coù theå duøng laïi khi baïn söû duïng trong ñoaïn phim. 
Caùc Symbol coù theå laø caùc aûnh ñoà hoïa, nuùt, clip aâm thanh hay font chöõ. Khi baïn taïo ra moät 
Symbol, Symbol naøy ñöôïc löu laïi vaøo trong file thö vieän, khi baïn thay theá Symbol trong vuøng 
Stage,  baïn ñaõ taïo ra moät Instance cuûa Symbol ñoù.  

Caùc Symbol laøm giaûm kích thöôùc file, boû qua nhieàu Instance cuûa Symbol baïn taïo ra.  
Flash löu laïi caùc Symbol trong file chæ moät laàn.  Ñieàu naøy raát coù ích ñoái vôùi caùc thaønh phaàn xuaát 
hieän nhieàu laàn. Baïn coù theå thay ñoåi caùc thuoäc tính cuûa Instance maø khoâng laøm aûnh höôûng ñeán 
Symbol chính vaø hieäu chænh Symbol chính ñeå laøm thay ñoåi taát caû caùc Instance.  

Baïn coù theå chænh söûa caùc Symbol trong vuøng Stage. Caùc thaønh phaàn khaùc coøn laïi cuõng 
hieån thò trong vuøng Stage nhöng bò môø ñi. Ngoaøi ra cuõng coù theå hieäu chænh moät Symbol trong 
moät cöûa soå ñoäc laäp, vuøng cöûa soå taïi thanh thöôùc Timeline chæ hieån thò thanh thöôùc Timeline cuûa 
Symbol baïn ñang hieäu chænh. Baïn coù theå xem kyõ phaàn naøy trong muïc  “Caùch hieäu chænh 
Symbol”  

Baïn cuõng coù theå xaùc ñònh vaø môû moät Symbol trong thö vieän töø beân trong vuøng Movie 
Explorer, söû duïng leänh Find trong Library. Baïn coù theå xem kyõ phaàn naøy trong muïc  “Caùch 
duøng Movie Explorer”.  

TUÛ  SAÙCH STK – THEÁ GIÔÙI ÑOÀ HOÏA                                                                                                     BIEÂN SOAÏN : KS PHAÏM QUANG HUY 9 



GIAÙO TRÌNH THIEÁT KEÁ WEB :  PHAÀN LYÙ THUYEÁT - TÖÏ HOÏC MACROMEDIA FLASH 5.0 BAÈNG HÌNH AÛNH                 CHÖÔNG 1 
 

Ñeå bieát theâm veà caùc Symbol vaø Instance,  baïn coù theå choïn muïc tham khaûo Symbols 
trong trình ñôn Help > Lessons > Symbols (baèng tieáng Anh).  

 
Hieäu chænh moät Symbol  ñoäc laäp (beân traùi) vaø hieäu chænh moät Symbol trong ngöõ caûnh cuûa ñoaïn phim 

CAÙC SYMBOL VAØ VUØNG CHUYEÅN CAÛNH CUÛA ÑOAÏN PHIM TÖÔNG TAÙC 

Ngoaøi ra caùc Symbol laø moät phaàn toaøn boä cho vieäc taïo ra phaàn chuyeån caûnh cho ñoaïn 
phim. Baïn coù theå duøng caùc Instance cuûa Symbol ñeå taïo ra vuøng chuyeån caûnh cho ñoaïn phim. Ví 
duï nhö : Baïn coù theå taïo ra moät bieåu töôïng nuùt laøm thay ñoåi caùc haønh vi cuûa chuoät vaø ñaët 
Instance cuûa Symbol vaøo trong Stage. Baïn coù theå duøng loaïi Symbol khaùc goïi laø Movie Clip, 
nhaèm taïo ra caùc phaàn chuyeån  caûnh phöùc taïp hôn.  

Cöûa soå Library (Thö vieän) 
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Cöûa soå Library laø nôi löu vaø saép xeáp  caùc Symbol ñöôïc taïo ra trong Flash, cuõng nhö môû 
file aûnh Bitmap, file aâm thanh vaø QuickTime movies. Cöûa soå Library cho pheùp saép xeáp  caùc thö 
muïc trong thö vieän, sau ñoù saép xeáp chuùng theo loaïi naøo thöôøng ñöôïc duøng ñeán. 

TAÏO MOÄT ÑOAÏN PHIM MÔÙI VAØ THIEÁT LAÄP CAÙC THUOÄC TÍNH CUÛA NOÙ 

Moãi khi môû Flash, trình öùng duïng seõ taïo ra moät file môùi, vôùi phaàn ñònh daïng môû roäng laø 
FLA.  Baïn coù theå taïo ra caùc ñoaïn phim môùi do baïn laøm. Thieát laäp kích thöôùc soá löôïng frame, 
maøu neàn Background vaø caùc thuoäc tính khaùc cuûa ñoaïn phim môùi. Baïn seõ duøng hoäp thoaïi Movie 
Properties.  

Caùch taïo moät ñoaïn phim môùi vaø thieát laäp caùc thuoäc tính cuûa noù 

1. Choïn treân trình ñôn File > 
New. Sau ñoù choïn tieáp treân 
trình ñôn Modify > Movie. 
Hoäp thoaïi Movie Properties 
xuaát hieän. Taïi muïc choïn 
Frame Rate, nhaäp vaøo soá 
frame chuyeån ñoäng ñöôïc hieån 
thò trong moãi giaây. 

 

Ñoái vôùi haàu heát caùc aûnh chuyeån ñoäng hieån thò treân maùy tính, ñaëc bieät  khi chuùng hieån thò 
treân trang Web, giaù trò töø 8 fps (frame per second) ñeán 12 fps thöôøng ñöôïc söû duïng nhieàu nhaát. 
(cheá ñoä maëc ñònh laø 12 fps). 

 

2. Ñoái vôùi muïc choïn Dimensions, baïn coù theå choïn moät trong nhöõng tuøy choïn sau: 

 

 Xaùc ñònh kích thöôùc Stage baèng pixel, nhaäp vaøo giaù trò cho muïc Width vaø Height. 
Kích thöôùc ñoaïn phim theo maëc ñònh laø 550 x 400 pixels. Kích thöôùc toái thieåu laø 
18 x 18 pixel, kích thöôùc toái ña laø 2880 x 2880 pixel.  

 Thieát laäp kích thöôùc trong vuøng Stage ñeå coù khoaûng troáng xung quanh dieän tích 
caùc maët, nhaáp chuoät vaøo nuùt  Match Contents. Xaùc ñònh kích thöôùc ñoaïn phim toái 
thieåu, canh leà taát caû caùc thaønh phaàn sang goùc traùi treân cuûa Stage tröôùc khi söû duïng 
Contents trong muïc Match. 
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 Thieát laäp kích thöôùc trong vuøng Stage ñeán giaù trò lôùn nhaát cho vuøng in ra giaáy, 

nhaáp chuoät vaøo nuùt Match choïn Printer. Vuøng naøy xaùc ñònh kích thöôùc khoå giaáy 
tröø ñi leà trang hieän haønh ñöôïc choïn trong vuøng Margins cuûa hoäp thoaïi Page Setup 
(trong  Windows) hoaëc hoäp thoaïi Print Margins (trong Macintosh). 

 

3. Thieát laäp maøu neàn Background cho ñoaïn phim, nhaáp chuoät vaøo nuùt Background Color 
choïn moät maøu coù trong baûng maøu Background vöøa xuaát hieän. 

 

 

4. Choïn moät ñôn vò ño trong trình ñôn xoå xuoáng Ruler Units,  choïn ñôn vò ño cho loaïi thöôùc 
maø baïn muoán hieån thò trong cöûa soå cuûa trình öùng duïng.  

 
5. Sau khi xaùc ñònh xong caùc thuoäc tính, nhaáp chuoät choïn nuùt OK. 
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XEM TRÖÔÙC VAØ KIEÅM TRA LAÏI ÑOAÏN PHIM 

Khi baïn taïo ra moät ñoaïn phim, baïn caàn phaùt noù laïi ñeå xem caùc chuyeån ñoäng vaø kieåm tra  
caùc ñieàu khieån chuyeån caûnh. Baïn coù theå xem vaø kieåm tra ñoaïn phim trong Flash taïi cöûa soå laøm 
vieäc hay taïi trình duyeät Web.  

Xem tröôùc ñoaïn phim trong vuøng cöûa soå taïi Stage: 

Ñeå xem tröôùc ñoaïn phim baïn coù theå söû duïng leänh trong trình ñôn Control, caùc nuùt trong 
Controller hoaëc leänh baèng baøn phím.  

Ñeå xem tröôùc caûnh trong ñoaïn phim hieän haønh, haõy thöïc hieän moät trong caùc thao taùc sau 
ñaây:  

 Choïn treân trình ñôn Control > Play. 

 Choïn tieáp treân trình ñôn Window > Toolbars  > Controller (trong Windows) hoaëc 
Window >  Controller (trong Macintosh) vaø nhaáp chuoät vaøo nuùt Play. 

 

 
 Nhaán phím Enter (Windows) hoaëc phím Return (Macintosh). Caûnh chuyeån ñoäng        

hieån thò trong cöûa soå Movie vôùi soá löôïng frame ñaõ xaùc ñònh  cho ñoaïn phim.  

 Ñeå böôùc sang caùc frame tieáp theo cuûa quaù trình chuyeån ñoäng, baïn haõy söû duïng nuùt 
Step Forward vaø nuùt Step Backward trong baûng Controller hoaëc choïn nhöõng leänh naøy 
trong trình ñôn Control. Baïn coù theå nhaán phím < & > treân baøn phím. Baïn coù theå ñi ñeán 
frame ñaàu tieân hoaëc frame cuoái cuøng trong ñoaïn phim, baïn coù theå söû duïng nuùt First 
Frame hay Last Frame trong baûng Controller. 

 

Chuù yù :  Baïn coù theå thay ñoåi caùch phaùt laïi (Playback) cuûa ñoaïn phim baèng caùch duøng caùc leänh 
trong trình ñôn Control. Chuù yù raèng baïn phaûi choïn Control > Play ñeå xem ñoaïn phim tröôùc khi  
duøng caùc leänh sau ñaây.  

Xem ñoaïn phim ôû cheá ñoä lieân tuïc : Choïn treân trình ñôn Control > Loop 
Playback.  

♦ 

♦ Xem taát caû caùc caûnh trong ñoaïn phim : Choïn treân trình ñôn Control > Play All 
Scenes.  
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Xem ñoaïn phim khoâng caàn nghe aâm thanh : Choïn trong trình ñôn Control > 
Mute Sounds.  

♦ 

♦ 

♦ 

♦ 

Choïn haønh vi cho frame actions : Choïn treân trình ñôn Control > Enable Simple 
Frame Actions hoaëc Enable Simple Buttons.  

KIEÅM TRA LAÏI ÑOAÏN PHIM 

Duø Flash coù theå phaùt ñoaïn phim trong vuøng Stage, nhieàu chöùc naêng chuyeån caûnh vaø 
chuyeån ñoäng khoâng theå hoaït ñoäng tröø khi ñoaïn phim ñöôïc xuaát ra ñònh daïng cuoái cuøng. Baïn coù 
theå söû duïng caùc leänh treân trình ñôn Control, hay coù theå xuaát ñoaïn phim hieän haønh ra döôùi ñònh 
daïng Flash Player vaø laäp töùc phaùt ñoaïn phim trong cöûa soå môùi. Vieäc xuaát ra moät ñoaïn phim 
duøng caùc tuøy choïn ñöôïc thieát laäp trong hoäp thoaïi Publish Settings. Baïn coù theå kieåm tra moät ñoaïn 
phim trong trình duyeät Web. Ngoaøi ra cuõng coù theå kieåm tra caùc action trong ñoaïn phim duøng cheá 
ñoä Debugger.  

 Caùch kieåm tra caùc chöùc naêng chuyeån caûnh vaø chuyeån ñoäng 

Choïn treân trình ñôn  Control > Test Movie  hoaëc Control > Test Scene.  

Flash taïo ra moät ñoaïn phim Flash Player (moät file  SWF),  môû noù trong cöûa soå ñoäc 
laäp vaø xem noù trong Flash Player. File  SWF ñöôïc ñaët trong cuøng thö muïc vôùi file 
FLA.  

 Caùch kieåm tra ñoaïn phim trong trình duyeät Web  

 Choïn treân trình ñôn File > Publish Preview  > HTML.  

LÖU FILE ÑOAÏN PHIM THÖÏC HIEÄN 

Baïn coù theå löu moät file trong Flash FLA, söû duïng teân vaø ñòa chæ hieän haønh hoaëc löu taøi 
lieäu sang teân khaùc vaø vuøng ñòa chæ khaùc. Baïn coù theå  trôû laïi phieân baûn ñaõ löu laïi laàn sau cuøng.   

Caùch löu moät taøi lieäu  

 Thöïc hieän moät trong nhöõng thao taùc sau: 

 

Ñeå ghi choàng leân phieân baûn hieän haønh treân, choïn File > Save. ♦ 

♦ Löu file vaøo vuøng teân vaø ñòa chæ khaùc, choïn treân trình ñôn File > Save As. 
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Neáu baïn choïn leänh Save As hoaëc neáu baïn chöa bao giôø löu file ñang taïo, haõy 
nhaäp teân vaø ñòa chæ cho file ñoù.  

2. Sau ñoù nhaáp chuoät vaøo nuùt Save. 

Trôû laïi phieân baûn file ñaõ löu cuoái cuøng :  Choïn treân trình ñôn File > Revert. 

CAÙCH DUØNG HOÄP COÂNG CUÏ   

Caùc coâng cuï trong hoäp coâng cuï cho pheùp baïn veõ, toâ, choïn, chænh söûa aûnh vaø thay ñoåi 
vuøng xem trong Stage. Hoäp coâng cuï ñöôïc chia thaønh boán vuøng choïn:  

Vuøng choïn Tools goàm coù caùc coâng cuï veõ, toâ vaø choïn. ♦ 

♦ 

♦ 

♦ 

♦ 

♦ 

Vuøng choïn View goàm coù caùc coâng cuï khuyeách ñaïi vaø di chuyeån trong cöûa soå 
chöông trình. 

Vuøng choïn Colors goàm coù caùc coâng cuï chænh söûa vaø toâ maøu. 

Vuøng tuøy choïn Options hieån thò vieäc chænh söûa coâng cuï choïn maø coù aûnh höôûng 
ñeán  neùt veõ cuûa coâng cuï hoaëc treân thao taùc hieäu chænh.  

Ñeå bieát theâm thoâng tin veà caùch duøng caùc coâng cuï veõ vaø toâ, baïn coù theå xem muïc “Caùc 
coâng cuï veõ vaø toâ maøu trong Flash”. Ñoái vôùi caùch duøng caùc coâng cuï choïn, coù theå tham khaûo muïc 
“Caùch choïn caùc ñoái töôïng”. Ñoái vôùi caùch duøng caùc coâng cuï chænh söûa xem tröôùc, coù theå tham 
khaûo “Vuøng xem tröôùc trong Stage”. 

Caùch hieån thò hoaëc cho aån  hoäp coâng cuï:  

     Choïn treân trình ñôn Window > Tools.  

     Ñeå choïn moät coâng cuï, baïn haõy thöïc 
hieän moät trong nhöõng thao taùc sau ñaây:  

Nhaáp chuoät vaøo coâng cuï baïn muoán 
duøng. Tuøy thuoäc vaøo coâng cuï baïn 
choïn, moät boä coâng cuï boå sung cho 
coâng cuï vöøa choïn hieån thò trong vuøng 
döôùi cuøng cuûa hoäp thoaïi. 

Nhaán phím noùng cho coâng cuï muoán 
choïn. 

 

 

Baûng hoäp coâng cuï trong Flash 
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CAÙCH DUØNG CAÙC THANH COÂNG CUÏ TRONG CÖÛA SOÅ WINDOWS  

Trong Windows, baïn söû duïng caùc leänh trong trình ñôn phuï Toolbars ñeå laøm hieån thò hay 
daáu ñi caùc thanh coâng cuï chöùa caùc leänh trong Shortcut bar. Baïn coù theå caát caùc thanh coâng cuï veõ 
vaø thanh coâng cuï chuaån hoaëc cho pheùp chuùng troâi treân cöûa soå.  

Cho caùc thanh coâng cuï aån hoaëc hieån thò 

Choïn treân trình ñôn Window > Toolbars vaø choïn nhöõng tuøy choïn sau:  

Thanh coâng cuï chính hieån thò thanh coâng cuï chuaån coù caùc Shortcut caùc leänh treân 
trình ñôn chuaån nhö Open vaø Print. 

♦ 

♦ 

♦ 

Vuøng traïng thaùi hieån thò qua thanh Status, goàm coù caùc thoâng tin veà caùc leänh vaø 
nuùt cuûa phím Caps Lock vaø Num Lock. 

Caùc thanh ñieàu khieån hieån thò treân thanh Controller, giuùp cho vieäc phaùt laïi ñoaïn 
phim. 

Di chuyeån thanh coâng cuï troâi trong cöûa soå 

 Keùo chuoät treân baát kyø vò trí naøo treân neàn Background hoaëc treân thanh tieâu ñeà.  

CAÙCH DUØNG CAÙC BAÛNG  

Trong Flash baïn duøng raát nhieàu baûng troâi treân cöûa soå laøm vieäc. Caùc baûng naøy giuùp baïn 
xem, saép xeáp vaø thay ñoåi caùc thuoäc tính trong ñoaïn phim. Caùc baûng trong Flash cho pheùp baïn 
laøm vieäc vôùi caùc ñoái töôïng, maøu saéc, vaên baûn, Instance, frame, Scene vaø toaøn ñoaïn phim.  

Ví duï nhö baïn duøng baûng Character cho vieäc choïn caùc thuoäc tính nhaäp kyù töï vaø baûng 
Frame cho vieäc nhaäp vaøo caùc teân cuûa frame vaø choïn tuøy choïn Tween Options.  

Ñeå xem danh saùch caùc baûng coù trong Flash, choïn treân trình ñôn Window > Panels.  

      
Baïn coù theå hieån thò, laøm aån, nhoùm vaø thay ñoåi kích thöôùc caùc baûng naøy khi baïn laøm vieäc. 

Ngoaøi ra baïn coù theå hieån thò nhieàu baûng nhö baûng Info, Mixer, Instance, Frame vaø  Actions, söû 
duïng caùc nuùt trong thanh Launcher ôû beân döôùi cöûa soå chöông trình.  

Baïn coù theå nhoùm caùc baûng naøy laïi vôùi nhau theo caùch xeáp ñaët tuøy choïn vaø baïn coù theå löu 
caùc baûng tuøy choïn naøy. Baïn cuõng coù theå thieát laäp, xeáp ñaët caùc baûng naøy trôû laïi cheá ñoä hieån thò 
maëc ñònh (hieån thò baûng  Info, Mixer, Character vaø Instance sang beân phaûi cuûa cöûa soå giao dieän) 
hoaëc xeáp ñaët tuøy choïn khi baïn löu laïi tröôùc ñoù.  

           Haàu heát caùc baûng trong trình ñôn phuï ñeàu coù theâm caùc tuøy choïn boå sung. Khi nhaáp 
chuoät vaøo hình tam giaùc taïi goùc phaûi treân trong baûng seõ xuaát hieän trình ñôn phuï tuøy choïn.  

Chuù yù : Neáu hình tam giaùc bò môø ñi thì baûng ñoù khoâng coù caùc tuøy choïn.                                                    
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Baûng khoâng coù tuøy choïn vaø baûng coù tuøy choïn 

 Môû moät baûng : Choïn treân trình ñôn Window > Panels vaø choïn baûng mong muoán coù trong 
danh saùch.  

 Ñoùng moät baûng,  thöïc hieän moät trong nhöõng böôùc sau. 

Nhaáp chuoät vaøo hoäp Close taïi goùc phaûi phía treân (trong Windows) hoaëc taïi goùc 
traùi phía treân (trong Macintosh). 

♦ 

 
Choïn treân trình ñôn Window > Panels vaø choïn baûng muoán ñoùng. ♦ 

 
Nhaáp phaûi chuoät (trong Windows) hoaëc nhaáp phaûi Control (trong Macintosh) vaø 
choïn Close Panel trong trình ñôn ngöõ caûnh. 

♦ 

 Môû hoaëc ñoùng baûng duøng thanh Launcher: 
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Trong thanh Launcher, nhaáp chuoät vaøo nuùt trong baûng Info, Color Mixer, Character, 
Instance hoaëc Actions.  

Chuù yù : Baïn coù theå môû hoaëc ñoùng cöûa soå Library hay Movie Explorer  baèng caùch duøng thanh 
Launcher.  

 
Thanh Launcher 

 Söû duïng baûng trình ñôn  phuï Options: 

1. Nhaáp chuoät vaøo tam giaùc taïi goùc phaûi phía treân ñeå hieån thò trình ñôn. 

    
2. Nhaáp chuoät vaøo moät muïc choïn trong trình ñôn naøy. 

 Ñoùng taát caû caùc baûng : Choïn trong trình ñôn Window > Close All Panels.  

 Nhoùm laïi caùc baûng :  Keùo tab cuûa baûng naøy sang tab cuûa baûng khaùc 

      

Nhaáp chuoät vaøo tab Frame trong baûng Instance keùo sang baûng Character 

 Keùo moät baûng trong moät nhoùm baûng sang phía tröôùc :  Nhaáp chuoät vaøo tab cuûa baûng ñoù.  

 Boû nhoùm moät baûng trong cöûa soå ñoäc laäp : Keùo tab cuûa baûng ra beân ngoaøi cöûa soå.  
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Baûng maëc ñònh ban ñaàu  

      
Baûng sau khi keùo tab Swatches, baây giôø tab Swatches laø moät baûng ñoäc laäp 

 Di chuyeån moät baûng hay moät nhoùm baûng :  Keùo tieâu ñeà cuûa baûng hay nhoùm baûng.  

 Löu moät caùch saép xeáp tuøy choïn trong 
baûng:  

Choïn treân trình ñôn Window > Save 
Panel Layout. Nhaäp teân cho vieäc xeáp 
ñaët vaøo khng Name vaø nhaáp chuoät vaøo 
nuùt  OK.  

 

 Xoaù moät söï saép xeáp tuøy choïn. 

Môû thö muïc chöông trình Flash 5 trong ñóa cöùng cuûa baïn vaø xoùa file Panel Sets.  

 Choïn caùch  xeáp ñaët moät baûng. 

1. Choïn treân trình ñôn Window > Panel Sets. 

 

2. Töø trong trình ñôn phuï, choïn Default Layout ñeå thieát laäp taát caû caùc baûng theo 
caùch saép xeáp hay choïn caùch saép xeáp tuøy choïn maø baïn löu laïi tröôùc ñoù.  

 Thay ñoåi kích thöôùc baûng :  Keùo chuoät taïi goùc phaûi döôùi cuûa baûng (trong Windows) hoaëc 
keùo hoäp Size taïi goùc phaûi döôùi cuûa baûng  (trong Macintosh).  
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 Thu bôùt moät baûng hay moät nhoùm baûng chæ coøn laïi thanh tieâu ñeà hoaëc tab :  Nhaáp ñuùp 
chuoät vaøo thanh tieâu ñeà trong baûng. Nhaáp ñuùp chuoät vaøo thanh tieâu ñeà cuûa baûng hay moät 
nhoùm baûng moät laàn nöõa ñeå traû baûng veà traïng thaùi bình thöôøng vôùi kích thöôùc tröôùc ñoù.  

     

CAÙCH DUØNG TRÌNH ÑÔN CONTEXT (NGÖÕ CAÛNH) 

Trình ñôn Context goàm coù caùc leänh 
lieân quan ñeán vuøng choïn hieän haønh.  

Ví duï nhö, khi choïn moät frame trong 
cöûa soå Timeline, trình ñôn Context goàm coù caùc 
leänh taïo, xoaù vaø hieäu chænh caùc frame vaø 
keyframe ñoù. 

 Môû moät trình ñôn Context 

Nhaáp phaûi chuoät (trong Windows) hoaëc 
nhaáp Control (trong Macintosh) trong 
vuøng Timeline taïi cöûa soå Library hoaëc 
trong vuøng Stage.  

 

 
Trình ñôn Context cho frame ñöôïc choïn 

CAÙCH DUØNG THANH THÖÔÙC THÔØI GIAN TIMELINE 

Thanh thöôùc Timeline saép xeáp vaø ñieàu khieån noäi dung cuûa ñoaïn phim trong caùc Layer vaø 
caùc frame. Coâng cuï chính cuûa thanh thöôùc Timeline laø caùc Layer, frame vaø playhead.  

Caùc Layer trong ñoaïn phim ôû phaàn ñaàu cuûa thanh thöôùc Timeline ñöôïc hieån thò thaønh coät 
beân traùi cuûa Timeline. Trong  Frame coù caùc Layer xuaát hieän thaønh coät beân phaûi cuûa teân Layer. 
ÔÛ ñaàu cuûa thanh thöôùc Timeline chæ ra soá löôïng frame coù trong ñoaïn phim.   

Nuùt Playhead chæ ra frame hieän haønh ñang hieån thò trong vuøng Stage. Vuøng traïng thaùi 
thanh thöôùc Timeline (ôû beân döôùi cuûa thanh thöôùc) hieån thò soá frame hieän haønh, soá frame trong 
moät giaây vaø thôøi gian döï tính dieãn hoaït trong frame hieän haønh.  

Chuù yù :   Khi aûnh chuyeån ñoäng, tæ soá frame thaät ñöôïc hieån thò. Ñieàu naøy coù theå khaùc bieät vôùi tæ 
soá frame trong ñoaïn phim neáu maùy tính khoâng theå hieån thò ñaày ñuû cheá ñoä chuyeån ñoäng.  
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Baïn coù theå thay ñoåi caùch thöùc caùc frame hieån thò vaø hieån thò noäi dung aûnh cuûa frame 
trong thanh thöôùc Timeline. Thanh thöôùc Timeline hieån thò vuøng giôùi haïn chuyeån ñoäng trong 
ñoaïn phim, bao goàm töøng frame chuyeån ñoäng naøy sang frame khaùc (frame-by-frame animation). 
Ñeå bieát theâm chi tieát, baïn coù theå tham khaûo muïc “Caùch Taïo Ra Ñoaïn Phim Chuyeån Ñoäng” 
muïc Tweened Animation vaø ñöôøng daãn chuyeån ñoäng. Caùc ñieàu khieån trong vuøng choïn Layer  
trong thanh thöôùc Timeline cho pheùp baïn laøm aån hoaëc hieän, khoaù (Lock), môû khoaù (Unlock) 
hoaëc hieån thò noäi dung cuûa Layer ñoù leân maøn hình.  

Ngoaøi ra baïn cuõng coù theå cheøn, xoaù, choïn, di chuyeån frame trong thanh thöôùc Timeline. 
Baïn coù theå keùo caùc frame sang vò trí môùi treân cuøng moät Layer hay Layer khaùc.  

THAY ÑOÅI VUØNG HIEÅN THÒ CUÛA THANH THÖÔÙC TIMELINE  

Theo maëc ñònh, thanh thöôùc Timeline hieån thò phía treân cöûa soå giao dieän chính cuûa 
chöông trình, beân treân vuøng Stage. Ñeå thay ñoåi vò trí baïn coù theå keùo thanh thöôùc Timeline 
xuoáng döôùi hoaëc sang hai beân trong cöûa soå. Hôn nöõa, cuõng coù theå daáu thanh thöôùc Timeline 
naøy.  

Baïn coù theå ñònh vò laïi kích thöôùc thanh thöôùc Timeline nhaèm thay ñoåi soá löôïng frame vaø 
Layer hieån thò. Khi coù nhieàu Layer hieån thò trong thanh thöôùc, luùc ñoù baïn coù theå duøng thanh 
cuoän beân phaûi cuûa Timeline.  

 Di chuyeån thanh thöôùc Timeline :  Keùo chuoät taïi vuøng beân treân ñaàu Timeline.  Keùo 
thanh thöôùc Timeline ñeán caùc goùc cuûa cöûa soå chöông trình. 

 Môû roäng hay thu nhoû vuøng teân cuûa Layer :  Keùo thanh bar taùch bieät teân cuûa Layer vaø 
frame ñònh vò treân Timeline.  

 Thay ñoåi kích thöôùc Timeline, thöïc hieän moät trong nhöõng böôùc sau : Neáu thanh thöôùc 
Timeline ñöôïc gaén vaøo trong cöûa soå öùng duïng chính, baïn haõy keùo thanh bar treân thanh 
thöôùc Timeline taùch bieät khoûi cöûa soå öùng duïng naøy. 

TUÛ  SAÙCH STK – THEÁ GIÔÙI ÑOÀ HOÏA                                                                                                     BIEÂN SOAÏN : KS PHAÏM QUANG HUY 21 



GIAÙO TRÌNH THIEÁT KEÁ WEB :  PHAÀN LYÙ THUYEÁT - TÖÏ HOÏC MACROMEDIA FLASH 5.0 BAÈNG HÌNH AÛNH                 CHÖÔNG 1 
 

Neáu thanh thöôùc Timeline khoâng ñöôïc gaén vaøo trong cöûa soå öùng duïng chính, baïn haõy 
keùo thanh bar treân thanh thöôùc Timeline xuoáng goùc phaûi thaáp beân döôùi (trong Windows) hoaëc 
hoäp Size taïi goùc phaûi döôùi (trong Macintosh). 

DI CHUYEÅN NUÙT (ÑAÀU) PLAYHEAD  

Nuùt Playhead di chuyeån ngang qua thanh thöôùc Timeline cho bieát frame hieän haønh ñang 
hieån thò treân Stage. Ñaàu thanh thöôùc Timeline hieån thò soá löôïng frame chuyeån ñoäng. Ñeå hieån thò 
frame trong vuøng Stage, haõy di chuyeån nuùt Playhead sang moät frame trong Timeline.  

Khi baïn laøm vieäc treân moät soá löôïng frame quaù lôùn, baïn khoâng theå cho taát caû chuùng hieän 
thò leân treân thanh thöôùc Timeline cuøng moät luùc, baïn phaûi ñaët nuùt Playhead vaøo giöõa thanh thöôùc 
Timeline ñeå ñònh vò frame hieän haønh deã daøng.  

 Di chuyeån ñeán moät frame : Nhaáp chuoät vaøo trong vò trí frame trong vuøng ñaàu cuûa thanh 
thöôùc Timeline hoaëc keùo nuùt Playhead sang vò trí mong muoán.  

 

Ñaët Playhead ôû chính giöõa ñoaïn phim : Nhaáp chuoät vaøo trong nuùt Center Frame taïi 
phía döôùi thanh thöôùc Timeline.  

THAY ÑOÅI CAÙCH HIEÅN THÒ FRAME TRONG THANH THÖÔÙC TIMELINE  

Baïn coù theå thay ñoåi kích thöôùc cuûa frame trong thanh thöôùc Timeline vaø hieån thò caùc 
frame lieân tuïc vôùi caùc oâ maøu toâ. Ngoaøi ra, baïn coù theå xem caùc aûnh trong frame taïi thanh thöôùc 
Timeline. Nhöõng aûnh naøy coù raát ít khi baïn xem caùc aûnh ñoäng nhöng chuùng chieám nhieàu khoaûng 
troáng treân maøn hình.  

 Thay ñoåi vuøng frame hieån thò trong thanh  thöôùc Timeline. 

1. Nhaáp chuoät vaøo nuùt Frame View taïi goùc phaûi phía treân cuûa Timeline ñeå choïn cheá ñoä 
xem Frame. 

Choïn moät trong nhöõng tuøy choïn sau: 

 Thay ñoåi ñoä roäng cuûa oâ frame, choïn Tiny, Small, Normal, Medium hoaëc Large. 
(Thieát laäp ñoä roäng trong frame vôùi muïc choïn Large coù ích cho vieäc xem caùc chi 
tieát cuûa soùng aâm thanh). 

 Giaûm ñoä cao cuûa haøng coät frame, choïn Short. 

 Taét hoaëc môû cheá ñoä toâ maøu cho caùc frame, choïn muïc  Tinted Frames. 

2. Hieån thò noäi dung cuûa aûnh trong frame coù tæ leä thích hôïp vôùi caùc frame trong thanh thöôùc 
Timeline, choïn muïc Preview. 
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 Hieån thò aûnh ñaày ñuû trong moãi frame (keå caû 

caùc khoaûng troáng), choïn Preview in 
Context. Cheá ñoä xem tröôùc nhoû hôn tuøy 
choïn Preview. 

 Trình ñôn phuï Frame View.  

 
 Tuøy choïn Preview vaø Preview in Context 
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TAÏO RA TEÂN CHO FRAME VAØ LÔØI CHUÙ THÍCH CHO ÑOAÏN PHIM 

Ñaët teân cho Frame raát coù ích cho vieäc nhaän bieát ñöôïc keyframe trong thanh thöôùc 
Timeline vaø ñöôïc duøng thay cho soá löôïng frame khi frame coù keát quaû trong  moät action laø Go 
To.  

Neáu baïn theâm vaøo hay boû ñi  frame, teân treân frame cuõng seõ di chuyeån theo vì frame vaø 
teân ñöôïc gaén lieàn vôùi nhau baát cöù khi naøo soá löôïng frame thay ñoåi. Do vieäc ñaët teân cho Frame 
xuaát ra trong vuøng döõ lieäu vì vaäy traùnh vieäc ñaët teân quaù daøi ñeå taïo ra kích thöôùc file nhoû.  

Lôøi chuù thích cho frame raát coù ích cho vieäc nhaän bieát ghi chuù cho frame cuûa baïn vaø 
frame cuûa ngöôøi khaùc khi laøm cuøng moät ñoaïn phim. Do lôøi chuù thích cho frame khoâng ñöôïc xuaát 
ra ngoaøi vuøng döõ lieäu, vì vaäy baïn coù theå taïo ra chuùng nhö mong muoán.  

 Caùch taïo ra teân cho frame vaø lôøi chuù thích  

1. Choïn moät frame baát kyø vaø sau ñoù choïn treân trình ñôn Window > Panels > 
Frame. 

2. Trong baûng Frame,  nhaäp vaøo teân 
frame hoaëc lôøi chuù thích cho frame 
trong hoäp Label.  Taïo ra moät ñoaïn 
chuù thích, neân nhaäp  hai daáu gaïch 
xieân taïi moãi ñaàu haøng cuûa ñoaïn 
chuù thích. 

 

LAØM VIEÄC VÔÙI CAÙC FRAME TRONG THANH THÖÔÙC TIMELINE  

Baïn seõ laøm vieäc vôùi caùc frame vaø keyframe trong thanh thöôùc Timeline. Moät keyframe 
laø moät frame maø baïn xaùc ñònh moät thay ñoåi vuøng chuyeån ñoäng hoaëc caùc action cho moät frame 
nhaèm thay ñoåi ñoaïn phim.  

Caùc keyframe laø moät phaàn raát quan troïng cuûa cheá ñoä Tweened Animation. Baïn coù theå 
thay ñoåi chieàu daøi cuûa Tweened Animation baèng caùch keùo moät keyframe trong thanh thöôùc 
Timeline.  

 Baïn coù theå thöïc hieän caùc böôùc thay ñoåi sau ñaây treân frame  hoaëc keyframe 

 Baïn coù theå cheøn (Insert), choïn (Select), xoaù (Delete)  vaø di chuyeån (Move) frame 
hay keyframe. 

 Keùo frame hoaëc keyframe sang vò trí môùi treân cuøng moät Layer hoaëc sang Layer 
khaùc.  

 Sao cheùp vaø daùn  frame hay keyframe.  

 Bieán ñoåi  keyframe thaønh frame. 

 Keùo moät muïc trong cöûa soå Library vaøo trong Stage ñeå theâm muïc ñoù vaøo trong 
keyframe hieän haønh. 

Thanh thöôùc Timeline taïo ra caùc frame chuyeån ñoäng. Ñeå bieát theâm chi tieát, caùc baïn coù 
theå tham khaûo muïc “Caùch taïo ra phaàn chuyeån ñoäng”.  

TUÛ  SAÙCH STK – THEÁ GIÔÙI ÑOÀ HOÏA                                                                                                     BIEÂN SOAÏN : KS PHAÏM QUANG HUY 24 



GIAÙO TRÌNH THIEÁT KEÁ WEB :  PHAÀN LYÙ THUYEÁT - TÖÏ HOÏC MACROMEDIA FLASH 5.0 BAÈNG HÌNH AÛNH                 CHÖÔNG 1 
 

Ñeå cheøn caùc frame trong thanh thöôùc Timeline, baïn haõy thöïc hieän moät trong nhöõng thao 
taùc sau ñaây:  

 Cheøn moät frame môùi, choïn treân trình ñôn Insert > Frame. 

 Taïo moät keyframe môùi, choïn trình ñôn 
Insert > Keyframe hoaëc nhaáp phaûi chuoät 
(trong Windows) hay nhaáp Control (trong 
Macintosh) cho frame nôi baïn muoán ñaët vaøo 
moät keyframe. Sau ñoù choïn leänh Insert 
Keyframe coù trong trình ñôn Context. 

 

 

 Taïo moät keyframe troáng môùi, choïn trong 
trình ñôn Insert > Blank Keyframe hoaëc 
nhaáp phaûi chuoät (trong Windows) hay nhaáp 
Control (trong Macintosh). Choïn frame nôi 
baïn muoán ñaët keyframe vaøo, sau ñoù choïn 
leänh Insert Blank Keyframe trong trình ñôn 
Context. 

 
 

 Hieäu chænh hoaëc xoaù moät keyframe hoaëc frame, thöïc hieän moät trong nhöõng thao taùc 
sau  

Baïn coù theå xoaù moät frame, keyframe hoaëc moät chuoãi caùc frame, baèng caùch choïn frame, 
keyframe hoaëc moät chuoãi frame. Sau ñoù choïn treân trình ñôn Insert > Remove Frame hoaëc 
nhaáp phaûi chuoät (trong Windows) hay nhaáp Control (trong Macintosh). Choïn frame, keyframe 
hay chuoãi frame. Sau ñoù choïn leänh Remove Frame trong trình ñôn Context. Caùc frame xung 
quanh vaãn khoâng thay ñoåi.  

 Di chuyeån moät frame hay chuoãi keyframe cuøng vôùi noäi dung cuûa noù, baïn haõy keùo 
frame hay chuoãi keyframe sang vò trí mong muoán.  

 

 Keùo daøi thôøi gian cuûa moät keyframe, baïn coù theå nhaán phím Alt vaø keùo (trong 
Windows) hoaëc nhaán phím action (Macintosh) vaø keùo keyframe ñeán frame cuoái 
cuøng cuûa chu kyø thôøi gian môùi.  

 Sao cheùp moät keyframe hay chuoãi frame baèng caùch keùo, nhaán phím Alt vaø nhaáp  
chuoät (trong Windows) hoaëc nhaán phím Option (trong Macintosh) vaø keùo 
keyframe sang vò trí môùi. 

 Sao cheùp vaø daùn moät keyframe hay chuoãi frame baèng caùch choïn ra frame hay 
chuoãi  keyframe vaø choïn trình ñôn Edit > Copy Frames. Choïn frame maø baïn 
muoán thay theá, sau ñoù choïn treân trình ñôn Edit > Paste Frames. 
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 Chuyeån ñoåi moät  keyframe thaønh moät frame 
baèng caùch choïn trình ñôn Insert > Clear 
Keyframe hoaëc nhaáp phaûi chuoät (trong 
Windows) hay nhaáp Control (trong 
Macintosh) trong keyframe vaø choïn leänh 
Clear Keyframe trong trình ñôn Context. 
Keyframe bò xoùa vaø taát caû caùc frame taêng leân 
keyframe ñöôïc thay theá baèng noäi dung cuûa 
frame ñöùng tröôùc keyframe bò  xoaù.   

 Thay ñoåi kích thöôùc chieàu daøi cuûa chuoãi chuyeån ñoäng Tweened Sequence, keùo 
keyframe baét ñaàu hay keyframe cuoái cuøng sang traùi hay phaûi. Thay ñoåi ñoä daøi cuûa 
moät chuoãi frame-by-frame. Baïn coù theå xem muïc “Caùch taïo ra caùc frame by frame 
Animation”. 

 Theâm moät muïc trong thö vieän vaøo keyframe hieän haønh, keùo muïc ñoù trong cöûa soå 
Library vaøo trong vuøng Stage. 

CAÙCH DUØNG SCENE 

Ñeå toå chöùc moät ñoaïn phim coù chuû ñeà, baïn coù theå duøng caùc Scene (caûnh trong phim). Ví 
duï nhö baïn coù theå duøng caùc Scene rieâng bieät cho caùc muïc giôùi thieäu (Introduction), lôøi thoâng 
baùo cho vieäc truy caäp (Loading Message) v.v. . .  

Khi baïn xuaát moät ñoaïn phím trong Flash, ñoaïn phim naøy coù nhieàu Scene, caùc Scene  
trong file SWF phaùt laïi moät caûnh ñeå chuùng ñöôïc hieån thò trong baûng Scene trong file FLA. Caùc 
frame trong file SWF ñöôïc ñaùnh soá  lieân tieáp qua caùc Scene. Ví duï, neáu moät ñoaïn phim coù 2 
Scene vôùi moãi Scene coù 10 frame vaø soá frame trong Scene thöù hai ñöôïc ñaùnh soá töø 11-20.  

 Baïn coù theå theâm, xoaù, sao cheùp, 
ñoåi teân vaø thay ñoåi thöù töï cuûa caùc 
Scene.  

 

 
Baûng Scene 

 Baïn duøng caùc actions cho vieäc döøng haún ñoaïn phim hoaëc taïm döøng ñoaïn phim sau 
moãi Scene hay cho pheùp ngöôøi duøng ñieàu khieån ñoaïn phim theo yù muoán. 

 Caùch hieån thò baûng Scene : Choïn trình ñôn  Window > Panels > Scene.  

 Xem moät Scene ñaët bieät : Choïn treân trình ñôn View > Goto sau ñoù choïn teân Scene 
trong trình ñôn phuï.  

 Theâm vaøo moät Scene, thöïc hieän moät trong nhöõng thao taùc sau:  
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♦ 

♦ 

Nhaáp chuoät vaøo nuùt Add 
Scene trong baûng Scene,  

hoaëc 

Choïn trong trình ñôn  Insert 
> Scene. 

 

 

 Xoaù moät Scene, thöïc hieän moät trong nhöõng thao taùc sau: 

♦ 

♦ 

Nhaáp chuoät vaøo nuùt  Delete 
Scene trong baûng Scene,  

hoaëc 

Môû moät Scene baïn muoán 
xoùa vaø sau ñoù choïn treân 
trình ñôn Insert > Remove 
Scene.  

  

 Thay ñoåi teân cuûa Scene 

Nhaáp ñuùp chuoät vaøo teân cuûa 
Scene trong baûng Scene vaø 
nhaäp vaøo teân môùi. 

 

 

 Sao cheùp moät Scene : Nhaáp chuoät vaøo nuùt Duplicate Scene trong baûng Scene.  

 Thay ñoåi traät töï cuûa moät Scene trong ñoaïn phim : Keùo teân cuûa Scene sang vò trí khaùc 
trong baûng Scene.  

CAÙCH DUØNG THÖ VIEÄN LIBRARY  

Thö vieän trong Flash löu laïi caùc bieåu töôïng ñöôïc taïo ra trong Flash vaø töø caùc chöông 
trình khaùc ñöa vaøo trong Flash. Chuùng cho pheùp baïn xem vaø saép xeáp nhöõng file naøy khi laøm 
vieäc. Cöûa soå Library hieån thò moät thanh cuoän hieån thò danh saùch caùc teân cuûa nhöõng muïc coù trong 
thö vieän. Bieåu töôïng keá beân teân cuûa muïc trong cöûa soå thö vieän cho bieát loaïi file cuûa muïc ñoù. 
Khi choïn moät muïc trong cöûa soå Library, aûnh nhoû cuûa muïc xuaát hieän treân ñænh cuûa cöûa soå 
Library. Neáu muïc choïn laø file aûnh hoaëc file aâm thanh, baïn coù theå duøng nuùt Play trong cöûa soå 
xem tröôùc Library hoaëc Controller ñeå xem tröôùc muïc choïn. Baïn coù theå saép xeáp caùc muïc trong 
thö vieän. Caùc coät trong cöûa soå Library hieån thò teân, loaïi file, soá laàn ñöôïc söû duïng trong file. Baïn 
coù theå saép xeáp  caùc muïc  trong cöûa soå Library theo baát kyø coät naøo. Cöûa soå Library coù trình ñôn 
Options vôùi caùc tuøy choïn hieäu chænh caùc muïc trong thö vieän. Ñeå hieäu chænh caùc muïc trong thö 
vieän goàm coù nhaäp file, coù theå choïn caùc tuøy choïn trong trình ñôn Library Options. Baïn coù theå caäp 
nhaät caùc file sau khi hieäu chænh vaø duøng tuøy choïn Update trong trình ñôn Library Options.  
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Baïn coù theå môû thö vieän cuûa baát kyø file Flash FLA  naøo trong khi baïn ñang laøm vieäc trong 
Flash ñeå taïo caùc muïc trong thö vieän trôû thaønh file coù saün thaønh ñoaïn phim hieän haønh. Baïn coù 
theå taïo ra caùc thö vieän taïm thôøi trong chöông trình Flash. Ngoaøi ra thö vieän coù saün caùc nuùt, aûnh 
ñoà hoïa, caùc Clip phim, aâm thanh maø baïn coù theå theâm vaøo ñoaïn phim trong Flash. Caùc thö vieän 
taïm thôøi, baïn coù theå taïo ra ñöôïc hieån thò  trong trình ñôn Window > Common Libraries.  

 

Baïn coù theå xuaát moät thö vieän sang ñòa chæ URL nhaèm taïo ra thö vieän chia seû, cho pheùp 
baïn keát noái  taøi nguyeân trong thö vieän töø baát kyø ñoaïn phim Flash naøo. 

Ñeå hieån thò cöûa soå Library, baïn haõy thöïc hieän moät trong nhöõng böôùc sau ñaây:  

 Choïn trong trình ñôn Window > Library. 
Hoaëc nhaáp chuoät vaøo nuùt Library trong 
thanh Launcher taïi goùc phaûi beân döôùi cuûa 
cöûa soå giao dieän.  

 Caùch duøng muïc Item trong ñoaïn phim hieän haønh :  Keùo muïc Item trong cöûa soå Library 
vaøo vuøng Stage. Muïc Item ñoù ñöôïc theâm vaøo trong  Layer hieän haønh.  

1. Môû thö vieän töø trong moät file Flash. 

2. Choïn trình ñôn File > Open as Library. 

Choïn file Flash baïn muoán môû taïi thö vieän, sau ñoù nhaáp chuoät vaøo nuùt Open. 

Cöûa soå cuûa file ñöôïc choïn môû trong ñoaïn phim hieän haønh vôùi teân cuûa file ñoù xuaát 
hieän ôû phía treân cuøng trong cöûa soå Library. Ñeå söû duïng caùc muïc coù trong cöûa soå 
Library vaøo trong ñoaïn phim hieän haønh, baïn chæ vieäc keùo muïc choïn ñoù vaø thaû vaøo 
trong cöûa soå thö vieän cuûa ñoaïn phim hieän haønh. 
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 Thay ñoåi kích thöôùc cöûa soå Library, baïn haõy thöïc hieän moät trong nhöõng thao taùc sau ñaây 

 Keùo chuoät taïi goùc phaûi phía döôùi trong cöûa soå thö vieän Library. 

            

 Nhaáp chuoät vaøo nuùt Wide State ñeå môû roäng cöûa soå Library nhaèm hieån thò taát caû 
caùc coät trong cöûa soå. 

 

Vuøng cöûa soå Library xuaát hieän roäng ra sau khi nhaáp chuoät vaøo nuùt Wide State 

 Nhaáp chuoät vaøo nuùt Narrow State ñeå laøm giaûm ñoä roäng cuûa cöûa soå. 
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Khi nhaáp chuoät vaøo nuùt Narrow State (1), sau khi nhaáp chuoät vaøo nuùt Narrow State (2) 

 Thay ñoåi ñoä roäng cuûa caùc coät 

 Ñaët vò trí con troû chính giöõa caùc tieâu ñeà cuûa 
coät vaø keùo ñeå thay ñoåi kích thöôùc caùc coät. 
Baïn khoâng theå thay ñoåi thöù töï cuûa caùc coät 
naøy.  

 

 

 Söû duïng tuøy choïn trong trình ñôn Library Options 

 Nhaáp chuoät vaøo bieåu töôïng tam giaùc taïi goùc phaûi phía treân cuûa cöûa soå Library ñeå 
hieån thò trình ñôn phuï Options. 

    
Nhaáp chuoät vaøo nuùt Options ñeå xuaát hieän caùc tuøy choïn coù trong ñoù nhö hình treân 

 Nhaáp chuoät vaøo moät muïc coù trong trình ñôn. 
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LAØM VIEÄC VÔÙI CAÙC THÖ  MUÏC TRONG CÖÛA SOÅ LIBRARY 

Baïn coù theå saép xeáp caùc muïc trong cöûa soå Library söû duïng caùc thö muïc gioáng nhö chöông 
trình Windows Explorer  hoaëc Macintosh Finder. Khi taïo ra moät bieåu töôïng môùi, noù ñöôïc löu laïi 
vaøo trong thö muïc ñöôïc choïn. Neáu chöa choïn thö muïc, bieåu töôïng naøy ñöôïc löu taïi thö muïc goác 
cuûa thö vieän.  

 Caùch  taïo ra moät thö muïc môùi 

 Nhaáp chuoät vaøo nuùt New Folder trong cöûa soå 
Library.  

 

 

 Di chuyeån moät muïc giöaõ caùc thö muïc :  Keùo noù töø moät thö muïc naøy sang moät thö muïc 
khaùc.  

 Môû hay ñoùng moät thö muïc, baïn haõy thöïc hieän moät trong hai thao taùc sau: 

• Nhaáp ñuùp chuoät vaøo trong thö muïc ñoù. 

• Choïn moät thö muïc vaø choïn Expand Folder hoaëc Collapse Folder trong trình ñôn  
Library Options. 

      
Nhaáp chuoät vaøo trình ñôn Options, trình ñôn Options xuaát hieän 

SAÉP XEÁP CAÙC MUÏC ITEM TRONG CÖÛA SOÅ LIBRARY  

Baïn coù theå saép xeáp caùc muïc naøy thaønh coät trong cöûa 
soå Library theo thöù töï baûng chöõ caùi. Vieäc saép xeáp caùc muïc 
naøy cho pheùp baïn xem ñöôïc caùc thö muïc coù lieân quan vôùi 
nhau. Caùc muïc naøy ñöôïc saép xeáp vaøo trong caùc thö muïc. 

 Saép xeáp caùc muïc trong cöûa soå Library :  Nhaáp chuoät 
vaøo ñaàu tieâu ñeà trong coät ñoù. Nhaáp chuoät vaøo nuùt 
tam giaùc ñeå ñaûo ngöôïc traät töï saép xeáp ñoù.  

 

HIEÄU CHÆNH CAÙC MUÏC TRONG LIBRARY  

Baïn coù theå hieäu chænh caùc muïc trong  thö vieän trong Flash hoaëc trong tröôøng hôïp caùc file  
nhaäp vaøo. 

Caùch hieäu chænh moät muïc trong thö vieän   

1. Choïn moät muïc trong cöûa soå Library. 
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2. Choïn moät trong nhöõng tuøy choïn coù trong 
trình ñôn Library Options: 

• Choïn leänh Edit ñeå hieäu chænh moät muïc 
trong Flash. 

• Choïn leänh Edit With vaø choïn moät chöông 
trình ñeå hieäu chænh muïc choïn trong moät 
chöông trình boå sung.  

 

 

ÑOÅI TEÂN CAÙC MUÏC TRONG THÖ VIEÄN 

Baïn coù theå ñoåi teân caùc muïc coù trong thö vieän. Vieäc thay ñoåi teân cuûa caùc muïc trong thö 
vieän cuûa file nhaäp vaøo seõ khoâng laøm thay ñoåi teân cuûa file.  

 Caùch ñoåi teân  moät muïc trong thö vieän, baïn haõy thöïc hieän moät trong caùc böôùc sau:  

 Nhaáp ñuùp chuoät vaøo teân muïc choïn vaø nhaáp vaøo teân môùi. 

         

 Choïn moät muïc Item vaø nhaáp chuoät vaøo bieåu töôïng caùc thuoäc tính taïi beân döôùi cöûa 
soå Library. Nhaäp vaøo teân môùi trong hoäp thoaïi Symbol Properties vaø sau ñoù nhaáp 
chuoät vaøo nuùt OK. 

 

 Choïn moät muïc  Item vaø choïn trong trình ñôn Library Options leänh Rename vaø sau 
ñoù nhaäp teân môùi vaøo trong hoäp thoaïi. 
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Choïn leänh Rename trong trình ñôn Options 

 

 Nhaáp phaûi chuoät (trong Windows) 
hoaëc  nhaáp Control  (trong 
Macintosh) taïi item vaø choïn leänh 
Rename trong trình ñôn ngöõ caûnh, 
vaø sau ñoù nhaäp teân môùi vaøo vuøng 
vaên baûn. 

 

 

XOAÙ CAÙC MUÏC ITEM TRONG THÖ VIEÄN   

Khi baïn xoaù moät muïc Item khoûi thö vieän, 
taát caû caùc Instance hoaëc caùc Occurrence (söï kieän) 
cuûa moät muïc Item trong ñoaïn phim cuõng bò xoaù. 
Coät Use Count trong cöûa soå Library  cho bieát  Item 
ñoùù ñang trong tình traïng duøng hay khoâng.  

 Xoaù moät muïc Item trong thö vieän:  
Choïn moät muïc Item vaø nhaáp chuoät 
vaøo bieåu töôïng hoäp raùc ( ) ôû beân 
döôùi cöûa soå Library. 

 

 

TÌM CAÙC MUÏC ITEM  CHÖA DUØNG TRONG THÖ VIEÄN  

Ñeå laøm giaûm kích thöôùc cuûa file FLA trong Flash, baïn coù theå xaùc ñònh caùc muïc Item 
chöa duøng ñeán trong thö vieän vaø xoaù. Tuy nhieân, khoâng caàn thieát ñeå xoaù caùc muïc Item chöa 
duøng ñeán trong thö vieän ñeå laøm giaûm kích thöôùc file SWF cuûa ñoaïn phim trong Flash vì caùc muïc 
Item chöa duøng trong thö vieän khoâng coù file SWF.  
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 Tìm caùc muïc Item chöa duøng trong thö vieän: 

• Choïn Select Unused Items trong trình 
ñôn Library Options. 

• Saép xeáp caùc muïc trong thö vieän baèng 
caùch duøng coät Use Count. Baïn coù theå 
xem muïc “ Caùch saép xeáp caùc muïc Item 
trong cöûa soå Library”. 

 

CAÄP NHAÄT CAÙC FILE NHAÄP VAØO TRONG CÖÛA SOÅ LIBRARY 

Neáu baïn duøng moät trình soaïn thaûo môû roäng  ñeå hieäu chænh file baïn vöøa nhaäp vaøo Flash 
nhö file aûnh Bitmap hoaëc file aâm thanh, baïn coù theå caäp nhaät  caùc file trong Flash maø khoâng caàn 
nhaäp laïi.  

 Caùch caäp nhaät file vöøa nhaäp vaøo :  Choïn moät file nhaäp vaøo trong cöûa soå Library vaø choïn 
leänh Update trong trình ñôn Library Options.  

           
Choïn file aûnh caàn nhaäp vaøo sau ñoù choïn trong trình ñôn ngöõ caûnh leänh Update 

LAØM VIEÄC VÔÙI CAÙC THÖ VIEÄN CHUNG (COMMON LIBRARY)  

Baïn coù theå duøng caùc thö vieän ñöôïc caøi ñaët saün coù trong Flash nhö caùc nuùt taïo ra  caùc bieåu 
töôïng, caùc nuùt hoaëc aâm thanh cho ñoaïn phim cuûa baïn. Ngoaøi ra baïn cuõng coù theå taïo ra caùc thö 
vieän taïm thôøi trong chöông trình Flash maø sau ñoù baïn coù theå duøng chuùng trong baát kyø ñoaïn phim 
naøo baïn taïo ra. Taát caû nhöõng loaïi thö vieän naøy ñöôïc hieån thò trong trình ñôn phuï Window > 
Common Libraries.  

 

 Caùch taïo ra moät thö vieän taïm thôøi trong chöông trình Flash cuûa baïn:  

• Taïo moät file Flash vôùi moät thö vieän chöùa caùc bieåu töôïng maø baïn muoán ñaët chuùng 
vaøo thö vieän taïm thôøi. 
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• Ñaët file Flash vaøo trong thö muïc Libraries trong thö muïc chöông trình Flash trong 
ñóa cöùng cuûa baïn 

 Caùch duøng moät muïc töø thö vieän chung trong ñoaïn phim: 

• Choïn trong trình ñôn Window > Common Libraries vaø choïn moät thö vieän  coù 
trong trình ñôn phuï. 

 

• Keùo moät muïc Item töø thö vieän chung vaøo trong thö vieän cuûa ñoaïn phim hieän 
haønh. 

CAÙCH DUØNG CAÙCTHÖ VIEÄN CHIA SEÛ  (SHARED LIBRARY)  

Baïn coù theå taïo ra caùc thö vieän chia seû (Shared Library) ñeå truy caäp töø moät thö vieän trong 
nhieàu ñoaïn phim Flash khaùc nhau. Baïn phaûi xaùc ñònh Shared library truy caäp trong moät phim 
sau ñoù lieân keát chuùng sang nhöõng ñoaïn phim khaùc. Khi baïn lieân keát moät moái truy caäp trong 
Shared Library, moái truy caäp coù theå  chuyeån ñeán moät file beân ngoaøi nhöng file truy caäp khoâng 
ñöôïc theâm vaøo ñoaïn phim. Caùch duøng Shared Library coù theå toái öu hoaù  vuøng laøm vieäc vaø ñoaïn 
phim coù theå ñöôïc truy caäp theo nhieàu caùch khaùc nhau. Ví duï, baïn coù theå duøng Shared Library ñeå 
thöïc hieän caùc böôùc sau:  

• Chia seû moät file aâm thanh qua moät choã.  

• Chia seû moät bieåu töôïng  font qua nhieàu choã.  

• Cung caáp moät nguoàn ñôn leû cho caùc thaønh phaàn chuyeån ñoäng ñöôïc duøng qua 
nhieàu Scene hoaëc ñoaïn phim. 

• Taïo ra thö vieän nguoàn troïng taâm duøng ñeå xem laïi caùc ñieàu khieån vaø caùc Track 
(raõnh ghi).  

TAÏO VAØ LIEÂN KEÁT ÑEÁN CAÙC NGUOÀN TAØI NGUYEÂN ÑÖÔÏC CHIA SEÛ 

Taïo ra moät Shared Library maø baïn coù theå duøng vôùi caùc ñoaïn phim khaùc, baïn phaûi xaùc 
ñònh caùc thuoäc tính keát noái cho caùc muïc Item trong thö vieän cuûa moät ñoaïn phim. Khi löu ñoaïn 
phim, Shared Library cuõng ñöôïc löu vôùi file FLA. 

Ñeå duøng caùc taøi nguyeân trong moät thö vieän Shared Library trong ñoaïn phim khaùc, haõy 
choïn treân trình ñôn File > Open As Shared Library trong ñoaïn phim hieän haønh, vaø choïn file 
Shared Library muoán duøng.   

Thö vieän Shared Library môû moät cöûa soå thö vieän trong ñoaïn phim hieän haønh. Khi ñoù baïn 
coù theå theâm caùc nguoàn taøi nguyeân vaøo ñoaïn phim hieän haønh ñeå taïo ra caùc keát noái ñeán nguoàn taøi 
nguyeân ñoù. Baïn phaûi gôûi moät Shared Library leân trang Web cho ñoaïn phim maø keát noái ñeán 
Shared Library nhaèm hieån thò caùc nguoàn taøi nguyeân ñöôïc keát noái.  
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Caùch gôûi moät Shared Library leân trang Web 

Baïn xuaát ñoaïn phim maø baïn taïo Shared Library. Thuû tuïc naøy gôûi Shared Library ñeán 
URL nôi maø ñoaïn phim SWF ôû ñoù. (Baïn coù theå xaùc ñònh vò trí khaùc cho Shared Library neáu baïn 
muoán). Khi baïn xem moät ñoaïn phim trong Flash  maø coù chöùa caùc keát noái ñeán nguoàn taøi nguyeân 
chia seû, ñoaïn phim naøy truy caäp ñeán Shared Library töø vò trí cuûa noù treân trang Web vaø hieån thò 
caùc nguoàn taøi nguyeân chia seû. Ñoaïn phim taûi xuoáng toaøn boä file trong Shared Library khi noù 
ñeán frame ñaàu tieân chöùa caùc nguoàn taøi nguyeân keát noái. (Neáu ñoaïn phim chöùa caùc nguoàn taøi 
nguyeân keát noái töø nhieàu Shared Library, moãi Shared Library seõ ñöôïc taûi xuoáng ñoäc laäp khi  
nguoàn taøi nguyeân ñaàu tieân trong Shared Library xaûy ra).  

Neáu vieäc taûi Shared Library xuoáng bò loãi, ñoaïn phim seõ khoâng chaïy nöõa, baïn neân giöõ 
caùc Shared Library vôùi kích thöôùc nhoû ñeå vieäc taûi xuoáng deã daøng hôn.  

Xaùc ñònh caùc nguoàn taøi nguyeân trong Shared Library  

Baïn coù theå duøng hoäp thoaïi Symbol Linkage ñeå gaùn caùc thuoäc tính lieân keát toàn taïi trong 
muïc Item taïi thö vieän ñeå xaùc ñònh caùc muïc Item nhö laø caùc nguoàn taøi nguyeân Shared Library. 
Sau khi baïn gaùn caùc thuoäc tính lieân keát ñeán caùc nguoàn taøi nguyeân chia seû, baïn phaûi löu thaønh 
file ñoaïn phim maø baïn xaùc ñònh laø coù duøng nguoàn taøi nguyeân chia seû laïi ñeå laøm cho caùc nguoàn 
taøi nguyeân naøy coù saün lieân keát ñeán caùc ñoaïn phim khaùc trong Flash.  

Ngoaøi ra baïn cuõng coù theå duøng hoäp thoaïi Symbol Linkage ñeå gaùn moät teân ñònh danh cho 
moät ñoaïn phim Movie Clip hoaëc moät file aâm thanh maø baïn muoán xem duøng method (phöông 
thöùc) attachMovie hoaëc attachSound.  

Caùch xaùc ñònh moät nguoàn taøi nguyeân Shared Library  

Tröôùc heát baïn haõy môû moät ñoaïn phim, 
sau ñoù choïn trong trình ñôn Window > 
Library hoaëc  nhaáp chuoät vaøo nuùt Library 
treân thanh Launcher (taïi goùc phaûi döôùi trong 
giao dieän cöûa soå chöông trình) ñeå hieån thò 
cöûa soå Library neáu noù chöa hieån thò. 

 
Nhaáp chuoät vaøo nuùt Show Library beân döôùi cöûa soå 

Choïn moät trong nhöõng thao taùc sau: 

• Choïn moät muïc Item trong cöûa soå Library  vaø 
choïn  leänh Linkage töø trong trình ñôn Library 
Options. 

• Nhaáp phaûi chuoät (trong Windows) hoaëc nhaáp 
Control (trong Macintosh) taïi moät muïc Item 
trong cöûa soå Library vaø choïn leänh Linkage 
trong trình ñôn ngöõ caûnh. 
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3. Trong  hoäp thoaïi Symbol Linkage Properties,  choïn Export this symbol. 

 
4. Trong vuøng vaên baûn Identifier,  nhaäp moät teân ñònh danh cho bieåu töôïng. (Teân ñònh danh 

khoâng coù khoaûng traéng). 

5. Sau ñoù nhaáp chuoät vaøo nuùt OK. 

 
6. Löu ñoaïn phim laïi. 

GÔÛI MOÄT SHARED LIBRARY ÑEÁN MOÄT URL 

Moät thö vieän Shared Library phaûi ñöôïc gôûi ñeán moät URL nhö laø moät file SWF ñeå cho 
caùc nguoàn taøi nguyeân chia seû xuaát hieän trong ñoaïn phim keát noái ñeán nguoàn taøi nguyeân.  

Baïn khoâng phaûi xaùc ñònh moät URL cho moät Shared Library ñeå nhaäp caû thö vieän vaø file 
SWF laïi.  Tuy nhieân, baïn coù theå xaùc ñònh moät URL  khaùc cho  moät file Shared Library ñeå ñaët 
thö vieän vaøo trong vò trí khaùc.  

 Caùch xaùc ñònh moät URL cho moät  Shared Library  

 Trong cöûa soå Library, choïn leänh Shared 
Library Properties töø trong trình ñôn 
Library Options. 

  

 Trong hoäp thoaïi Shared Library Properties, nhaäp teân URL nôi baïn muoán  Shared 
Library ôû ñoù. 
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 Nhaáp chuoät vaøo nuùt  OK 

Lieân keát ñeán nguoàn taøi nguyeân trong moät Shared Library 

Ñeå keát noái ñeán caùc nguoàn taøi nguyeân töø trong ñoaïn phim Flash, baïn haõy môû thö vieän 
Shared Library vaø theâm vaøo caùc muïc Item töø trong Shared Library ñeán thö vieän cuûa ñoaïn phim 
hieän haønh.  

Taïo ra caùc moái lieân keát ñeán nguoàn taøi nguyeân chia seû, baïn môû file FLA cho Shared 
Library.  Khoâng  caàn thieát ñeå Shared Library  thaønh moät file SWF ñeå taïo ra caùc moái lieân keát ñeán 
caùc nguoàn taøi nguyeân ñöôïc chia seû.   

Chuù yù :  Ñeå xem caùc nguoàn taøi nguyeân lieân keát  khi kieåm tra moät ñoaïn phim hoaëc hieån thò caùc 
nguoàn taøi nguyeân lieân keát khi xem ñoaïn phim ñöôïc taïo ra, tröôùc heát phaûi  taïo ra file SWF  cho 
Shared Library.  

 Ñeå keát noái moät nguoàn taøi nguyeân ñeán moät Shared Library  

1. Baïn haõy môû moät file ñoaïn phim,  sau ñoù choïn treân trình ñôn File > Open as Shared 
Library. 

 

2. Choïn thö vieän chia seû maø baïn muoán  môû vaø nhaáp chuoät vaøo nuùt Open. Thö vieän 
Shared Library môû moät cöûa soå Library trong ñoaïn phim hieän haønh. Caùc leänh vaø caùc 
nuùt trong trình ñôn Options taïi cöûa soå Shared Library bò môø ñi cho bieát nhöõng tuøy 
choïn ñoù chöa ñöôïc duøng ñeán.  

 

3. Keát noái nguoàn taøi nguyeân töø thö vieän Shared Library ñeán ñoaïn phim hieän haønh, thöïc 
hieän moät trong nhöõng thao taùc sau: 

• Keùo nguoàn taøi nguyeân töø trong thö vieän Shared Library vaøo trong thö vieän cuûa 
ñoaïn phim hieän haønh.  
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Keùo muïc Clock Pencil trong thö vieän Library Graphics sang thö vieän hieän haønh Library Cirle   

• Keùo nguoàn taøi nguyeân töø trong thö vieän Shared Library vaøo trong Stage. Baây giôø 
teân cuûa nguoàn taøi nguyeân vöøa choïn xuaát hieän trong thö vieän cuûa ñoaïn phim hieän 
haønh. Nguoàn taøi nguyeân naøy ñöôïc keát noái ñeán ñoaïn phim hieän haønh nhö laø moät 
file beân ngoaøi. File naøy khoâng ñöôïc theâm vaøo ñoaïn phim hieän haønh.  

CAÙCH DUØNG MOVIE EXPLORER  

Movie Explorer cung caáp moät phöông phaùp deã daøng giuùp baïn xem vaø saép xeáp noäi dung 
cuûa ñoaïn phim vaø choïn caùc thaønh phaàn thay ñoåi trong ñoaïn phim.  Noù taïo ra nhieàu ñaëc tính     
saép xeáp hôïp lyù trong vuøng laøm vieäc ñeå taïo ra ñoaïn phim.  

Chaúng haïn nhö, baïn coù theå duøng Movie Explorer ñeå thöïc hieän nhöõng coâng vieäc sau:  

 Tìm kieám teân cuûa moät thaønh phaàn trong ñoaïn phim. 

 Hieån thò baûng caùc thuoäc tính cho moät thaønh phaàn ñöôïc choïn ñeå thöïc hieän nhöõng 
thay ñoåi.  

 Laøm quen vôùi caáu truùc cuûa moät ñoaïn phim trong Flash ñöôïc chuyeân vieân thieát keá  
khaùc taïo ra.  

 Tìm taát caû caùc Instance  cuûa moät Symbol hay moät Action ñaët bieät. 

 Thay theá taát caû caùc söï kieän cuûa  moät font baèng font khaùc.  

 Xem teân caëp giaù trò cho Macromedia Generator Objects. 

 Sao cheùp ñoaïn vaên baûn sang Clipboard vaø daùn vaøo trong trình soaïn thaûo beân 
ngoaøi giuùp cho vieäc kieåm loãi chính taû. 

Movie Explorer coù moät danh saùch hieån thò, moät danh saùch cuûa noäi dung ñoaïn phim ñöôïc 
saép xeáp nhö moät caây coù thöù töï. Baïn coù theå  choïn caùc  loaïi trong muïc Item trong ñoaïn phim  ñöôïc 
hieån thò taïi  Movie Explorer,  choïn töø vaên baûn, aûnh ñoà hoïa, nuùt, ñoaïn phim Movie Clip, Actions, 
caùc file ñöôïc nhaäp vaøo vaø Generator Objects.  

Baïn coù theå hieån thò caùc loaïi ñöôïc choïn nhö caùc thaønh phaàn ñoaïn phim (Scenes), Symbol 
Definition hoaëc caû hai. Baïn coù theå môû roäng vaø thu bôùt caây ñònh höôùng (Navigation Tree) naøy.  
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Movie Explorer coù moät trình ñôn tuøy choïn Options vaø trình ñôn ngöõ caûnh vôùi caùc tuøy 
choïn ñeå thöïc hieän caùc ñieàu khieån caùc muïc Item ñöôïc choïn hay thay ñoåi hieån thò trong Movie 
Explorer.   

Trình ñôn tuøy choïn Options naøy laø hình tam giaùc naèm taïi goùc phaûi phía treân Movie 
Explorer.  

 

Baûng Movie Explorer 

 

Trình ñôn tuøy choïn Options 

Ñeå hieån thò baûng Movie Explorer, baïn haõy choïn treân trình ñôn Window > Movie 
Explorer. Ñeå loïc caùc thaønh phaàn hieån thò trong Movie Explorer:  

 Nhaáp chuoät vaøo moät hoaëc nhieàu nuùt boä loïc Filter sang beân phaûi cuûa tuøy choïn 
Show ñeå hieån thò ñoaïn vaên baûn, Symbol, ActionScript, caùc file ñöôïc nhaäp vaøo hay 
frame vaø Layer. Baïn coù theå tuøy choïn caùc muïc ñeå hieån thò baèng caùch nhaáp chuoät 
vaøo nuùt Customize. Choïn caùc tuøy choïn trong vuøng Show cuûa hoäp thoaïi Movie 
Explorer Settings ñeå hieån thò caùc thaønh phaàn ñoù. 

TUÛ  SAÙCH STK – THEÁ GIÔÙI ÑOÀ HOÏA                                                                                                     BIEÂN SOAÏN : KS PHAÏM QUANG HUY 40 



GIAÙO TRÌNH THIEÁT KEÁ WEB :  PHAÀN LYÙ THUYEÁT - TÖÏ HOÏC MACROMEDIA FLASH 5.0 BAÈNG HÌNH AÛNH                 CHÖÔNG 1 
 

 

 Töø trong trình ñôn baäc leân taïi goùc phaûi phía treân trong Movie Explorer, haõy choïn 
leänh Show Movie Elements ñeå hieån thò caùc muïc trong Scene vaø choïn leänh Show 
Symbol Definitions ñeå hieån thò caùc thoâng tin veà caùc bieåu töôïng. (Caû hai tuøy choïn 
naøy coù theå  kích hoaït ñöôïc cuøng luùc). 

 

 Tìm kieám moät muïc Item duøng hoäp kyù töï 
Find 

Trong hoäp kyù töï Find, nhaäp teân cuûa muïc 
Item, teân font, chuoãi ActionScript, soá löôïng 
frame hoaëc teân Generator Object hay caëp 
giaù trò. Ñaëc tính hoäp Find tìm kieám taát caû 
caùc muïc Item hieän haønh coù trong Movie 
Explorer.  

 

 Choïn moät muïc Item trong Movie Explorer 

Nhaáp chuoät vaøo Item trong caây ñònh höôùng. 
Baïn coù theå nhaán phím Shift vaø nhaáp chuoät 
ñeå choïn nhieàu muïc Item.  

 
 

Vieäc chæ ñöôøng daãn ñaày ñuû cho caùc muïc 
ñöôïc choïn xuaát hieän taïi vuøng ngang beân 
döôùi trong baûng Movie Explorer. Vieän choïn 
moät Scene trong Movie Explorer hieån thò 
frame ñaàu tieân cuûa Scene ñoù trong Stage.  
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Vieäc choïn moät thaønh phaàn trong Movie Explorer seõ choïn thaønh phaàn ñoù vaøo trong Stage 
neáu Layer ñoù chöùa thaønh phaàn khoâng bò khoaù. 

Caùch duøng trình ñôn doïc vaø caùc leänh trong trình ñôn ngöõ caûnh taïi Movie Explorer:  

1. Thöïc hieän moät trong hai böôùc sau: 

Nhaáp chuoät vaøo tam giaùc taïi goùc phaûi treân trong Movie Explorer ñeå hieån thò trình 
ñôn tuøy choïn. 

♦ 

 

Nhaáp vaøo moät muïc Item vaø nhaáp phaûi chuoät (trong Windows) hoaëc nhaáp  Control 
(trong Macintosh)  trong caây ñònh höôùng  taïi Movie Explorer . 

♦ 

 

2. Choïn moät leänh tuøy choïn coù trong trình ñôn: 

Leänh Goto Location nhaûy ñeán Layer, Scene hoaëc  frame ñöôïc choïn trong ñoaïn 
phim. 

♦ 

♦ 

♦ 

♦ 

♦ 

Leänh Goto Symbol Definition nhaûy ñeán Symbol Definition cho moät bieåu töôïng 
ñöôïc choïn trong vuøng Movie Elements cuûa Movie Explorer. Symbol Definition 
lieät keâ taát caû caùc file cuøng vôùi bieåu töïông cuûa file ñoù. (Tuøy choïn Show Symbol 
Definitions phaûi ñöôïc choïn). 

Leänh Select Symbol Instances nhaûy ñeán Scene coù chöùa caùc Instance  cuûa moät 
bieåu töôïng ñöôïc choïn trong vuøng Symbol Definitions cuûa Movie Explorer. (Tuøy 
choïn Show Movie Elements phaûi ñöôïc choïn.) 

Leänh Find in Library vuøng saùng caùc bieåu töôïng ñöôïc choïn trong thö vieän cuûa 
ñoïan phim (Flash seõ môû cöûa soå thö vieän Library neáu noù chöa hieån thò). Caùc thuoäc 
tính môû ra caùc baûng thích hôïp cho thaønh phaàn ñöôïc choïn. (moät soá thaønh phaàn coù 
theå coù nhieàu hôn moät baûng keát hôïp vôùi chuùng). 

Leänh Rename cho pheùp baïn nhaäp vaøo teân môùi cho moät thaønh phaàn ñöôïc choïn. 
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♦ 

♦ 

♦ 

♦ 

♦ 

Leänh Edit in New Window cho pheùp baïn 
hieäu chænh moät bieåu töôïng môùi trong cöûa soå 
môùi. 

Leänh Show Movie Elements hieån thò caùc 
thaønh phaàn coù trong ñoaïn phim, saép xeáp 
vaøo trong caùc Scene. 

Leänh Show Symbol Definitions hieån thò taát 
caû caùc thaønh phaàn cuøng vôùi bieåu töôïng cuûa 
noù. 

Leänh Collapse Branch  thu nhoû caâu ñònh 
höôùng taïi moät thaønh phaàn ñöôïc choïn. 

Leänh Copy Text to Clipboard sao cheùp 
ñoaïn vaên baûn vaøo trong Clipboard. Baïn coù 
theå daùn ñoaïn vaên baûn vaøo trong chöông 
trình soaïn thaûo beân ngoaøi cho vieäc kieåm tra 
loãi chính taû hay caùc caùch hieäu chænh khaùc.  

 
 

Leänh Cut, Copy, Paste vaø Clear thöïc thi nhöõng chöùc naêng thoâng thöôøng trong 
moät thaønh phaàn ñöôïc choïn. Thay ñoåi moät muïc trong danh saùch hieån thò bieán ñoåi 
thaønh phaàn töông thích trong ñoaïn phim.  

♦ 

♦ 

♦ 

♦ 

Leänh Expand Branch môû roäng caây ñònh höôùng taïi thaønh phaàn ñöôïc choïn.  

Leänh Collapse Others thu nhoû caùc caønh trong caây ñònh höôùng khoâng coù thaønh 
phaàn ñöôïc choïn.  

Leänh Print in ra danh saùch hieän haønh hieån thò trong Movie Explorer. 

VUØNG XEM STAGE  

Thay ñoåi vuøng xem Stage, baïn coù theå thay ñoåi möùc ñoä phoùng ñaïi hoaëc di chuyeån  vuøng 
Stage trong vuøng laøm vieäc Flash.  Baïn coù theå hieäu chænh vuøng xem trong Stage baèng caùch söû 
duïng caùc leänh  trong trình ñôn View.  

ÑOÄ PHOÙNG ÑAÏI 

Baïn coù theå xem toaøn boä vuøng Stage treân maøn hình hay moät vuøng veõ ñaëc bieät ôû ñoä phoùng 
ñaïi lôùn baèng caùch thay ñoåi ñoä phoùng ñaïi. Ñoä phoùng ñaïi lôùn nhaát phuï thuoäc vaøo ñoä phaân giaûi cuûa 
maøn hình vaø kích thöôùc cuûa ñoaïn phim.  

Ñeå thu hay phoùng vuøng xem Stage duøng caùc kyõ thuaät sau ñaây:  

• Phoùng to taïi moät thaønh phaàn naøo ñoù, choïn coâng cuï Zoom vaø nhaáp chuoät vaøo thaønh 
phaàn ñoù.  Baïn coù theå chuyeån ñoåi  coâng cuï Zoom giöõa cheá ñoä phoùng  to vaø thu nhoû  
duøng chöùc naêng Enlarge (phoùng to) hoaëc Reduce (thu nhoû) hoaëc nhaán giöõ phím Alt 
(trong Windows)  hay phím Option  (trong Macintosh). 
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Coâng cuï Zoom  

• Phoùng to moät vuøng ñaëc bieät baèng caùch veõ moät vuøng choïn hình chöõ nhaät baèng coâng 
cuï Zoom. Flash thieát laäp ñoä phoùng ñaïi ñeå laép ñaày cöûa soå.  

 
• Phoùng to hay thu nhoû vuøng Stage hoaøn toaøn, choïn trong trình ñôn View > Zoom In 

hay View > Zoom Out. 

• Phoùng to hay thu nhoû theo tæ leä phaàn traêm ñaëc bieät, baïn haõy choïn treân trình ñôn View 
> Magnification vaø choïn moät tæ leä phaàn traêm thích hôïp coù trong trình ñôn phuï  hoaëc 
choïn moät tæ leä phaàn traêm taïi ñieàu khieån Zoom ôû goùc traùi phía döôùi trong cöûa soå 
chöông trình. 

   
Choïn leänh Zoom trong trình ñôn View vaø taïi ñieàu khieån töø cöûa soå  

• Hieån thò noäi dung cuûa frame hieän haønh, choïn treân trình ñôn View > Magnification > 
Show All  hoaëc choïn Show All trong ñieàu khieån Zoom taïi goùc traùi phía döôùi trong 
cöûa soå chöông trình. Neáu moät  Scene troáng, vuøng Stage ñöôïc hieån thò hoaøn toaøn. 

• Hieån thò toaøn vuøng Stage, choïn treân trình ñôn View > Magnification > Show Frame 
hoaëc choïn leänh Show. 

• Choïn leänh Frame töø trong ñieàu khieån Zoom taïi goùc traùi döôùi cuûa cöûa soå chöông 
trình.  

• Hieån thò vuøng laøm vieäc xung quanh vuøng Stage, baïn haõy choïn treân trình ñôn View > 
Work Area. Vuøng laøm vieäc ñöôïc hieån thò trong vuøng maøu xaùm. 
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 Duøng leänh Work Area ñeå xem caùc thaønh phaàn trong moät Scene chæ moät phaàn hoaëc 
hoaøn toaøn beân ngoaøi Stage. Ví duï, coù moät con chim bay vaøo trong moät frame, baïn seõ 
xaùc ñònh vò trí ñaàu tieân cuûa con chim laø töø beân ngoaøi vuøng Stage trong vuøng laøm 
vieäc. 

 

Vuøng laøm vieäc vôùi vuøng Stage laø Work Area 

DI CHUYEÅN VUØNG XEM  STAGE  

Khi vuøng Stage ñöôïc phoùng ñaïi, baïn khoâng theå xem taát caû caùc thaønh phaàn coù trong vuøng 
Stage. Coâng cuï Hand cho pheùp di chuyeån vuøng Stage  ñeå thay ñoåi vuøng xem maø khoâng caàn phaûi 
thay ñoåi ñoä phoùng ñaïi.  

 Di chuyeån vuøng xem stage 

• Choïn coâng cuï Hand. Ñeå chuyeån ñoåi taïm thôøi giöõa coâng cuï 
khaùc vaø coâng cuï Hand, giöõ phím Spacebar vaø nhaáp chuoät 
vaøo coâng cuï coù trong hoäp coâng cuï. 

• Keùo vuøng Stage. 

 

 

CAÙCH DUØNG GRID (KHUNG LÖÔÙI), DOØNG GUIDE  VAØ RULER (THÖÔÙC)  

Cuõng nhö caùc chöông trình veõ khaùc nhö Corel Draw, AutoCad . v. v. . Flash cuõng coù cheá 
ñoä khung löôùi vaø baét dính ñoái töôïng trong khung löôùi naøy. 

Khi khung löôùi ñöôïc hieån thò trong moät ñoaïn phim, chuùng xuaát hieän caùc ñöôøng thaúng 
phía sau vuøng laøm vieäc trong taát caû caùc Scene.  Baïn coù theå baùm chaéc caùc ñoái töôïng vaøo löôùi vaø 
baïn coù theå thay ñoåi kích thöôùc vaø maøu cuûa löôùi.  

Khi caùc thanh thöôùc hieån thò, chuùng xuaát hieän doïc beân treân vaø beân traùi cuûa ñoaïn phim. 
Baïn coù theå choïn ñôn vò ño ñöôïc duøng ôû treân löôùi. Khi baïn di chuyeån moät ñoái töôïng trong vuøng 
Stage khi thanh thöôùc hieån thò, caùc ñöôøng thaúng xaùc ñònh chieàu cuûa ñoái töôïng xuaát hieän treân 
thanh thöôùc.  
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Caùc ñoái töôïng naèm trong khung löôùi 

Ñöôøng Guide laø ñöôøng ñöôïc taïo ra töø treân thanh thöôùc ngang hoaëc thöôùc doïc baïn keùo  
vaøo trong vuøng Stage. Chuùng taïo thaønh caùc ñöôøng maéc löôùi nhöng naèm beân treân khung löôùi 
Grid.   

   
Nhaáp chuoät keùo töø treân thanh thöôùc naèm ngang xuoáng ñeå taïo ra ñöôøng Guide naèm ngang  

 

Nhaáp chuoät keùo töø treân thanh thöôùc ñöùng ñeå taïo ra ñöôøng Guide thaúng ñöùng  
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Baïn coù theå keùo caùc doøng Guide theo ñöôøng ngang hoaëc ñöôøng doïc töø treân thanh thöôùc 
vaøo trong  vuøng Stage khi hieån thò thanh thöôùc. Baïn cuõng coù theå  di chuyeån, khoaù, laøm aån hoaëc 
xoaù caùc doøng Guide naøy. Ngoaøi ra baïn coù theå baét dính ñoái töôïng vaøo trong doøng Guide  vaø thay 
ñoåi maøu cho caùc doøng Guide naøy.  

 
Chuù yù : Baïn coù theå taïo ra caùc doøng Guide  tuøy choïn hoaëc caùc khoaûng caùch doøng  Guide khoâng 
ñeàu nhau.   

    Baïn coù theå  laøm xuaát hieän hoaëc aån ñi caùc thanh 
thöôùc  baèng caùch choïn trình ñôn View > Rulers 
hoaëc nhaán phím taét Ctrl + Alt + Shift + R. 

 

 Caùch xaùc ñònh ñôn vò ño cuûa thanh thöôùc 

1. Choïn treân trình ñôn Modify > Movie. 

2. Choïn moät tuøy choïn caùc ñôn vò ño coù trong trình ñôn phuï taïi muïc  Ruler Units. 

 

 Hieån thò hoaëc laøm aån maéc löôùi Grid hoaëc doøng Guide 

• Choïn treân trình ñôn View > Grid > Show Grid hoaëc  View > Guides > Show 
Guides ñeå hieån thò maéc löôùi hay doøng Guide. 

• Choïn treân trình ñôn View > Grid > Edit Grid  hoaëc View > Guides > Edit 
Guides, vaø choïn trong hoäp thoaïi Show Grid hay  Show Guides. 
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Hoäp thoaïi Grid vaø hoäp thoaïi Guide 

Chuù yù : Neáu caùc khung löôùi chöa hieån thò vaø leänh Snap to Grid ñöôïc choïn khi baïn taïo ra caùc 
doøng Guide. Luùc naøy caùc ñöôøng Guide seõ baét dính vaøo khung löôùi.  

 

 Ñeå taét hay môû cheá ñoä baét dính cuûa khung löôùi Grid hoaëc ñöôøng Giude, baïn coù theå thöïc 
hieän moät trong nhöõng böôùc sau:  

• Choïn treân trình ñôn View > Grid > Snap to Grid hoaëc View > Guides > Snap to 
Guides. 

• Choïn  treân trình ñôn View > Grid > Edit Grid hoaëc View > Guides > Edit 
Guides vaø ñaùnh daáu kieåm vaøo hoäp  Snap to Grid hoaëc hoäp Snap to Guides. 

Chuù yù : Cheá ñoä baét dính vaøo caùc doøng Guide xaûy ra tröôùc cheá ñoä baét dính khung löôùi Grid taïi 
nôi maø caùc doøng Guide  naèm giöõa caùc doøng löôùi.   

 Caùch xaùc ñònh dung sai baét dính cho Grid hoaëc Guide 

 Choïn View > Grid > Edit Grid hoaëc View > Guides > Edit Guides. 

 Choïn moät tuøy choïn töø trình ñôn phuï trong hoäp thoaïi Snap Accuracy.  
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 Thay ñoåi maøu cho Grid hoaëc Guide: 

Choïn treân trình ñôn View > Grid > Edit Grid  

hoaëc View > Guides > Edit Guides. 

 Nhaáp chuoät vaøo hình tam giaùc keá 
hoäp maøu vaø choïn moät maøu coù 
trong baûng palette. 

 Theo maëc ñònh maøu cuûa caùc 
khung löôùi laø maøu xaùm. Maøu 
maëc ñònh cuûa ñöôøng Guide laø 
maøu xanh laù caây. 

 

 

 Thay ñoåi khoaûng caùch giöõa caùc khung löôùi Grid: 

 Choïn treân trình ñôn View > Grid 
> Edit Grid. 

 Trong hoäp thoaïi Grid, nhaäp giaù 
trò khoaûng caùch löôùi theo ñöôøng 
ngang vaø doïc. Sau ñoù nhaáp nuùt 
OK. 

 

 

 Di chuyeån ñöôøng Guide:  Duøng coâng cuï Arrow  ñeå nhaáp vaø keùo ñöôøng Guide naøy.  

 Khoaù hoaëc xoaù taát caû caùc ñöôøng Guide : Choïn treân trình ñôn View > Guides > Edit 
Guides vaø sau ñoù choïn  Lock Guides hoaëc  Clear All vaø nhaáp chuoät choïn nuùt OK.  

 

Chuù yù : Nuùt Clear All  trong cöûa soå Guides seõ xoaù taát caû caùc ñöôøng Guide hieän haønh coù trong 
Scene.  

 Xoaù moät ñöôøng Guide 

Trong khi caùc ñöôøng Guide khoâng coù khoaù, baïn duøng coâng cuï Arrow vaø keùo ñöôøng 
Guide ñeán thanh thöôùc thaúng ñöùng hoaëc thanh thöôùc doïc.  
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Keùo ñöôøng Guide ngang veà phía thanh thöôùc naèm ngang ñeå xoaù ñöôøng Giude naøy 

TUØY CHOÏN PHÍM TAÉT 

Baïn coù theå tuøy choïn caùc phím taét trong Flash ñeå phuø hôïp vôùi caùc phím taét trong chöông 
trình khaùc hoaëc ñeå saép xeáp hôïp lyù vuøng laøm vieäc trong Flash. Theo maëc ñònh, Flash duøng caùc 
phím taét gaén lieàn vôùi chöông trình Flash. Ngoaøi ra baïn coù theå choïn moät phím taét ñöôïc thieát laäp 
töø moät trong nhöõng chöông trình ñoà hoïa khaùc nhö Fireworks, Adobe Illustrator vaø Adobe 
Photoshop.  

Ñeå taïo ra moät boä caùc phím taét tuøy choïn,  baïn sao cheùp moät boä phím ñang toàn taïi vaø sau 
ñoù theâm hay xoaù phím taét ñoù ñeå taïo thaønh boä phím taét môùi. Ngoaøi ra baïn cuõng coù theå xoaù caùc 
boä phím taét tuøy choïn.  

 
Baûng caùc phím taét 
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 Caùch choïn moät boä phím taét 

1. Choïn treân trình  ñôn  Edit > Keyboard Shortcuts. 

2. Trong hoäp thoaïi Keyboard Shortcuts, choïn boä phím taét trong trình ñôn phuï 
Current Set. 

 
 Caùch taïo moät boä phím taét môùi  

1. Choïn boä phím taét  nhö ñaõ moâ taû ôû treân . 

2. Nhaáp chuoät vaøo nuùt Duplicate Set   

 
3. Nhaäp teân vaøo cho teân phím taét vaø nhaáp chuoät vaøo nuùt OK. 

 Caùch ñoåi teân boä phím taét tuøy choïn 

1. Trong hoäp thoaïi Customize Shortcuts, choïn boä phím taét trong trình ñôn phuï Current 
Set . 

 
2. Nhaáp chuoät vaøo nuùt Rename Set. 

 
3. Trong hoäp thoaïi Rename, nhaäp vaøo teân trong muïc New name sau ñoù nhaáp OK. 

 
Chuù yù : Baïn khoâng theå ñoåi teân caùc boä ñaõ ñöôïc caøi ñaët saün.  
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Theâm hoaëc xoaù moät boä phím taét 

1. Choïn treân trình ñôn Edit > Keyboard Shortcuts vaø choïn boä phím taét baïn muoán 
thay ñoåi.  

2. Choïn Drawing Menu Commands, Drawing Tools hoaëc Test Movie Menu 
Commands coù trong trình ñôn Commands  ñeå xem caùc phím taét  trong caùc muïc 
ñöôïc choïn. 

 

 

3. Trong danh saùch Commands, choïn leänh muoán theâm hoaëc xoaù moät phím taét. Moät 
lôøi chuù thích cho leänh ñöôïc choïn xuaát hieän trong vuøng Description cuûa hoäp thoaïi. 

 
Lôøi chuù thích cho muïc choïn Rectangle trong muïc Description 

4. Thöïc hieän moät trong nhöõng böôùc sau: 

• Ñeå theâm moät phím taét , nhaáp chuoät vaøo nuùt Add Shortcut (+) . 

• Ñeå xoaù moät nuùt, nhaáp chuoät vaøo nuùt Remove Shortcut (-)  vaø tieán trình ñöôïc 
laøm tieáp theo cho ñeán böôùc  6. 

5. Neáu baïn ñang theâm vaøo moät phím taét,  haõy nhaäp vaøo toå hôïp phím taét trong hoäp 
thoaïi Press Key. 
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Chuù yù : Nhaäp vaøo toå hôïp phím, caùc phím ñôn giaûn coù treân baøn phím. Baïn khoâng caàn nhaäp teân 
phím nhö  Control, Option v.v . . . 

6. Nhaáp chuoät vaøo nuùt Change. 

7. Laëp laïi caùc böôùc treân ñeå theâm hoaëc xoaù caùc phím taét boå sung. 

8. Nhaáp chuoät vaøo nuùt OK. 

 Caùch xoaù boä phím taét:  

1. Choïn treân trình ñôn Edit > Keyboard Shortcuts. Trong hoäp thoaïi Keyboard 
Shortcuts, nhaáp chuoät vaøo nuùt Delete Set. 

 

2. Trong hoäp thoaïi Delete Set, choïn boä phím taét vaø nhaáp nuùt Delete. 

 

Chuù yù : Baïn khoâng theå xoaù boä phim ñaõ ñöôïc thieát laäp saün trong Flash.  

IN RA FILE FLASH KHI BAÏN HIEÄU CHÆNH ÑOAÏN PHIM  

Baïn coù theå in ra caùc frame töø caùc file  FLA trong Flash khi baïn laøm vieäc ñeå xem vaø hieäu 
chænh ñoaïn phim. Ngoaøi ra baïn cuõng coù theå xaùc ñònh caùc frame ñeå ñöôïc in ra trong Flash Player 
baèng caùch xem ñoaïn phim hieån thò trong Flash. Khi in ra caùc frame töø file FLA,  baïn söû duïng 
hoäp thoaïi Print ñeå xaùc ñònh loaïi Scene hay frame cuõng nhö soá löôïng baûn sao baïn muoán in ra.  

Trong  Window, hoäp thoaïi Page Setup xaùc ñònh kích thöôùc khoå giaáy, ñònh höôùng xoay 
ngang cuûa khoå giaáy vaø nhieàu tuøy choïn in khaùc nhö thieát laäp muïc canh leà cho taát caû caùc trang. 
Taát caû caùc frame ñöôïc in ra thaønh moãi trang. Trong  Macintosh, nhöõng tuøy choïn naøy ñöôïc chia 
ra giöõa hoäp thoaïi Page Setup vaø hoäp thoaïi Print Margins.  

Hoäp thoaïi Print vaø Page Setup laø daïng chuaån khi chuùng ñöôïc hieån thò trong baát kyø heä 
ñieàu haønh naøo vaø phuï thuoäc vaøo driver maùy in baïn choïn.   

TUÛ  SAÙCH STK – THEÁ GIÔÙI ÑOÀ HOÏA                                                                                                     BIEÂN SOAÏN : KS PHAÏM QUANG HUY 53 



GIAÙO TRÌNH THIEÁT KEÁ WEB :  PHAÀN LYÙ THUYEÁT - TÖÏ HOÏC MACROMEDIA FLASH 5.0 BAÈNG HÌNH AÛNH                 CHÖÔNG 1 
 

      
 Ñeå thieát laäp caùc tuøy choïn in ra:   

1. Choïn trình ñôn File > Page Setup (trong Windows)  

Hoaëc File > Print Margins (trong Macintosh). 

2. Thieát laäp vò trí trang in. Choïn tuøy choïn Center ñeå in frame ra chính giöõa trang.  

3. Trong trình ñôn baäc xuoáng Frames, choïn in ra taát caû caùc frame trong ñoaïn phim 
hoaëc chæ in frame ñaàu cuûa moãi Scene.  

 

4. Trong trình ñôn baäc xuoáng Layout, choïn moät trong nhöõng tuøy choïn sau: 

 

Actual Size seõ in ra kích thöôùc thaät cuûa caùc frame. Nhaäp vaøo giaù trò trong tuøy 
choïn Scale ñeå laøm giaûm kích thöôùc hoaëc phoùng lôùn frame ñöôïc in ra. 

♦ 

♦ 

♦ 

Fit on One Page laøm giaûm kích thöôùc hoaëc phoùng lôùn töøng frame ñöôïc in ra ñeå 
laép ñaày vuøng trang in.  

Tuøy choïn Storyboard in ra chæ moät trang cho caùc aûnh ñoà hoïa. Nhaäp vaøo soá aûnh 
cho moãi trang trong hoäp thoaïi kyù töï Frames. Thieát laäp khoaûng caùch giöõa caùc 
aûnh trong hoäp kyù töï  Story Margin. Choïn Label  ñeå in nhaõn frame nhö laø moät 
aûnh ñoà hoïa.  
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 Xem tröôùc caùch saép xeáp caùc Scene treân tôø giaáy tröôùc khi in 

Choïn treân trình ñôn File > Print Preview.  

 Caùch In ra caùc frame 

Choïn trình ñôn File > Print.  
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