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TOÅNG QUAN VEÀ CAÙC COÂNG CUÏ VEÕ 
 

Caùc coâng cuï veõ trong Flash cho pheùp baïn taïo vaø thay ñoåi hình daïng aûnh veõ trong ñoaïn 
phim. Baïn coù theå choïn trong trình ñôn Help > Lessons > Drawing ñeå bieát theâm veà coâng cuï veõ 
trong Flash. Tröôùc khi baïn veõ vaø toâ maøu trong Flash, ñieàu quan troïng laø baïn phaûi laøm quen vôùi 
caùc coâng cuï veõ, toâ maøu vaø thay ñoåi hình daïng cuûa caùc ñoái töôïng treân cuøng moät Layer. 

CAÙC COÂNG CUÏ VEÕ VAØ TOÂ MAØU TRONG  FLASH 

Flash cung caáp nhieàu coâng cuï veõ töï do 
hoaëc caùc coâng cuï veõ chính xaùc nhö  ñöôøng 
(Line), hình daïng (Shape), ñöôøng daãn (Path) 
vaø caùc ñoái töôïng toâ maøu veõ. 

 Veõ caùc ñöôøng neùt vaø hình daïng töï do 
gioáng nhö veõ baèng coâng cuï vieát chì 
thaät,  baïn haõy duøng coâng cuï Pencil.  

 Veõ caùc ñöôøng thaúng chính xaùc hoaëc caùc 
ñöôøng cong, baïn haõy duøng coâng cuï Pen. 

 Veõ caùc hình hoïc cô baûn, baïn haõy duøng 
coâng cuï Line, Oval vaø Rectangle.  

 Taïo ra caùc neùt coï veõ gioáng nhö veõ baèng 
coï, baïn haõy choïn coâng cuï Brush. 

Khi baïn duøng coâng cuï veõ hoaëc toâ maøu ñeå 
taïo ra ñoái töôïng, coâng cuï seõ aùp ñaët neùt coï 
veõ hieän haønh vaø caùc thuoäc tính toâ maøu vaøo 
ñoái töôïng.  

Ñeå thay ñoåi neùt veõ vaø thuoäc tính toâ maøu 
treân ñoái töôïng, baïn coù theå duøng coâng cuï 
Paint Bucket vaø Ink Bottle. 

Baûng coâng cuï veõ  

 

Baïn coù theå phuïc hoài laïi caùc ñöôøng neùt vaø ñöôøng vieàn ngoaøi theo nhieàu caùch khaùc nhau 
sau khi baïn taïo ra chuùng. Thuoäc tính neùt veõ vaø toâ maøu ñöôïc xem nhö laø caùc ñoái töôïng ñoäc laäp. 
Baïn coù theå choïn thuoäc tính toâ maøu vaø neùt veõ taùch rôøi nhau ñeå di chuyeån vaø thay ñoåi chuùng. Baïn 
coù theå duøng cheá ñoä baét dính ñeå canh caùc ñoái töôïng thaúng haøng vôùi nhau baèng coâng cuï veõ ôû cheá 
ñoä khung löôùi vaø ñöôøng Guide.  

CAÙC HÌNH DAÏNG CHOÀNG LAÁP  (OVERLAPPING SHAPE) TRONG FLASH   

Khi baïn duøng caùc coâng cuï Pencil, Line, Oval, Rectangle hoaëc Brush ñeå veõ moät ñöôøng 
thaúng ngang qua ñöôøng thaúng khaùc hoaëc toâ maøu cho caùc hình, caùc ñöôøng thaúng choàng nhau ñöôïc 
chia thaønh nhieàu ñoaïn taïi nhieàu giao ñieåm. Baïn coù theå duøng coâng cuï Arrow  ñeå choïn, di chuyeån 
vaø taïo laïi hình daïng ñoái töôïng taïi moãi ñoaïn.  
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Chuù yù : Caùc ñöôøng thaúng choàng nhau maø baïn duøng coâng cuï Pen taïo ra chia caùc ñoaïn thaønh 
nhöõng ñoaïn.  

 

Moät vuøng maøu toâ, moät vuøng maøu  toâ vôùi moät ñöôøng thaúng xuyeân qua noù vaø hai vuøng maøu chia ra cuøng vôùi ba ñoaïn 
thaúng ñöôïc taïo ra thaønh töøng ñoaïn 

Khi baïn toâ maøu phaàn treân cuøng cuûa ñoái töôïng vaø ñöôøng thaúng, phaàn chia beân döôùi ñöôïc 
thay theá baèng baát kyø maøu gì maø maøu beân treân ñaõ toâ. Khi toâ cuøng moät maøu seõ troän caùc maøu naøy 
laïi vôùi nhau. Vieäc toâ caùc maøu khaùc nhau seõ vaãn coù söï khaùc bieät, caùc maøu khaùc nhau naøy seõ 
khoâng hoøa troän cuøng maøu vôùi nhau. Baïn coù theå duøng nhöõng thuoäc tính naøy ñeå taïo ra lôùp maët naï, 
caùc vieàn ngoaøi vaø caùc aûnh aâm tính khaùc. Ví duï nhö, vieàn maøu beân döôùi ñöôïc taïo ra baèng caùch di 
chuyeån aûnh (file Kite) khoâng nhoùm laïi vaøo trong ñoái töôïng maøu xanh laù caây, choïn laïi aûnh Kite 
vaø sau ñoù loaïi boû töøng phaàn aûnh Kite ñöôïc toâ maøu xanh laù caây.  

 

Ñeå traùnh vieäc thay ñoåi caùc ñoái töôïng vaø ñöôøng thaúng moät caùch voâ tình baèng caùch veõ 
choàng leân chuùng, baïn coù theå nhoùm caùc ñoái töôïng naøy hoaëc duøng lôùp Layer ñeå taùch bieät chuùng.  

VEÕ BAÈNG COÂNG CUÏ PENCIL 

 

 Ñeå veõ ñöôøng thaúng vaø hình daùng ñoái töôïng, baïn haõy choïn coâng cuï 
Pencil. Baïn seõ duøng coâng cuï naøy theo nhieàu caùch maø baïn muoán. Coâng cuï 
Pencil coøn giuùp cho vieäc veõ caùc ñöôøng thaúng vaø hình daïng ñoái töôïng nhaün vaø 
thaúng hôn.  
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 Veõ baèng coâng cuï Pencil:  

1. Choïn coâng cuï Pencil. 

2. Choïn maøu cho neùt veõ, kieåu neùt veõ vaø troïng löôïng neùt veõ.  

3. Choïn moät cheá ñoä coù trong hoäp coâng cuï Options: 

Choïn cheá ñoä Straighten ñeå veõ caùc ñöôøng thaúng neùt vaø chuyeån ñoåi xaáp xæ 
caùc hình tam giaùc, hình baàu duïc, hình troøn, hình chöõ nhaät vaø hình vuoâng 
thaønh nhöõng daïng hình hoïc thoâng thöôøng.  

♦ 

♦ 

♦ 

Choïn cheá ñoä Smooth  ñeå veõ caùc ñöôøng cong nhaün. 

Choïn cheá ñoä Ink  ñeå veõ caùc ñöôøng thaúng töï do maø khoâng coù söï thay ñoåi 
naøo.  

   
Caùc ñöôøng thaúng veõ vôùi töøng cheá ñoä Straighten, Smooth vaø Ink 

Keùo coâng cuï Pencil vaøo vuøng Stage ñeå veõ. Trong khi veõ  haõy nhaán phím Shift ñeå cuõng coá 
ñöôøng thaúng ñöùng vaø ñöôøng naèm ngang cho thaät ngay thaúng nhö mong muoán.  

VEÕ ÑÖÔØNG THAÚNG, HÌNH BAÀU DUÏC VAØ HÌNH CHÖÕ NHAÄT  

Baïn coù theå duøng caùc coâng cuï Line, Oval vaø Rectangle ñeå taïo ra nhöõng kieåu hình hình 
hoïc cô baûn deã daøng. Coâng cuï Oval vaø Rectangle taïo ra neùt veõ vaø toâ ñaày maøu cho vuøng vöøa veõ. 
Baïn coù theå duøng coâng cuï Rectangle ñeå taïo ra hình chöõ nhaät coù caùc goùc vuoâng hoaëc troøn.  

 
 Caùch veõ ñöôøng thaúng, hình baàu duïc vaø hình chöõ nhaät:  

1. Choïn coâng cuï Line, Oval hoaëc Rectangle. 

2. Choïn caùc thuoäc tính cho neùt veõ vaø maøu toâ  

 
 

Chuù yù :  Baïn khoâng theå thieát laäp caùc thuoäc tính toâ maøu cho coâng cuï  Line.  

3. Ñoái vôùi coâng cuï Rectangle phaûi xaùc ñònh goùc 
troøn baèng caùch nhaáp chuoät vaøo vuøng boå sung 
Round Rectangle vaø nhaäp vaøo moät giaù trò cho 
baùn kính goùc. Giaù trò laø 0 taïo ra goùc vuoâng.  
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4. Keùo trong vuøng Stage neáu baïn duøng coâng cuï Rectangle nhaán phím Up vaø Down 

Arrow trong khi keùo ñeå hieäu chænh baùn kính cuûa caùc goùc troøn.  

Ñoái vôùi coâng cuï Oval vaø Rectangle, 
nhaán phím Shift trong khi keùo ñeå taïo 
ra ñöôïc caùc hình troøn vaø hình vuoâng. 

Ñoái vôùi coâng cuï Line, nhaán phím Shift 
trong khi keùo ñeå taïo nhieàu ñöôøng 
thaúng coù goùc 45°. 

 

DUØNG COÂNG CUÏ PEN  

 

Ñeå veõ caùc ñöôøng thaúng nhö mong muoán hoaëc caùc ñöôøng cong mòn vaø cong lieàn 
neùt, baïn coù theå duøng coâng cuï Pen. Baïn coù theå taïo ra caùc ñoaïn thaúng hoaëc ñöôøng 
cong vaø hieäu chænh ñoä daøi,  goùc  taïo ra  caùc ñoaïn  vaø  ñoä nghieâng cuûa caùc ñoaïn 
cong naøy.  

 Khi baïn choïn coâng cuï Pen, baïn nhaáp chuoät vaøo nôi ñaàu tieân ñeå taïo ra caùc ñieåm trong   
caùc ñoaïn thaúng. Sau ñoù nhaáp chuoät vaø keùo ñeå taïo ra caùc ñoaïn ñöôøng cong. Baïn coù theå hieäu 
chænh caùc ñoaïn thaúng vaø ñoaïn ñöôøng cong naøy baèng caùch hieäu chænh caùc ñieåm treân ñöôøng thaúng 
ñoù. Baïn coù theå laøm ñaûo ngöôïc caùc ñöôøng cong thaønh ñöôøng thaúng vaø ngöôc laïi. Ngoaøi ra baïn coù 
theå laøm hieån thò caùc ñieåm treân ñöôøng thaúng maø baïn taïo ra vôùi caùc coâng cuï veõ trong Flash nhö  
coâng cuï Pencil, Brush, Line, Oval vaø Rectangle ñeå hieäu chænh nhöõng ñöôøng naøy.  

    

Choïn coâng cuï Pen ñeå veõ vaø hieäu chænh caùc ñieåm veõ treân ñöôøng thaúng 

THIEÁT LAÄP CAÙC MÖÙC ÖU TIEÂN CHO COÂNG CUÏ PEN 
 Baïn coù theå xaùc laäp möùc öu tieân cho coâng cuï Pen khi noù xuaát hieän coù con troû ñeå xem caùc 
ñoaïn thaúng khi baïn veõ hoaëc caùc ñieåm neo (caùc maáu) ñöôïc choïn xuaát hieän. Caùc ñieåm neo vaø caùc  
ñoaïn thaúng ñöôïc choïn seõ hieån thò vôùi caùc maøu vieàn ngoaøi cuûa lôùp Layer maø caùc ñöôøng thaúng 
hoaëc caùc  ñieåm xuaát hieän. 
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Caùch thieát  laäp möùc öu tieân cho coâng cuï Pen 

1. Choïn treân trình ñôn Edit > Preferences vaø nhaáp chuoät vaøo tab Editing trong cöûa soå môùi môû. 

 

2. Beân döôùi muïc Pen Tool, baïn haõy thieát laäp caùc tuøy choïn sau ñaây: 

 Choïn muïc Show Pen Preview ñeå xem caùc ñoaïn thaúng khi baïn veõ. Flash hieån thò 
ñoaïn thaúng khi baïn di chuyeån con troû xung quanh vuøng Stage, tröôùc khi baïn nhaáp 
chuoät taïo ra ñieåm cuoái cuûa ñoaïn thaúng ñoù. Neáu tuøy choïn naøy khoâng ñöôïc choïn, Flash 
seõ khoâng hieån thò ñoaïn thaúng cho ñeán khi baïn taïo ra ñieåm cuoái cuûa ñoaïn thaúng ñoù. 

 

 Choïn muïc Show Solid Points ñeå xaùc ñònh caùc ñieåm neo (maáu) chöa ñöôïc choïn xuaát 
hieän laø caùc ñieåm ñaëc vaø caùc ñieåm ñöôïc choïn xuaát hieän laø caùc ñieåm roãng (theo maëc 
ñònh tuøy choïn naøy ñöôïc choïn). Choïn laïi muïc choïn naøy laø caùc ñieåm chöa ñöôïc choïn laø 
caùc ñieåm roãng vaø caùc ñieåm ñöôïc choïn laø caùc ñieåm ñaët.  

 

 Choïn muïc Show Precise Cursors xaùc ñònh con troû cuûa coâng cuï Pen xuaát hieän  coù 
hình daáu thaäp, toát hôn so vôùi ñeå ôû cheá ñoä maëc ñònh nhaèm saép ñaët caùc ñöôøng thaúng 
chính xaùc hôn. Choïn laïi tuøy choïn naøy ñeå hieån thò bieåu töôïng coâng cuï Pen maëc ñònh.  
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Chuù yù :  Nhaán phím  Caps Lock  khi baïn laøm vieäc ñeå chuyeån ñoåi giöõa caùc con troû.  

3. Choïn xong nhaáp chuoät vaøo nuùt OK. 

VEÕ ÑÖÔØNG THAÚNG BAÈNG COÂNG CUÏ PEN 

Ñeå veõ caùc ñoaïn thaúng baèng coâng cuï Pen, baïn taïo ra caùc ñieåm neo, caùc ñieåm treân ñöôøng 
thaúng xaùc ñònh chieàu daøi cuûa caùc ñoaïn thaúng rieâng bieät.  

Caùch veõ caùc ñöôøng thaúng baèng coâng cuï Pen: 

1. Choïn coâng cuï Pen.    

2. Choïn caùc thuoäc tính neùt veõ vaø toâ maøu cho ñöôøng thaúng caàn veõ.  

3. Ñaët con troû vaøo vuøng Stage nôi muoán baét ñaàu veõ ñöôøng thaúng, vaø nhaáp chuoät vaøo ñeå xaùc 
ñònh maáu neo cho  con troû ñaàu tieân.  

4. Nhaáp chuoät  moät laàn nöõa cho ñoaïn thaúng ñaàu tieân cuûa ñöôøng thaúng keát thuùc. Nhaán phím 
Shift ñeå coá ñònh goùc veõ  450. 

5. Tieáp tuïc nhaáp chuoät ñeå taïo ra caùc ñoaïn thaúng boå sung khaùc.  

   

Ñeå keát thuùc ñöôøng veõ, baïn haõy thöïc hieän moät trong nhöõng thao taùc sau ñaây: 

 Keát thuùc ñöôøng môû, nhaáp ñuùp chuoät vaøo vò trí ñieåm cuoái cuøng, sau ñoù nhaáp 
chuoät vaøo coâng cuï Pen trong hoäp coâng cuï hoaëc nhaán phím Ctrl vaø nhaáp chuoät 
(trong Windows) hoaëc nhaán phím Command (trong Macintosh) vaø nhaáp taïi baát 
kyø nôi ñaâu trong vuøng Stage. 
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♦ 

♦ 

Keát thuùc moät ñöôøng, ñaët coâng cuï Pen ngay 
vò trí con troû ñaàu tieân cuûa ñieåm vöøa veõ. 
Moät daáu troøn roãng nhoû xuaát hieän keá beân 
ñaàu ngoøi vieát veõ. Sau ñoù nhaáp chuoät vaø 
keùo ñeå keát thuùc ñöôøng veõ.  

Ñeå keát thuùc neùt veõ, baïn coù theå choïn treân 
trình ñôn Edit > Deselect All hoaëc choïn 
moät coâng cuï khaùc trong hoäp coâng cuï. 

 

 

VEÕ ÑÖÔØNG CONG BAÈNG COÂNG CUÏ PEN  
Baïn coù theå taïo ra caùc ñöôøng cong baèng caùch keùo coâng cuï Pen theo höôùng baïn muoán 

ñöôøng cong taïo ra ñieåm maáu neo ñaàu tieân, sau ñoù keùo coâng cuï Pen theo höôùng ñoái laäp ñeå taïo ra 
ñieåm maáu neo thöù hai.  

Khi duøng coâng cuï Pen ñeå taïo ra caùc ñöôøng cong, caùc ñieåm maáu neo cuûa ñoaïn ñöôøng cong 
xuaát hieän handle tieáp tuyeán. Goùc tieáp tuyeán vaø chieàu daøi cuûa caùc handle tieáp tuyeán seõ xaùc ñònh 
ñoä cao, goùc tieáp tuyeán vaø chieàu saâu loõm vaøo cuûa ñöôøng cong. Vieäc di chuyeån caùc handle tieáp 
tuyeán seõ laøm thay ñoåi hình daïng cuûa caùc ñöôøng cong.  

 Caùch veõ moät ñöôøng cong: 

1. Choïn coâng cuï Pen trong hoäp coâng cuï. 

2. Ñaët coâng cuï Pen vaøo vuøng Stage nôi 
baïn muoán ñöôøng cong baét ñaàu. Sau 
ñoù giöõ nuùt chuoät. Ñieåm maáu neo ñaàu 
tieân xuaát hieän vaø ñaàu muùt cuûa ngoøi 
vieát baây giôø thay ñoåi laø ñaàu muõi teân.  

  

3. Keùo theo höôùng baïn muoán ñoaïn 
ñöôøng cong ñöôïc veõ. Khi baïn keùo, 
caùc handle tieáp tuyeán xuaát hieän 
ñöôøng cong. Nhaáp phím Shift trong 
khi keùo ñeå coù ñöôïc ñöôøng cong moät 
goùc 450. 

 

 
4. Nhaû nuùt chuoät. Ñoä daøi vaø heä soá goác  cuûa caùc handle tieáp tuyeán xaùc ñònh hình daùng 

cuûa caùc ñoaïn ñöôøng cong. Sau ñoù baïn coù theå di chuyeån caùc handle tieáp tuyeán naøy ñeå 
hieäu chænh ñöôøng cong. 
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5. Ñaët con troû nôi baïn muoán vò trí ñöôøng 
cong keát thuùc vaø nhaán giöõ nuùt chuoät vaø 
keùo sang höôùng ñoái dieän ñeå keát thuùc 
ñoaïn vöøa veõ. Nhaáp phím Shift trong khi 
keùo. 

 

 

6. Veõ ñoaïn ñöôøng cong keá tieáp,  ñaët con 
troû vaøo vuøng baïn muoán ñoaïn tieáp theo 
keát thuùc vaø keùo chuoät ra khoûi ñöôøng 
cong.  

 

 

HIEÄU CHÆNH CAÙC MAÁU NEO TREÂN ÑÖÔØNG VEÕ   

Khi baïn veõ ñöôøng cong baèng coâng cuï Pen, baïn seõ taïo ra caùc ñieåm cong (Curved Point), 
goàm coù caùc ñieåm maáu neo trong moät ñöôøng cong lieân tuïc.  

Khi baïn veõ moät ñöôøng thaúng 
noái tieáp ñeán moät  ñoaïn ñöôøng cong, 
baïn taïo ra caùc ñieåm goác (Corner 
Point), caùc ñieåm maáu neo trong moät 
ñöôøng thaúng hoaëc taïi vuøng tieáp noái 
cuûa ñöôøng thaúng vaø ñöôøng cong. 

 

Theo maëc ñònh,  caùc ñieåm ñöôøng cong ñöôïc choïn xuaát hieän caùc loå troøn roãng vaø caùc ñieåm 
goác ñöôïc choïn xuaát hieän caùc loã vuoâng roãng. Bieán ñoåi caùc ñoaïn trong moät ñöôøng thaúng töø caùc 
ñoaïn thaúng thaønh caùc ñoaïn ñöôøng cong vaø ngöôïc laïi, baïn chuyeån ñoåi caùc ñieåm goác sang caùc 
ñieåm cong (Curved Point) vaø ngöôïc laïi.  

     
Ngoaøi ra, baïn cuõng coù theå di chuyeån, theâm vaø xoaù caùc ñieåm maáu neo trong ñöôøng veõ. 

Baïn di chuyeån caùc ñieåm maáu neo baèng caùch duøng coâng cuï Subselection ñeå hieäu chænh ñoä daøi, 
goùc  cuûa ñoaïn thaúng hoaëc heä soá goùc cuûa ñoaïn ñöôøng cong. 

 Baïn coù theå nhích caùc ñieåm maáu neo ñöôïc choïn ñeå thay ñoåi moät ít treân ñöôøng veõ.  
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Vieäc xoaù ñi caùc ñieåm maáu neo khoâng caàn thieát treân ñöôøng cong nhaèm ñeå toái öu hoaù 
ñöôøng cong vaø laøm giaûm kích thöôùc file.  

 Caùch di chuyeån moät ñieåm maáu neo :  Duøng coâng cuï Subselection keùo noù.  

 Caùch di chuyeån moät hay nhieàu ñieåm maáu neo :  Choïn moät hoaëc nhieàu ñieåm baèng coâng cuï 
Subselection vaø duøng caùc phím muõi teân ñeå di chuyeån caùc ñieåm choïn naøy.  

 Caùch chuyeån ñoåi moät ñieåm maáu neo,  baïn haõy thöïc hieän moät trong hai böôùc sau :  

Chuyeån ñoåi moät ñieåm goác sang moät ñieåm cong, duøng coâng cuï Subselection  
choïn moät ñieåm sau ñoù nhaán phím Alt vaø keùo ñieåm ñoù (trong Windows)  
hoaëc nhaán phím  Option vaø keùo  (trong Macintosh) . 

♦ 

 

Chuyeån ñoåi moät ñieåm cong sang moät ñieåm goùc, duøng coâng cuï Pen vaø nhaáp 
chuoät treân ñieåm ñoù.  

♦ 

♦ 

 Caùch theâm vaøo moät ñieåm :  Nhaáp  coâng cuï Pen  vaøo moät ñoaïn thaúng.  

 Caùch xoaù moät ñieåm,  baïn haõy thöïc hieän moät trong nhöõng thao taùc sau:  

Xoaù moät ñieåm goác, duøng 
coâng cuï Pen vaø nhaáp chuoät 
vaøo ñieåm caàn xoaù moät laàn. 

 

 

Xoaù moät ñieåm cong, duøng coâng Pen vaø nhaáp chuoät vaøo ñieåm caàn xoaù hai 
laàn. (Nhaáp chuoät moät laàn ñeå chuyeån ñoåi ñieåm cong sang ñieåm goác vaø moät 
laàn nöõa ñeå xoaù ñieåm goác ñoù.) 

♦ 

♦ Duøng coâng cuï Subselection choïn ñieåm caàn xoaù, sau ñoù nhaán phím Delete. 

HIEÄU CHÆNH CAÙC ÑOAÏN   

Baïn coù theå hieäu chænh nhöõng ñoaïn thaúng ñeå thay ñoåi goùc vaø chieàu daøi ñoaïn thaúng hoaëc 
hieäu chænh caùc ñoaïn cong nhaèm thay ñoåi heä soá goùc vaø höôùng cong. Khi baïn di chuyeån moät 
handle tieáp tuyeán trong moät ñieåm cong, caùc ñöôøng cong treân caû hai phía cuûa ñieåm ñoù cuõng bò 
thay ñoåi. Vaø trong khi ñoù baïn di chuyeån moät ñieåm goác, chæ coù ñöôøng cong treân cuøng moät phía 
cuûa ñieåm ñoù bò thay ñoåi.  
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 Hieäu chænh moät ñoaïn thaúng:  

1. Choïn coâng cuï Subselection vaø choïn 

moät ñöôøng thaúng.   

2. Duøng coâng cuï Subselection ñeå keùo 
ñieåm trong ñoaïn thaúng sang vò trí 
môùi.  

 

 Hieäu chænh moät ñoaïn ñöôøng cong :  Choïn coâng cuï Subselection vaø keùo ñoaïn cong ñoù.  

Chuù yù : Caùc ñieåm thöôøng bò che daáu khi baïn duøng coâng cuï Subselection vaø nhaáp chuoät vaøo 
ñöôøng thaúng ñoù. Ñeå xem caùc ñieåm ñoù sau khi hieäu chænh, baïn coù theå duøng coâng cuï Subselection 
hoaëc coâng cuï Pen vaø nhaáp vaøo ñoaïn thaúng ñoù.  Ngoaøi ra, baïn coù theå duøng coâng cuï Subselection 
ñeå theâm caùc ñieåm vaøo ñöôøng thaúng.  

 Hieäu chænh nhieàu ñieåm hoaëc nhieàu handle tieáp tuyeán trong moät ñöôøng cong: 

1. Choïn coâng cuï Subselection vaø choïn moät ñoaïn ñöôøng cong.  Luùc naøy caùc handle 
tieáp tuyeán xuaát hieän treân ñöôøng cong ñoù.  

2. Thöïc hieän moät trong nhöõng thao taùc sau:  

♦ 

♦ 

Hieäu chænh vò trí cuûa maáu neo trong 
ñöôøng cong ñoù vaø keùo ñieåm ñoù.  

Hieäu chænh hình daïng cuûa ñöôøng cong 
treân caû hai maët cuûa maáu neo ñoù, sau 
ñoù keùo ñieåm ñoù hoaëc keùo handle tieáp 
tuyeán ñoù. Trong khi keùo nhôù nhaán 
phím Shift ñeå coá ñònh goùc 450.  

  

VEÕ BAÈNG COÂNG CUÏ BRUSH  

Coâng cuï Brush taïo ra caùc neùt veõ gioáng nhö coï gioáng nhö  theå baïn ñang sôn. Noù cho pheùp 
taïo ra caùc hieäu öùng ñaëc bieät, caùc hieäu öùng taïo ra chöõ ñeïp. Trong haàu heát tröôøng hôïp, caùc baûng 
choïn ñeàu deã söû duïng, baïn coù nhieàu caùch hieäu chænh ñoä roäng vaø choïn neùt veõ cuûa coï veõ baèng caùch 
nhaáp chuoät vaøo choïn caây buùt veõ Stylus.  Baïn coù theå duøng aûnh Bitmap nhaäp vaøo khi duøng coâng 
cuï Brush ñeå veõ.  

  
Choïn buùt veõ vôùi neùt coï veõ lôùn   

 Veõ baèng coâng cuï Brush:  

1. Choïn coâng cuï Brush.   

2. Choïn moät maøu cho coï veõ. Baïn coù theå xem muïc “Xaùc ñònh caùc thuoäc tính cho neùt 
coï veõ vaø maøu veõ”. 

TUÛ  SAÙCH STK – THEÁ GIÔÙI ÑOÀ HOÏA                                                                                                          BIEÂN SOAÏN : KS PHAÏM QUANG HUY 65 



GIAÙO TRÌNH THIEÁT KEÁ WEB : PHAÀN LYÙ THUYEÁT - TÖÏ HOÏC MACROMEDIA FLASH 5.0 BAÈNG HÌNH AÛNH                 CHÖÔNG 2 
 

3. Nhaáp  chuoät choïn moät trong caùc cheá ñoä trong baûng boå sung vaø choïn moät cheá ñoä 
veõ:  

Cheá ñoä veõ Paint Normal veõ caùc ñöôøng thaúng 
vaø phuû ñaày maøu treân cuøng moät Layer. 

Cheá ñoä veõ Paint Fills toâ maøu caùc vuøng troáng, 
caùc ñöôøng thaúng khoâng bò thay ñoåi.  

Cheá ñoä veõ Paint Behind toâ caùc choã troáng trong 
vuøng Stage treân cuøng Layer, caùc ñöôøng thaúng 
khoâng thay ñoåi maøu.  

Cheá ñoä Paint Selection aùp ñaët vuøng maøu môùi 
vaøo vuøng choïn khi baïn choïn moät maøu trong 
vuøng boå sung maøu Fill hoaëc trong baûng Fill. 
(Tuøy choïn naøy gioáng nhö vieäc choïn moät vuøng 
maøu ñaõ toâ vaø aùp ñaët moät maøu môùi). 

 
 

♦ 

♦ 

♦ 

♦ 

Cheá ñoä veõ Paint Inside  veõ toâ maøu beân trong vuøng choïn, chuùng khoâng cho 
pheùp baïn toâ maøu beân ngoaøi caùc ñöôøng ñöôïc choïn. Neáu baïn baét ñaàu veõ trong 
vuøng troáng, vieäc toâ maøu seõ khoâng aûnh höôûng ñeán vuøng maøu ñaõ toâ toàn taïi.  

♦ 

 

AÛnh goác  vôùi cheá ñoä Paint Normal, Paint Behind, Paint Selection, Paint Fills vaø Paint Inside 

4. Choïn kích thöôùc coï veõ, hình daùng coï vaø maøu coï veõ 
trong baûng boå sung coâng cuï  Brush. 

5. Neáu caùc baûng caùc coâng cuï boå sung ñöôïc gaén vaøo 
maùy tính cuûa baïn, baïn coù theå choïn vuøng coâng cuï boå 
sung Pressure naøy ñeå thay ñoåi ñoä roäng cuûa neùt coï veõ  
baèng caùch thay ñoåi buùt coï veõ Stylus. 

6. Keùo chuoät trong vuøng Stage. Trong khi keùo chuoät 
vaøo vuøng Stage, baïn haõy nhaán  phím Shift ñeå coá 
ñònh neùt coï veõ theo höôùng ñöôøng thaúng vaø ñöôøng 
ngang.  

 
                                                 Baûng caùc coâng cuï veõ boå sung trong baûng coâng cuï 
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PHUÏC HOÀI HÌNH DAÏNG ÑÖÔØNG THAÚNG VAØ ÑÖÔØNG VIEÀN  NGOAØI 

Baïn coù theå thay ñoåi hình daïng ñöôøng thaúng vaø ñöôøng vieàn ngoaøi ñöôïc taïo ra baèng caùc 
coâng cuï Pencil, Brush, Line, Oval hoaëc Rectangle baèng caùch choïn coâng cuï Arrow vaøo keùo vaøo 
ñoái töôïng hoaëc baèng caùch toái öu caùc ñöôøng cong.  

Ngoaøi ra baïn cuõng coù theå  duøng coâng cuï Subselection ñeå hieån thò taát caû caùc ñieåm treân 
ñöôøng thaúng vaø ñöôøng vieàn ngoaøi vaø thay ñoåi  caùc ñöôøng thaúng vaø ñöôøng vieàn ngoaøi baèng caùch 
hieäu chænh nhöõng ñieåm naøy.  

Baïn coù theå cho hieån thò caùc ñieåm maáu neo treân ñöôøng thaúng hoaëc ñöôøng vieàn ngoaøi ñöôïc 
taïo ra baèng caùc coâng cuï Pencil, Brush, Line, Oval hoaëc Rectangle.  

Choïn coâng cuï Subselection. ♦ 

♦ Nhaáp chuoät vaøo moät ñöôøng thaúng hoaëc ñöôøng vieàn ngoaøi. 

     
Duøng coâng cuï Subselection taïo vuøng choïn sau ñoù nhaáp chuoät vaøo ñöôøng thaúng hoaëc ñöôøng vieàn ngoaøi ñeå thay ñoåi 
hình daïng cuûa noù  

THAY ÑOÅI HÌNH DAÏNG DUØNG COÂNG CUÏ ARROW  

Ñeå thay ñoåi hình daïng ñöôøng thaúng hoaëc ñöôøng vieàn ngoaøi, baïn coù theå duøng coâng cuï 
Arrow  keùo  vaøo baát kyø  ñieåm naøo coù treân ñöôøng thaúng. Luùc naøy con troû thay ñoåi ñeå chæ ra kieåu 
hình daùng cuûa ñoái töôïng bò thay ñoåi.  

            Flash hieäu chænh ñöôøng cong cuûa ñoaïn thaúng laøm cho 
phuø hôïp vôùi vò trí môùi cuûa ñieåm di chuyeån. Neáu caùc ñieåm ñöôïc 
ñònh vò laïi laø ñieåm cuoái, baïn coù theå laøm cho ñöôøng thaúng daøi 
hôn hoaën ngaén hôn. Neáu caùc ñieåm ñöôïc ñònh vò laïi laø ñieåm 
goác, caùc ñoaïn thaúng vaãn giöõ caùc goùc khi chuùng thay ñoåi daøi 
hôn hoaëc ngaén hôn. 

 

Khi moät goùc vuoâng xuaát hieän keá beân con troû, baïn coù theå thay ñoåi ñieåm cuoái. Trong khi 
moät ñöôøng cong xuaát hieän keá beân con troû, baïn coù theå hieäu chænh cho ñöôøng thaúng hoaëc ñöôøng 
cong ñoù cong hôn. Neáu baïn gaëp raéc roái veà vieäc thay ñoåi hình daïng cuûa moät ñöôøng thaúng phöùc 
taïp, baïn coù theå laøm nhaün noù ñeå loaïi boû moät soá chi tieát, taïo laïi cho hình daùng deã nhìn hôn. Vieäc 
laøm taêng ñoä phoùng ñaïi coù theå giuùp cho vieäc thay ñoåi hình daïng cuûa ñoái töôïng deã daøng vaø chính 
xaùc hôn.   

 Thay ñoåi hình daïng ñöôøng thaúng vaø ñöôøng vieàn ngoaøi duøng coâng cuï Arrow: 
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1. Choïn coâng cuï Arrow. 

2. Choïn moät trong hai thao taùc sau:  

Keùo baát kyø ñieåm naøo treân ñoaïn thaúng ñeå ñònh daïng laïi hình daùng. ♦ 

♦ Keùo chuoät vaøo moät ñöôøng thaúng vaø nhaán phím Ctrl (trong Windows)  hoaëc 
phím Option (trong Macintosh)  ñeå taïo ra moät ñieåm goác môùi.  

LAØM THAÚNG VAØ NHAÜN CAÙC ÑÖÔØNG THAÚNG  

Baïn coù theå  thay ñoåi hình daùng ñöôøng thaúng vaø ñöôøng vieàn ngoaøi baèng caùch laøm thaúng 
hoaëc nhaün chuùng.  

Chuù yù :   Hieäu chænh goùc ñoä laøm nhaün vaø thaúng töï ñoäng baèng caùch choïn caùc cheá ñoä thieát laäp veõ 
coù trong trình ñôn Edit > Preferences.  

 

Vieäc laøm thaúng caùc ñöôøng thaúng vaø ñöôøng cong seõ taïo ra söï thay ñoåi  nhoû khi baïn veõ. Noù 
khoâng coù taùc duïng ñoái vôùi ñoaïn thaúng.  

Ngoaøi ra, baïn coù theå duøng kyõ thuaät 
laøm thaúng ñeå taïo ra nhöõng hình daïng nhaän 
daïng khaùc nhau trong Flash. Neáu baïn veõ 
hình oâ-van, hình chöõ nhaät hoaëc hình tam 
giaùc vôùi tuøy choïn  Recognize Shapes taét ñi, 
baïn coù theå duøng tuøy choïn Straightening ñeå 
laøm cho nhöõng hình daïnh naøy hoaøn haûo hôn. 
(Baïn coù theå xem muïc “Caùch choïn caùc cheá 
ñoä thieát laäp veõ” ñeå bieát theâm chi tieát veà muïc 
tuøy choïn Recognize Shapes trong trình ñôn 
Edit > Preferences). Caùc hình daïng khoâng 
ñöôïc nhaän daïng maø chuùng chaïm nhau khi 
baïn veõ, chuùng seõ töï noái keát ñeán caùc thaønh 
phaàn khaùc keá noù. 

 
Cheá ñoä nhaän daïng hình daùng chuyeån daïng hình treân sang 

daïng hình beân döôùi   
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Vieäc laøm nhaün seõ laøm meàm caùc caïnh cong vaø laøm giaûm ñoä naûy hoaëc caùc cheá ñoä rung 
trong taát caû caùc höôùng oâ-van cuûa ñöôøng cong.  Ngoaøi ra, noù coøn laøm giaûm soá löôïng ñoaïn cong. 
Tuy nhieân vieäc laøm nhaün raát caân ñoái vaø khoâng coù taùc ñoäng ñeán ñoaïn thaúng.  

Ñaëc bieät, ñieàu naøy raát coù ích khi baïn gaëp raéc roái vôùi vieäc laøm thay ñoåi hình daïng cuûa moät 
soá ñoaïn thaúng cong ngaén. Choïn taát caû caùc ñoaïn vaø laøm nhaün caùc ñoaïn taïo ra moät ñöôøng cong 
nheï nhaøng deã daøng thay ñoåi hình daïng.  

Laëp laïi öùng duïng laøm nhaün laøm cho moãi ñoaïn nhaün vaø thaúng hôn phuï thuoäc vaøo  moãi 
ñoaïn cong vaø ñoaïn thaúng goác ban ñaàu.  

2. Laøm nhaün ñoä cong cuûa moãi ñöôøng vieàn ñöôïc choïn hoaëc 
ñöôøng cong:  

Choïn coâng cuï Arrow vaø nhaáp chuoät vaøo vuøng coâng cuï boå 
sung Smooth trong vuøng tuøy choïn Options cuûa hoäp coâng 
cuï hoaëc choïn trong trình ñôn Modify > Smooth.   

 
 

3. Taïo söï thay ñoåi thaúng nhoû trong moãi vieàn ñöôïc choïn hoaëc 
ñöôøng cong:  

Choïn coâng cuï Arrow vaø nhaáp chuoät vaøo vuøng coâng cuï boå 
sung Straighten trong vuøng tuøy choïn Options cuûa hoäp coâng 
cuï hoaëc choïn trong trình ñôn Modify > Straighten.   

  
 

4. Duøng cheá ñoä nhaän daïng 

Choïn coâng cuï Arrow vaø nhaáp chuoät vaøo vuøng coâng cuï boå sung Straighten hoaëc choïn  
trong trình ñôn Modify > Straighten.   

 

TOÁI ÖU HOAÙ CAÙC ÑÖÔØNG CONG   

Caùch khaùc ñeå laøm nhaün caùc ñöôøng cong laø toái öu hoaù chuùng.  Ñieàu naøy seõ laøm caûi tieán 
caùc ñöôøng cong  vaø ñöôøng vieàn ngoaøi baèng caùch laøm giaûm soá löôïng ñöôøng cong ñöôïc duøng ñeå 
xaùc ñònh nhöõng thaønh phaàn naøy. 

Ngoaøi ra, vieäc toái öu hoaù cuõng laøm giaûm kích thöôùc ñoaïn phim trong Flash vaø xuaát ra file 
Flash Player.  Vôùi caùc coâng cuï boå sung Smooth hay Straighten hoaëc caùc leänh coù trong trình ñôn, 
baïn coù theå aùp duïng caùc cheá ñoä toái öu hoaù caùc thaønh phaàn nhieàu laàn.  

Caùch toái öu hoaù caùc caùc ñöôøng cong 

1. Choïn caùc thaønh phaàn ñaõ veõ ñeå toái öu hoaù chuùng vaø choïn treân trình ñôn  Modify > 
Optimize. 

2. Trong  hoäp thoaïi Optimize Curves, keùo con tröôït Smoothing ñeå xaùc ñònh goùc ñoä 
laøm nhaün.  Keát quaû chính xaùc phuï thuoäc vaøo ñoä cong ñöôïc choïn. Noùi chung vieäc 
toái öu hoaù taïo ra moät soá ñöôøng cong ít hôn, goùc ñoä gioáng ñöôøng vieàn goác  ít hôn.  

TUÛ  SAÙCH STK – THEÁ GIÔÙI ÑOÀ HOÏA                                                                                                          BIEÂN SOAÏN : KS PHAÏM QUANG HUY 69 



GIAÙO TRÌNH THIEÁT KEÁ WEB : PHAÀN LYÙ THUYEÁT - TÖÏ HOÏC MACROMEDIA FLASH 5.0 BAÈNG HÌNH AÛNH                 CHÖÔNG 2 
 

 
3. Thieát laäp caùc tuøy choïn  boå sung. 

Choïn muïc Use Multiple Passes (Slower) laëp laïi quaù trình laøm nhaün cho ñeán 
khi khoâng coøn cheá ñoä toái öu hoaù naøo nöõa. Ñieàu naøy gioáng nhö vieäc choïn cheá 
ñoä toái öu hoaù laëp laïi nhieàu laàn treân cuøng moät thaønh phaàn chonï.  

♦ 

♦ Choïn muïc  Show Totals Message ñeå hieån thò hoäp thoaïi thay ñoåi chæ ra möùc 
toái öu hoaù khi cheá ñoä laøm nhaün ñöôïc choïn.  

 
4. Sau ñoù nhaáp OK. 

COÂNG CUÏ XOAÙ   

Xoaù baèng coâng cuï Eraser seõ loaïi boû taát caùc caùc maøu vaø ñöôøng neùt veõ. Baïn coù theå xoaù 
moät caùch nhanh choùng  moïi thöù coù trong vuøng Stage, xoaù töøng ñoaïn vieàn neùt veõ, vuøng maøu hoaëc 
duøng chuoät keùo taùch bieät nhau.  

Baïn coù theå toái öu hoaù coâng cuï Eraser ñeå chæ coù xoaù caùc neùt veõ, vuøng maøu hoaëc chæ moät 
vuøng maøu ñoäc laäp.  Coâng cuï Eraser  coù theå  choïn laø hình vuoâng hoaëc hình caàu, vaø noù coù moät 

trong naêm kích thöôùc khaùc nhau.   

Ñeå xoaù taát caû moïi thöù  coù trong vuøng Stage moät caùch nhanh choùng tieán haønh baèng caùch  
nhaáp ñuùp chuoät vaøo coâng cuï xoaù.   

 Xoaù moät ñoaïn neùt veõ hoaëc vuøng maøu. 

1. Choïn coâng cuï Eraser vaø sau ñoù nhaáp chuoät vaøo vuøng coâng 

cuï boå sung choïn  Faucet .   

2. Nhaáp chuoät vaøo ñoaïn neùt veõ hoaëc vuøng maøu maø baïn 
muoán xoaù.   

 Xoaù baèng caùch keùo chuoät 

1. Nhaáp chuoät choïn coâng cuï Eraser. 

2. Nhaáp chuoät choïn Eraser Mode trong vuøng coâng cuï boå sung vaø choïn moät trong 
nhöõng cheá ñoä xoaù sau:  
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♦ 

♦ 

♦ 

♦ 

Cheá ñoä Erase Normal xoaù caùc ñöôøng vieàn vaø 
neùt veõ treân cuøng moät Layer.  

Cheá ñoä Erase Fills chæ xoaù caùc maøu toâ; caùc 
ñöôøng neùt veõ khoâng bò aûnh höôûng.  

Cheá ñoä Erase Lines chæ xoaù caùc ñöôøng neùt veõ, 
maøu toâ khoâng  bò aûnh höôûng.  

Cheá ñoä Erase Selected Fills chæ xoaù caùc vuøng 
maøu hieän haønh, khoâng laøm aûnh höôûng ñeán caùc 
maøu choïn hoaëc ñöôøng neùt veõ. (Choïn vuøng maøu 
baïn muoán xoaù tröôùc khi duøng coâng cuï Eraser 
trong cheá ñoä naøy.) 

 
 

♦ Cheá ñoä Erase Inside chæ xoaù vuøng maøu maø 
baïn baét ñaàu xoaù ñöôøng neùt veõ. Neáu baïn baét 
ñaàu xoaù moät ñieåm troáng, seõ khoâng xoaù ñöôïc. 
Caùc ñöôøng neùt veõ khoâng bò aûnh höôûng trong 
cheá ñoä xoaù naøy.  

3. Nhaáp chuoät vaøo vuøng coâng cuï boå sung vaø choïn 
coâng cuï Eraser Shape. Sau ñoù choïn moät loaïi coâng 
cuï xoaù coù trong baûng. Baûo ñaûm raèng cheá ñoä Faucet 
chöa choïn. 

4. Keùo chuoät vaøo trong vuøng Stage. 

 

 

 

THAY ÑOÅI HÌNH DAÏNG CUÛA ÑOÁI TÖÔÏNG  

Baïn coù theå laøm thay ñoåi hình daïng cuûa ñoái töôïng baèng caùch bieán ñoåi caùc ñöôøng thaúng 
sang vuøng maøu toâ, môû roäng hình daïng cuûa ñoái töôïng ñöôïc toâ maøu, hoaëc laøm meàm caùc goùc ñöôïc 
toâ maøu baèng caùch thay ñoåi caùc daïng ñöôøng cong.  

Ñaëc tính Lines to Fills thay ñoåi ñöôøng thaúng sang vuøng maøu, cho pheùp baïn toâ maøu ñöôøng 
thaúng baèng maøu Gradients  hoaëc xoaù moät phaàn cuûa ñöôøng thaúng. Caùc ñaëc tính Expand Shape vaø 
Soften Edges cho pheùp baïn môû roäng caùc ñoái töôïng ñöôïc toâ maøu vaø laøm môø caùc goùc.  

Leänh Expand Shape vaø Soften Edges laøm vieäc toát treân caùc ñoái töôïng nhoû khoâng coù 
nhieàu chi tieát nhoû. AÙp ñaët leänh Soften Edges vaø caùc ñoái töôïng nhieàu chi tieát coù theå laøm taêng 
kích thöôùc file Flash Player.  

 Bieán ñoåi ñöôøng thaúng thaønh maøu toâ:   

a. Choïn moät hoaëc nhieàu ñöôøng thaúng.  

b. Choïn  trong trình ñôn  Modify > Shape > Convert Lines to Fills. 

Caùc ñöôøng thaúng ñöôïc choïn bò thay ñoåi thaønh caùc daïng ñöôïc toâ maøu. Vieäc chuyeån 
ñoåi ñöôøng thaúng thaønh maøu toâ coù theå laøm kích thöôùc file lôùn hôn nhöng noù coù theå 
laøm taêng toác ñoä veõ cho caùc ñoái töôïng chuyeån ñoäng.  
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1. Môû roäng hình daïng cuûa ñoái töôïng ñöôïc toâ maøu:  

1. Choïn moät ñoái töôïng ñaõ ñöôïc toâ maøu. Leänh naøy hoaït ñoäng toát nhaát treân caùc ñoái 
töôïng ñöôïc toâ moät maøu vaø khoâng coù ñöôøng vieàn.  

2. Choïn trong trình ñôn  Modify > Shape > Expand Fill. 

 

3. Trong hoäp thoaïi Expand Fill,  nhaäp vaøo moät giaù trò pixel trong muïc Distance vaø 
choïn muïc Expand hoaëc Inset trong tuøy choïn Direction. Muïc Expand môû roäng 
kích thöôùc ñoái töôïng vaø muïc  Inset laøm nhoû kích thöôùc cuûa ñoái töôïng. 

 

2. Caùch laøm meàm caùc goùc cuûa ñoái töôïng:  

1. Choïn moät ñoái töôïng ñaõ ñöôïc toâ maøu. Leänh naøy hoaït ñoäng toát nhaát treân caùc ñoái 
töôïng ñöôïc toâ moät maøu vaø khoâng coù ñöôøng vieàn. 

2. Choïn treân trình  ñôn Modify > Shape > Soften Fill Edges. Thieát laäp caùc tuøy 
choïn sau ñaây: 

Muïc Distance laø ñoä roäng cuûa caùc ñieåm pixel trong caùc goùc meàm. ♦ 

 

  Muïc Number of Steps ñieàu khieån soá ñöôøng cong seõ ñöôïc söû duïng cho caùc hieäu 
öùng goùc meàm. Taïo ra theâm nhieàu böôùc nöõa trong muïc naøy seõ laøm cho hieäu öùng 
caøng nhaün hôn vaø cuõng laøm cho kích thöôùc file caøng lôùn.   

♦ 

♦  Caùc muïc Expand hoaëc Inset ñieàu khieån hình daïng cuûa ñoái töôïng seõ lôùn leân hoaëc  
nhoû laïi ñeå laøm meàm caùc goùc.  

TUÛ  SAÙCH STK – THEÁ GIÔÙI ÑOÀ HOÏA                                                                                                          BIEÂN SOAÏN : KS PHAÏM QUANG HUY 72 



GIAÙO TRÌNH THIEÁT KEÁ WEB : PHAÀN LYÙ THUYEÁT - TÖÏ HOÏC MACROMEDIA FLASH 5.0 BAÈNG HÌNH AÛNH                 CHÖÔNG 2 
 

CHEÁ ÑOÄ BAÉT DÍNH ( SNAP) 

Ñeå saép xeáp caùc thaønh phaàn coù trong vuøng Stage töï ñoäng baét dính vaøo nhau, baïn coù theå 
duøng cheá ñoä Snap (baét dính).  Cheá ñoä Snap naøy coù theå môû taïi vuøng coâng cuï boå sung khi baïn 
choïn coâng cuï Arrow, hoaëc choïn leänh Snap to Objects trong trình ñôn View.  

     

Chuù yù :  Ngoaøi ra baïn coù theå choïn cheá ñoä baét dính vaøo khung löôùi hoaëc vaøo ñöôøng Guide.  

Neáu vuøng coâng cuï boå sung khi baïn choïn coâng cuï Arrow ñöôïc môû, seõ xuaát hieän cheá ñoä  
Snap, moät voøng ñen nhoû xuaát hieän beân döôùi con troû khi baïn keùo moät ñoái töôïng. Voøng nhoû naøy 
thay ñoåi sang voøng lôùn hôn khi ñoái töôïng naèm trong khoaûng caùch ñöôøng khung löôùi.  

Ñeå môû hoaëc taét cheá ñoä Snap, baïn haõy choïn moät trong hai cheá ñoä sau: 

Choïn coâng cuï Arrow vaø nhaáp chuoät vaøo vuøng coâng cuï boå sung Snap trong hoäp 
coâng cuï. 

♦ 

♦ Choïn treân trình ñôn View > Snap to 
Objects.  Moät daáu kieåm seõ xuaát hieän 
phía tröôùc leänh Snap to Object  khi 
cheá ñoä Snap ñöôïc choïn.  

 

Khi baïn di chuyeån hoaëc thay ñoåi hình daùng cuûa ñoái töôïng, vò trí cuûa coâng cuï  Arrow trong 
ñoái töôïng ñoù seõ cung caáp con troû tham chieáu ñeán vuøng Snap naøy. Chaúng haïn nhö neáu baïn di 
chuyeån moät ñoái töôïng ñöôïc toâ maøu baèng caùch keùo ñoái töôïng ñoù ñeán gaàn taâm cuûa noù,  con troû 
taâm seõ baét dính vaøo ñoái töôïng khaùc. Ñaëc bieät ñieàu naøy raát coù ích cho vieäc baét dính caùc ñoái töôïng 
chuyeån ñoäng thay ñöôøng daãn chuyeån ñoäng.    

3. Caùch hieäu chænh dung sai cuûa cheá 
ñoä Snap:  

Hieäu chænh cheá ñoä thieát laäp muïc 
Connect Lines beân döôùi muïc tuøy choïn  
Drawing Settings trong trình ñôn Edit 
> Preferences.  

 
 

CHOÏN CAÙC CHEÁ ÑOÄ THIEÁT LAÄP CHO COÂNG CUÏ VEÕ   

Baïn coù theå thieát laäp caùc cheá ñoä cho nhöõng coâng cuï veõ ñeå xaùc ñònh caùc haønh vi nhö baét 
dính, laøm nhaün hay laøm thaúng ñoái töôïng khi baïn duøng caùc coâng cuï veõ trong Flash. Baïn coù theå 
thay ñoåi caùc cheá ñoä thieát laäp Tolerance (sai soá) trong moãi tuøy choïn vaø taét hoaëc môû caùc tuøy choïn 
naøy. 
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 Cheá ñoä thieát laäp Tolerance töông ñoái phuï thuoäc vaøo ñoä phaân giaûi cuûa maøu hình maùy tính 
cuûa baïn vaø ñoä phoùng ñaïi hieän haønh cuûa moät Scene. Theo maëc ñònh, moãi tuøy choïn môû leân coù cheá 
ñoä thieát laäp Tolerance laø Normal.  

 Caùch thieát laäp caùc cheá ñoä thieát laäp cho coâng cuï veõ:   

1. Choïn treân trình ñôn Edit > Preferences vaø nhaáp chuoät vaøo tab  Editing. 

2. Beân döôùi muïc Drawing Settings, baïn coù theå choïn moät trong caùc tuøy choïn sau:  

 
 Muïc choïn Connect Lines xaùc ñònh ñöôøng veõ keát thuùc cuûa moät ñoaïn thaúng ñang 

toàn taïi tröôùc khi baét dính vaøo ñieåm gaàn nhaát cuûa moät ñoaïn thaúng khaùc. Caùc tuøy 
choïn saün coù laø Must Be Close, Normal vaø Can Be Distant. Ngoaøi ra cheá ñoä thieát 
laäp naøy ñieàu khieån söï nhaän bieát ñöôøng thaúng ngang vaø doïc trong  Flash giuùp baïn 
veõ ra caùc ñöôøng thaúng ngang vaø doïc moät caùch chính xaùc. Khi baïn choïn tuøy choïn 
Snap to Objects, cheá ñoä thieát laäp naøy ñieàu khieån caùc ñoái töôïng gaàn nhau ñöôïc baét 
dính vaøo nhau.  

 Muïc choïn Smooth Curves xaùc ñònh  ñoä nhaün aùp ñaët vaøo ñöôøng cong veõ baèng 
coâng cuï Pencil khi baïn thieát laäp cheá ñoä veõ  Straighten hoaëc Smooth. (Caùc ñöôøng 
cong caøng nhaün caøng deã thay ñoåi hình daùng ñoái töôïng trong khi ñoù caùc ñöôøng 
cong thoâ keät lôûm chôûm caøng laøm cho caùc ñöôøng veõ gioáng ñöôøng veõ ban ñaàu).  
Caùc tuøy choïn laø  Off, Rough, Normal vaø Smooth. 

Chuù yù :  Baïn coù theå laøm nhaün caùc ñoaïn cong hôn duøng trình ñôn Modify > Smooth vaø Modify > 
Optimize.  

 Muïc choïn Recognize Lines xaùc ñònh caùc ñoaïn thaúng gaàn nhö thaúng khi duøng 
coâng cuï veõ Pencil tröôùc khi Flash nhaän daïng vaø laøm noù thaúng hoaøn toaøn. Caùc muïc 
choïn laø Off, Strict, Normal vaø Tolerant. Neáu baïn taét muïc Recognize Lines trong 
khi veõ, sau ñoù baïn coù theå laøm thaúng caùc ñöôøng thaúng baèng caùch choïn moät hoaëc 
nhieàu ñoaïn thaúng vaø choïn trong trình ñôn Modify > Straighten. 

 
 Muïc choïn Recognize Shapes ñieàu khieån chính xaùc vieäc nhaän daïng vaø veõ laïi 

caùc daïng hình hoïc maø baïn veõ nhö caùc ñöôøng troøn, hình oâ-van, hình vuoâng, hình 
chöõ nhaät vaø caùc hình cung 900 vaø1800 moät caùch chính xaùc. Caùc tuøy choïn laø Off, 
Strict, Normal vaø Tolerant. Neáu baïn taét muïc Recognize Shapes trong khi veõ 
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baïn coù theå laøm thaúng caùc ñöôøng thaúng sau ñoù baèng caùch choïn moät hoaëc nhieàu 
hình, (chaúng haïn nhö caùc ñoaïn thaúng ñöôïc noái laïi vôùi nhau) vaø choïn trong trình 
ñôn Modify > Straighten. 

 Nhaáp chuoät vaøo muïc choïn 
Accuracy xaùc ñònh caùc kieåu 
con troû tröôùc khi Flash nhaän 
daïng chuùng. Caùc tuøy choïn laø  
Strict, Normal, vaø Tolerant.  

          Caùc baïn ñaõ hoïc xong caùch duøng caùc coâng cuï veõ cô baûn, tröôùc khi qua hoïc tieáp phaàn lyù 
thuyeát toâ maøu caùc baïn haõy laøm thöû caùc baøi taäp maãu sau ñeå roõ hôn phaàn lyù thuyeát.  

          Caàn chuù yù laø nhôù löu keát quaû ñeå duøng laïi trong phaàn thöïc hieän phim hoaït hình ôû caùc 
chöông sau. Caùc baøi taäp naøy ñöôïc bieân soaïn thöïc haønh treân Flash nhöng cuõng raát toát cho vieäc 
hoïc CorelDraw, Illustrator hay Freehand. Caùc baïn haõy thöû thöïc haønh vôùi caùc baøi taäp naøy seõ thaáy 
nhöõng ñieåm raát lyù thuù vôùi theá giôùi ñoà hoïa. Chæ qua nhöõng phaùt thaûo laø caùc ñöôøng thaúng vaø 
ñöôøng troøn caùc baïn ñaõ taïo ra nhieàu khuoân maët vôùi tính caùch khaùc nhau. Coá gaéng nhaän xeùt caùc 
neùt veõ tröôùc khi baét ñaàu thöïc haønh veõ caùc hình sau. 

          Do trong baøi thöïc taäp caàn phaûi ñoå maøu, trong khi chöông 4 : Ñoå maøu, caùc baïn chöa ñöôïc 
höôùng daãn söû duïng. Caùc baïn haõy nhaûy tôùi chöông 4 ñeå xem phaàn lyù thuyeát. Caùc baïn coù theå cho 
laø vieäc boá trí chöông nhö theá chöa hôïp lyù nhöng theo nhoùm bieân soaïn neáu ñeå hoïc xong phaàn ñoå 
maøu roài môùi tôùi phaàn baøi taäp caùc baïn seõ mau chaùn naûn vôùi phaàn lyù thuyeát quaù nhieàu ôû quyeån 
saùch naøy.   

 

 
 

 

 

 

 

 

 

 

 

 

 

TUÛ  SAÙCH STK – THEÁ GIÔÙI ÑOÀ HOÏA                                                                                                          BIEÂN SOAÏN : KS PHAÏM QUANG HUY 75 


	CAÙC COÂNG CUÏ VEÕ VAØ TOÂ MAØU TRONG  FLASH
	CAÙC HÌNH DAÏNG CHOÀNG LAÁP  \(OVERLAPPING SH
	VEÕ BAÈNG COÂNG CUÏ PENCIL
	VEÕ ÑÖÔØNG THAÚNG, HÌNH BAÀU DUÏC VAØ HÌNH�
	DUØNG COÂNG CUÏ PEN
	THIEÁT LAÄP CAÙC MÖÙC ÖU TIEÂN CHO COÂNG CU�
	
	
	
	Caùch thieát  laäp möùc öu tieân cho coâng c�




	VEÕ ÑÖÔØNG THAÚNG BAÈNG COÂNG CUÏ PEN
	VEÕ ÑÖÔØNG CONG BAÈNG COÂNG CUÏ PEN
	HIEÄU CHÆNH CAÙC MAÁU NEO TREÂN ÑÖÔØNG VEÕ
	HIEÄU CHÆNH CAÙC ÑOAÏN
	VEÕ BAÈNG COÂNG CUÏ BRUSH
	PHUÏC HOÀI HÌNH DAÏNG ÑÖÔØNG THAÚNG VAØ ÑÖ
	THAY ÑOÅI HÌNH DAÏNG DUØNG COÂNG CUÏ ARROW
	LAØM THAÚNG VAØ NHAÜN CAÙC ÑÖÔØNG THAÚNG
	Choïn coâng cuï Arrow vaø nhaáp chuoät vaøo v
	TOÁI ÖU HOAÙ CAÙC ÑÖÔØNG CONG
	COÂNG CUÏ XOAÙ
	THAY ÑOÅI HÌNH DAÏNG CUÛA ÑOÁI TÖÔÏNG
	CHEÁ ÑOÄ BAÉT DÍNH \( SNAP\)
	CHOÏN CAÙC CHEÁ ÑOÄ THIEÁT LAÄP CHO COÂNG CU�

