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Tuyên b  b n quy nố ả ề

Giáo trình này s  d ng làm tài li u gi ng d y n i b  trong tr ngử ụ ệ ả ạ ộ ộ ườ  

cao đ ng ngh  Công nghi p Hà N iẳ ề ệ ộ

Tr ng Cao đ ng ngh  Công nghi p Hà N i không s  d ng vàườ ẳ ề ệ ộ ử ụ  

không cho phép b t k  cá nhân hay t  ch c nào s  d ng giáo trình nàyấ ỳ ổ ứ ử ụ  

v i m c đích kinh doanh.ớ ụ

M i trích d n, s  d ng giáo trình này v i m c đích khác hay ọ ẫ ử ụ ớ ụ ở 

n i khác đ u ph i đ c s  đ ng ý b ng văn b n c a tr ng Cao đ ngơ ề ả ượ ự ồ ằ ả ủ ườ ẳ  

ngh  Công nghi p Hà N iề ệ ộ



M  Đ uở ầ

After Effects (AE) là m t trong các ch ng trình x  lý phim chuyên nghi p ộ ươ ử ệ

(Edit film) và d  s  d ng do hãng Adobe phát tri n.ễ ử ụ ể

AE giúp qu n lý các giao di n cũng nh  cách qu n lý m t Project hay nh ng ả ệ ư ả ộ ữ

effect th ng dùng trong phim  nh. Cung c p các công c  v  cách làm k  x oườ ả ấ ụ ề ỷ ả  

phim, v  chuy n đ ng, timming, nh p…ề ể ộ ị

Ph n 1 ầ

GIAO DI N Ệ

Đ u tiên chúng ta s  làm quen v  Giao di n (Interface), hay Vùng làm vi c ầ ẽ ề ệ ệ

(WorkSpace) c a After Effects (AE).ủ

Vùng nhìn Project: Qu n lý các files import. ả

Composition panel: Gi ng nh  monitor, s  hi n th  k t qu  sau khi x  lý. ố ư ẽ ể ị ế ả ử
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Timeline: Đi u khi n animation, effects… theo th i gian. ề ể ờ

 M  1 vùng làm vi c m i: Ch n open m t workspace đ nh s n c a AE ở ệ ớ ọ ộ ị ẵ ủ

b ng cách :ằ

Ho c chúng ta đi u ch nh kích th c c a t ng panel, b ng cách đ a con tr  ặ ề ỉ ướ ủ ừ ằ ư ỏ

chu t vào gi a hai panel:ộ ữ
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Dock, group, or float panels: 

B n có th  di chuy n các panel b ng cách kéo các chúng s p x p theo t ng ạ ể ể ằ ắ ế ừ

nhóm (group) khác nhau.

Ho c rightclick góc trên panel, ch n undock panel.ặ ọ
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Các icon trong panel:

Dùng mouse wheel, b n có th  phóng l n thu nh  vùng nhìn composite. ạ ể ớ ỏ

Alt + mouse wheel, phóng l n vùng nhìn Timeline. ớ

Gi  Spacebar + mouse left đ  pan. ữ ể

Right click trên toolbar b n có th   n ho c hi n các c t nh  hình v . ạ ể ẩ ặ ệ ộ ư ẽ

Ho c t i góc m i viewer có các icon tam giác b n có th  click vào : ặ ạ ỗ ạ ể
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T i vùng nhìn Composition (góc trái bên d i), b n click vào icon (Always ạ ướ ạ

Preview This view) thì m i l n b n th c hi n preview ch  c a s  này m i ỗ ầ ạ ự ệ ỉ ử ổ ớ

view cho b n. ạ
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 icon k  bên, b n b t Title/Action Safe : Ở ế ạ ậ

Lúc này s  xu t hi n vùng nhìn an toàn trên viewer composition :ẽ ấ ệ
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Cũng nh  các ch ng trình khác, thanh Toolbar trên góc trái màn hình có các ư ươ

ch c năng :ứ
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PH N 2 Ầ TH C HI N M T PROJECTỰ Ệ Ộ

Tr c khi b t tay vào edit hay làm effects m t đ an phim nào đó, chúng ta ướ ắ ộ ọ

ph i s p x p các hình  nh, âm thanh, k ch b n…. T c là th c hi n m t ả ắ ế ả ị ả ứ ự ệ ộ

Project.

1 – Setup Projects:

Vào menu File> New Project

Ti p theo ch n Files/project settings:ế ọ
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T i Timecode base, ch n 25fpt (25 frame per secon cho h  PAL video) và ạ ọ ệ

Audio setting chon Sample Rate 41.100 kHz

2.T o Composition m iạ ớ

C1: T i menu Composition/New Composition (Ctr+N).ạ

C2: Nháy vào bi u t ng ể ượ

H p Composition setting xu t hi nộ ấ ệ
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T i thanh Preset ch n kích c  c a phim (N u làm h  PAL thì ch n PAL ạ ọ ỡ ủ ế ệ ọ

D1/DV mà các kênh truy n hình trong n c th ng phát).ề ứơ ườ

Chu n HD bây gi  : HDTV 1080 24( 24 hình/giây) ho c HD TV 1080 25( 25 ẩ ờ ặ

hình/giây)

 Đ t tên t i Compsition Nameặ ạ

 Preset: ch n kích th c màn hình   ch  đ  tùy ch n Custom.ọ ướ ở ế ộ ọ

 Width: chi u r ng màn hìnhề ộ

 Height: chi u cao màn hìnhề

 Pixel Aspect Ratio: Ch n ch  đ  hi n th  hình  nhọ ế ộ ể ị ả

xem   truy n hình ch n D1/DV Pal (1.09)ở ề ọ

Xem   máy chi u ho c máy tính ch n Squarở ế ặ ọ e pixel

  thanh Resolution (đ  phân gi i) ch n half hay full…, th ng ch n Ở ộ ả ọ ườ ọ

half cho nh  máy.ẹ

 Duration (th i l ng đ an phim) t c là chi u dài đ an phim mà chu n ờ ượ ọ ứ ề ọ ẩ
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b  x  lý (gi  s  đ an phim Qu ng các 30s, gõ vào s  30 thay th  vào sị ử ả ử ọ ả ố ế ố 

05 này gi : phút: giây: frame)ờ

 OK

  menu Edit/Preferences/General… b m next đ n thanh ImportỞ ấ ế

 t i Sequence Footage 25 Frames Per Second n u là h  PAL videoạ ế ệ

 Ph n Still Footage ( nh tĩnh) ch n Length of Compositionầ ả ọ

 Nh n next qua ph n Video preview ch n Output Device: Computer ấ ầ ọ

Monitor Only n u b n ch  preview trên máy tính (không có card d ng ế ạ ỉ ự

phim)
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3  Importting:

Có 4 cách:

 C1: T i menu File/Importạ

 C2: Nháy đúp  vào project panel

 C3: Ctrl+I

 C4: Kéo th    Window explorer vào ho c   desktop vào.ả ở ặ ở

  ph n Files of type ch a nh ng file mà AE cho phép import. Ph n Ở ầ ứ ữ ầ

Targa sequence s  active n u có m t chu i hình đ c đánh th  t  li n ẽ ế ộ ỗ ượ ứ ự ề

nhau,

15



 N u Import là file Photoshop thì s  xu t hi n menuế ẽ ấ ệ

 Và ch n t ng layer hay merged l i tùy ý.ọ ừ ạ

 Interpret Footage> main( Ctrl+Alt+ G): xu t hi n c a sấ ệ ử ổ

+ N u file đ c ch n có alpha chanel (32bit) thì s  xu t hi n:ế ượ ọ ẽ ấ ệ
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+ Ignore: b  qua chanel alpha.ỏ

+ Straight – Unmatted: n u file 32bit (nh  Targa 30bit)ế ư

+ Premultiplied – Matted with color: ch ng trình s  t  t o ph n mate theo ươ ẽ ự ạ ầ

màu background ch n (BG ph i là m t màu đ ng nh t).ọ ả ộ ồ ấ

Ph i chu t vào  nh ho c video:ả ộ ả ặ

+Replace Footage> File (Ctrl+H): thay th  video đang ch n.ế ọ

+Reload Footage: khi x  lý v i file Photoshop.ử ớ

 Kéo th  các files t  Project panel th  vào Timeline panel. Có th  import ả ừ ả ể

nhi u file và kéo th  nhi u files vào Timeline panel này, lúc đó s  xu t ề ả ề ẽ ấ

hi n nhi u layer nh  layer bên Photoshop.ệ ề ư

 Thi t l p l i màu n n c a ế ậ ạ ề ủ Compsition: Vào menu Compsition> 

Background Color. Ch n màu mu n thi t l p.ọ ố ế ậ

 Zoom Composition: lăn chu t gi aộ ữ

 ~ : zoom panel

 T o 1 th  m c đ  qu n lý các file  nh và video , nháy vào bi u t ng ạ ư ụ ể ả ả ể ượ
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Create New Folder.

4. C t video:ắ

Kéo thanh tr t đ  thay đ i workarea   TimeRuler, kéo 2 bên vào.ượ ể ổ ở

Ph i chu t> Trim Comp to workarea: c t ph n th aả ộ ắ ầ ừ

5. Animation

Ch n layer hình  nh, nháy vào mũi tên x  xu ngọ ả ổ ố

� Transform

� Anchor Point: phím t t ắ A

� Position: phím t t ắ P

� Scale: phím t tắ  S

� Rotation: phím t t ắ R

� Opacity: phím t t ắ T

Anchor Point là đi m trung tâm trong hình  nh, không b   nh h ng b iể ả ị ả ưở ở  

các thông s  : Rotation, Opacity, Scale nh ng s  b   nh h ng b i Positionố ư ẽ ị ả ưở ở

 Đ  thay đ i v  trì c a Anchor Point, ta s  d ng công c  Pan Behind (phím ể ổ ị ủ ử ụ ụ

t t Y)ắ

 T o m t keyframe b ng cách click vào hình đ ng h  n m bên tay trái tên ạ ộ ằ ồ ồ ằ

c a hi u  ngủ ệ ứ

 S  d ng phím ử ụ Space bar đ  xem tr c (preview)ể ướ

 M  nhi u hi u  ng cùng lúc: ở ề ệ ứ Shift + phím t tắ  (P,T,A,R,S,….)

� m  nh ng hi u  ng có keyframe: phím t tở ữ ệ ứ ắ  U

6. Keyframe:

C1:  n vào nút ấ �  Add or remove keyframe at current time, thay đ i thông ổ

s  c a hình  nh   keyframe ti p theo.ố ủ ả ở ế

C2:  kéo thanh tr t đ n th i gian c n t o và kéo tr c ti p trên hình  nh   ượ ế ờ ầ ạ ự ế ả ở

MH Compo.

C3:

+kéo thanh th i gian và  n vào đ ng h  trên hi u  ng t  giây s  0 xu t hi n ờ ấ ồ ồ ệ ứ ừ ố ấ ệ

đi m keyframe ể �
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+kéo thanh th i gian và thay đ i thông s  c a hi u  ng xu t hi n ờ ổ ố ủ ệ ứ ấ ệ �

 Có th  hoán đ i các keyframe cho nhau đ  thay đ i hi u  ng.ể ổ ể ổ ệ ứ

Xóa keyframe: ch n keyframe  n Deleteọ ấ

 Kích ho t ạ Motion blur 

             đ  chuy n đ ng ể ể ộ

đ c m t mà h n. ượ ượ ơ

7. Hi u  ngệ ứ

7.1. Thi t l p hi u  ng chuy n đ ng cho textế ậ ệ ứ ể ộ

Gõ ch ( đ  màu tr ng)ữ ể ắ

Vào menu Animation>Add text selector

> Wiggly

Trong  Add   ch n property>Positionọ

Thay đ i thông s  X= 700ổ ố
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Kéo thanh th i gian đ n 2s, thay đ i x=20ờ ế ổ

Trong  Add   ch n property>Blurọ

Th i đi m 0, đ t 700;700ờ ể ặ

Th i đi m 2s, đ t 25;25ờ ể ặ

T o Solid layer:ạ

Là 1 l p trung gian đ  ch a hi u  ng nào đó đ  áp d ng lên hi u  ng th  3ớ ể ứ ệ ứ ể ụ ệ ứ ứ

Vào menu Layer>New> Solid (Ctrl+Y)

Thi t l p hi u  ng cho layer Solidế ậ ệ ứ

Ch n layer solidọ

Menu Effect> Generate> 4Color gradient

Kéo 4 đi m g n nhau 1 chútể ầ

Ph i chu t vào layer Solid> Blending Mode> Classic Color Dodgeả ộ

>Ch  ch y đ i màu .ữ ạ ổ

7.2.Hi u  ng Textệ ứ

Ch n layer chọ ữ

Vào menu Animation> Brows Preset, ch n th  m c Textọ ư ụ

Ch n hi u  ng đ  xem tr c hi u  ngọ ệ ứ ể ướ ệ ứ

Nháy đúp đ  áp d ng hi u  ngể ụ ệ ứ
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Ho c vàoc a s   Effects and Preset, ch n Textặ ử ổ ọ

7.3.Các hi u  ng:ệ ứ

Ch n layer hình  nh ho c videoọ ả ặ

Vào menu Effects> Ch n hi u  ngọ ệ ứ

Ho c m  c a s  Effects and Preset (Ctrl+5)ặ ở ử ổ

Nháy đúp vào tên hi u  ng ho c kéo th  vào layer.ệ ứ ặ ả

7.3.1.Blur&Sharpen: s a hình d ng, đ  s c nét và đ  m  c a hình  nhử ạ ộ ắ ộ ờ ủ ả

Channel blur: m  đi kênh Alpha ho c t ng kênh màu riêng l , ho c theo ờ ặ ừ ẻ ặ

chi u ngang, chi u d cề ề ọ

Compound Blur: làm m  d a trên giá tr  Luminanceờ ự ị

Maximum: m c đ  m  t i đaứ ộ ờ ố

Strectch map to fit: t o l p che m  theo kich th c c a l p đ c áp d ngạ ớ ờ ướ ủ ớ ượ ụ

Invert blur: ngh ch đ o các giá tr  làm m , vùng t i s  m  nhi u h n vùng ị ả ị ờ ố ẽ ờ ề ơ

sáng.

Directional blur: t o  o giác chuy n đ ng cho 1 l p  nhạ ả ể ộ ớ ả

Fast Blur: làm mờ

Gaussian blur: làm m  d u hình  nhờ ị ả

Radial blur: t o c nh m   o xung quanh 1 đi m c  thạ ả ờ ả ể ụ ể

Sharpen: tăng đ  t ng ph n t i nh ng v  trí màu s c thay đ i, làm s c nét ộ ươ ả ạ ữ ị ắ ổ ắ

hình  nhả

Unsharp mask: tăng đ  t ng ph n gi a các màu nh m xác đ nh mép c nhộ ươ ả ữ ằ ị ạ

Box Blur: làm m  d a trên các giá tr  màu trung bình c a nh ng pixel k  c nờ ự ị ủ ữ ế ậ

7.3.2.Channel

*Arithmetic: thay đ i giá tr  các kênh màu red, green, blue v i t ng pixel trongổ ị ớ ừ  

nh.ả

*Blend: t o chuy n c nh cho 2 clip. Ch  đ  Crossfade :  nh g c m  d n ạ ể ả ế ộ ả ố ờ ầ

trong khi  nh m i d n hi n raả ớ ầ ệ

Blend with layer: ch  đ nh layer đ  đc ph i h p v i layer g cỉ ị ể ố ợ ớ ố
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Mode: ch  đ nh ch  đ  blend mu n s  d ngỉ ị ế ộ ố ử ụ

Cossfade: m  d n gi a  nh g c và  nh th  2ờ ầ ữ ả ố ả ứ

Color only: hóa màu t ng pixel trong  nh g c d a trên màu t ng px t ng ừ ả ố ự ừ ươ

ng trong  nh th  2.ứ ả ứ

Blend with layer:  layer đ  đc ph i h p v i layer g cể ố ợ ớ ố

Mode: ch  đ nh ch  đ  blend mu n s  d ngỉ ị ế ộ ố ử ụ

Cossfade: m  d n gi a  nh g c và  nh th  2ờ ầ ữ ả ố ả ứ

Color only: hóa màu t ng pixel trong  nh g c d a trên màu t ng px t ng ừ ả ố ự ừ ươ

ng trong  nh th  2.ứ ả ứ

Tint only: gi ng Color only nh ng ch  tính nh ng px trong  nh g c khi nào ố ư ỉ ữ ả ố

chúng đã đc tô màu.

Darken Only: làm s m nh ng px trong  nh g c đang   tình tr ng nh t h n pxẫ ữ ả ố ở ạ ạ ơ  

t ng  ng trong  nh th  2.ươ ứ ả ứ

Lighten Only: làm nh t nh ng px trong  nh g c đang   tình tr ng đ m h n pxạ ữ ả ố ở ạ ậ ơ  

t ng  ng trong  nh th  2.ươ ứ ả ứ

Blend with original: ch  đ nh m c đ  m  d n gi a  nh đã ph i h p v i  nh ỉ ị ứ ộ ờ ầ ữ ả ố ợ ớ ả

g c.ố

Ví d : Layer  nh 1 và  nh 2.ụ ả ả

Ch n layer  nh 1, ch n hi u  ng Blend.ọ ả ọ ệ ứ

Blend with layer=None (ko áp d n chuy n c nh gi a 2 layer)ụ ể ả ữ

Mode= Color only

Blend with original= 100% t i th i đi m đ u, t i th i đi m cu i ch n 0%ạ ờ ể ầ ạ ờ ể ố ọ
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*Caculation: ph i h p các kênh c a 2  nh v i nhauố ợ ủ ả ớ

*Chanel combiner: hi u ch nh nh ng kênh màu khác nhau trog  nhệ ỉ ữ ả

*Compound arithmetic: ph i h p v  m t toán h c layer mà nó đc áp d ng ố ợ ề ặ ọ ụ

v i 1 layer khác.ớ

*Invert: ngh ch đ o giá tr  màu c a  nhị ả ị ủ ả

*Minimax: m  r ng ho c thu nh  1 matte dành cho 1 kênh c  th  ho c t t cở ộ ặ ỏ ụ ể ặ ấ ả 

các kênh.

*Set channels: thi t đ t các kênh màu t  nh ng layer khác vào nh ng kênh ế ặ ừ ữ ữ

red, green, blue và alpha c a layer hi n hành.ủ ệ

*Set matte: thay th  kênh alpha c a 1 layer v i 1 kênh t  1 layer khác phía ế ủ ớ ừ

trên nó.

*Shift channels: thay th  nh ng kênh red, green, blue và alpha trong  nh b ngế ữ ả ằ  

nh ng kênh khác. Take channel from: ch  đ nh kênh ngu n.ữ ỉ ị ồ

7.3.3. Color Correction: hi u ch nh cân b ng màu s c.ệ ỉ ằ ắ

*Brightness&Contrast: đi u ch nh đ  sáng và đ  t ng ph n c a toàn b  layerề ỉ ộ ộ ươ ả ủ ộ

*Channel Mixer: s a đ i kênh màu b ng cách ph i h p các kênh màu hi n ử ổ ằ ố ợ ệ
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hành.

*Color Balance: thay đ i các màu R, G, B trong 1 layerổ

*Change to color: làm thay đ i màu ch n trong  nh thành 1 màu khác mà ko ổ ọ ả

nh h ng đ n màu khác.ả ưở ế

7.3.4.Generate

*4Color gradient: t o chuy n s c 4 màuạ ể ắ

*Avanced lightning: t o các hi u  ng phóng sétạ ệ ứ

*beam effect: t o chuy n đ ng c a tia laser( b n tia laser ho c b n c a đũa ạ ể ộ ủ ắ ặ ắ ủ

th n)ầ
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Công c  Mask.ụ

1. Mask Là gì?

Mask là m t công c  đ c tích h p s n trên Menu Bar c a ph n m m after ộ ụ ượ ợ ẵ ủ ầ ề

effects, tính năng chính c a Mask là t o ra l p m t n , khi l p Layer đ c áp ủ ạ ớ ặ ạ ớ ượ

d ng b i mask chúng ta ch  có th  quan sát đ c m t ph n c a l p layer n mụ ở ỉ ể ượ ộ ầ ủ ớ ằ  

trong vùng  nh h ng c a Mask, ph n còn l i c a layer n m ngoài vùng anh ả ưở ủ ầ ạ ủ ằ

h ng c a Mask s  b  tri t thoát kh i vùng nhìn.ưở ủ ẽ ị ệ ỏ

2. Mask Đ c hình thành b i y u t  gì?ượ ở ế ố

C u t o c a Mask đ c hình thành b i m t đ ng Path khép kín, đ c k t ấ ạ ủ ượ ở ộ ườ ượ ế

n i b i các node g n li n v i nhau, Mask ch  hi n h u khi các Node đ c ố ở ắ ề ớ ỉ ệ ữ ượ

đóng l i thành m t kh i li n m ch. Ngoài ra Mask có th  di chuy n theo ạ ộ ố ề ạ ể ể

chuy n đ ng c a Keys Frame.ể ộ ủ
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