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Tuyên bố bản quyền 

Giáo trình này sử dụng làm tài liệu giảng dạy nội bộ trong trường 

cao đẳng nghề Công nghiệp Hà Nội 

Trường Cao đẳng nghề Công nghiệp Hà Nội không sử dụng và 

không cho phép bất kỳ cá nhân hay tổ chức nào sử dụng giáo trình này với 

mục đích kinh doanh. 

Mọi trích dẫn, sử dụng giáo trình này với mục đích khác hay ở nơi 

khác đều phải được sự đồng ý bằng văn bản của trường Cao đẳng nghề 

Công nghiệp Hà Nội 
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Mở Đầu 

 

After Effects (AE) là một trong các chương trình xử lý phim chuyên nghiệp 

(Edit film) và dễ sử dụng do hãng Adobe phát triển. 

 

AE giúp quản lý các giao diện cũng như cách quản lý một Project hay những 

effect thường dùng trong phim ảnh. Cung cấp các công cụ về cách làm kỷ xảo 

phim, về chuyển động, timming, nhịp… 

 

Phần 1  

GIAO DIỆN  

 

Đầu tiên chúng ta sẽ làm quen về Giao diện (Interface), hay Vùng làm việc 

(WorkSpace) của After Effects (AE). 

 

 

 

Vùng nhìn Project: Quản lý các files import.  

Composition panel: Giống như monitor, sẽ hiển thị kết quả sau khi xử lý.  
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Timeline: Điều khiển animation, effects… theo thời gian.  

 

- Mở 1 vùng làm việc mới: Chọn open một workspace định sẵn của AE 

bằng cách : 

 

 

Hoặc chúng ta điều chỉnh kích thước của từng panel, bằng cách đưa con trỏ 

chuột vào giữa hai panel: 
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Dock, group, or float panels:  

Bạn có thể di chuyển các panel bằng cách kéo các chúng sắp xếp theo từng 

nhóm (group) khác nhau. 

 

 

Hoặc right-click góc trên panel, chọn undock panel. 
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Các icon trong panel: 

Dùng mouse wheel, bạn có thể phóng lớn thu nhỏ vùng nhìn composite.  

Alt + mouse wheel, phóng lớn vùng nhìn Timeline.  

Giữ Spacebar + mouse left để pan.  

Right click trên toolbar bạn có thể ẩn hoặc hiện các cột như hình vẽ.  

 

 

 

Hoặc tại góc mỗi viewer có các icon tam giác bạn có thể click vào :  
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Tại vùng nhìn Composition (góc trái bên dưới), bạn click vào icon (Always 

Preview This view) thì mỗi lần bạn thực hiện preview chỉ cửa sổ này mới view 

cho bạn.  
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Ở icon kế bên, bạn bật Title/Action Safe :  

 

 

 

 

 

 

Lúc này sẽ xuất hiện vùng nhìn an toàn trên viewer composition : 
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Cũng như các chương trình khác, thanh Toolbar trên góc trái màn hình có các 

chức năng : 
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PHẦN 2 THỰC HIỆN MỘT PROJECT 

 

Trước khi bắt tay vào edit hay làm effects một đọan phim nào đó, chúng ta phải 

sắp xếp các hình ảnh, âm thanh, kịch bản…. Tức là thực hiện một Project. 

1 – Setup Projects: 

Vào menu File-> New Project 

 

Tiếp theo chọn Files/project settings: 

 

Tại Timecode base, chọn 25fpt (25 frame per secon cho hệ PAL video) và Audio 

setting chon Sample Rate 41.100 kHz 
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2.Tạo Composition mới 

C1: Tại menu Composition/New Composition (Ctr+N). 

C2: Nháy vào biểu tượng  

Hộp Composition setting xuất hiện 

 

 

Tại thanh Preset chọn kích cỡ của phim (Nếu làm hệ PAL thì chọn PAL D1/DV 

mà các kênh truyền hình trong nứơc thường phát). 

Chuẩn HD bây giờ : HDTV 1080 24( 24 hình/giây) hoặc HD TV 1080 25( 25 

hình/giây) 
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- Đặt tên tại Compsition Name 

- Preset: chọn kích thước màn hình ở chế độ tùy chọn Custom. 

- Width: chiều rộng màn hình 

- Height: chiều cao màn hình 

- Pixel Aspect Ratio: Chọn chế độ hiển thị hình ảnh 

xem ở truyền hình chọn D1/DV Pal (1.09) 

Xem ở máy chiếu hoặc máy tính chọn Square pixel 

- Ở thanh Resolution (độ phân giải) chọn half hay full…, thường chọn half 

cho nhẹ máy. 

- Duration (thời lượng đọan phim) tức là chiều dài đọan phim mà chuẩn bị 

xử lý (giả sử đọan phim Quảng các 30s, gõ vào số 30 thay thế vào số 05 

này- giờ: phút: giây: frame) 

- OK 

- Ở menu Edit/Preferences/General… bấm next đến thanh Import 
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- tại Sequence Footage 25 Frames Per Second nếu là hệ PAL video 

- Phần Still Footage (ảnh tĩnh) chọn Length of Composition 

- Nhấn next qua phần Video preview chọn Output Device: Computer 

Monitor Only nếu bạn chỉ preview trên máy tính (không có card dựng 

phim) 
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3 - Importting: 

Có 4 cách: 

- C1: Tại menu File/Import 

- C2: Nháy đúp  vào project panel 

- C3: Ctrl+I 

- C4: Kéo thả ở Window explorer vào hoặc ở desktop vào. 

- Ở phần Files of type chứa những file mà AE cho phép import. Phần Targa 

sequence sẽ active nếu có một chuỗi hình được đánh thứ tự liền nhau, 
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- Nếu Import là file Photoshop thì sẽ xuất hiện menu 

 

- Và chọn từng layer hay merged lại tùy ý. 

- Interpret Footage-> main( Ctrl+Alt+ G): xuất hiện cửa sổ 

+ Nếu file được chọn có alpha chanel (32bit) thì sẽ xuất hiện: 
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+ Ignore: bỏ qua chanel alpha. 

+ Straight – Unmatted: nếu file 32bit (như Targa 30bit) 

+ Premultiplied – Matted with color: chương trình sẽ tự tạo phần mate theo màu 

background chọn (BG phải là một màu đồng nhất). 

 

-Phải chuột vào ảnh hoặc video: 

+Replace Footage-> File (Ctrl+H): thay thế video đang chọn. 

+Reload Footage: khi xử lý với file Photoshop. 

 

- Kéo thả các files từ Project panel thả vào Timeline panel. Có thể import 

nhiều file và kéo thả nhiều files vào Timeline panel này, lúc đó sẽ xuất 

hiện nhiều layer như layer bên Photoshop. 

 

- Thiết lập lại màu nền của Compsition: Vào menu Compsition-> 

Background Color. Chọn màu muốn thiết lập. 

 

- Zoom Composition: lăn chuột giữa 

 

- ~ : zoom panel 

 

- Tạo 1 thư mục để quản lý các file ảnh và video , nháy vào biểu tượng 

Create New Folder. 
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4. Cắt video: 

Kéo thanh trượt để thay đổi workarea ở TimeRuler, kéo 2 bên vào. 

Phải chuột-> Trim Comp to workarea: cắt phần thừa 

5. Animation 

-Chọn layer hình ảnh, nháy vào mũi tên xổ xuống 

Transform 

 Anchor Point: phím tắt A 

 Position: phím tắt P 

 Scale: phím tắt S 

 Rotation: phím tắt R 

 Opacity: phím tắt T 

Anchor Point là điểm trung tâm trong hình ảnh, không bị ảnh hưởng bởi 

các thông số : Rotation, Opacity, Scale nhưng sẽ bị ảnh hưởng bởi Position 

- Để thay đổi vị trì của Anchor Point, ta sử dụng công cụ Pan Behind (phím tắt 

Y) 

- Tạo một keyframe bằng cách click vào hình đồng hồ nằm bên tay trái tên của 

hiệu ứng 

- Sử dụng phím Space bar để xem trước (preview) 

- Mở nhiều hiệu ứng cùng lúc: Shift + phím tắt (P,T,A,R,S,….) 

 mở những hiệu ứng có keyframe: phím tắt U 

6. Keyframe: 

C1: ấn vào nút  Add or remove keyframe at current time, thay đổi thông 

số của hình ảnh ở keyframe tiếp theo. 

C2:  kéo thanh trượt đến thời gian cần tạo và kéo trực tiếp trên hình ảnh ở MH 

Compo. 

C3: 

+kéo thanh thời gian và ấn vào đồng hồ trên hiệu ứng từ giây số 0 xuất hiện 

điểm keyframe  

+kéo thanh thời gian và thay đổi thông số của hiệu ứng xuất hiện  

 

- Có thể hoán đổi các keyframe cho nhau để thay đổi hiệu ứng. 

-Xóa keyframe: chọn keyframe ấn Delete 
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- Kích hoạt Motion blur   

             để chuyển động 

được mượt mà hơn.  

 

7. Hiệu ứng 

 

7.1. Thiết lập hiệu ứng chuyển động cho text 

-Gõ chữ( để màu trắng) 

-Vào menu Animation->Add text selector 

-> Wiggly 

 

 

Trong  Add  chọn property->Position 

 

 

 

Thay đổi thông số X= 700 

Kéo thanh thời gian đến 2s, thay đổi x=20 

Trong  Add  chọn property->Blur 

Thời điểm 0, đặt 700;700 

Thời điểm 2s, đặt 25;25 

 

Tạo Solid layer: 
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Là 1 lớp trung gian để chứa hiệu ứng nào đó để áp dụng lên hiệu ứng thứ 3 

Vào menu Layer->New-> Solid (Ctrl+Y) 

 

Thiết lập hiệu ứng cho layer Solid 

-Chọn layer solid 

-Menu Effect-> Generate-> 4-Color gradient 

-Kéo 4 điểm gần nhau 1 chút 

 

 

-Phải chuột vào layer Solid-> Blending Mode-> Classic Color Dodge 

 

->Chữ chạy đổi màu . 

7.2.Hiệu ứng Text 

-Chọn layer chữ 

-Vào menu Animation-> Brows Preset, chọn thư mục Text 

-Chọn hiệu ứng để xem trước hiệu ứng 

-Nháy đúp để áp dụng hiệu ứng 

-Hoặc vàocửa sổ  Effects and Preset, chọn Text 

 

7.3.Các hiệu ứng: 

-Chọn layer hình ảnh hoặc video 

-Vào menu Effects-> Chọn hiệu ứng 

-Hoặc mở cửa sổ Effects and Preset (Ctrl+5) 

-Nháy đúp vào tên hiệu ứng hoặc kéo thả vào layer. 
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7.3.1.Blur&Sharpen: sửa hình dạng, độ sắc nét và độ mờ của hình ảnh 

Channel blur: mờ đi kênh Alpha hoặc từng kênh màu riêng lẻ, hoặc theo chiều 

ngang, chiều dọc 

Compound Blur: làm mờ dựa trên giá trị Luminance 

Maximum: mức độ mờ tối đa 

Strectch map to fit: tạo lớp che mờ theo kich thước của lớp được áp dụng 

Invert blur: nghịch đảo các giá trị làm mờ, vùng tối sẽ mờ nhiều hơn vùng sáng. 

Directional blur: tạo ảo giác chuyển động cho 1 lớp ảnh 

Fast Blur: làm mờ 

Gaussian blur: làm mờ dịu hình ảnh 

Radial blur: tạo cảnh mờ ảo xung quanh 1 điểm cụ thể 

Sharpen: tăng độ tương phản tại những vị trí màu sắc thay đổi, làm sắc nét hình 

ảnh 

Unsharp mask: tăng độ tương phản giữa các màu nhằm xác định mép cạnh 

Box Blur: làm mờ dựa trên các giá trị màu trung bình của những pixel kế cận 

 

7.3.2.Channel 

*Arithmetic: thay đổi giá trị các kênh màu red, green, blue với từng pixel trong 

ảnh. 

*Blend: tạo chuyển cảnh cho 2 clip. Chế độ Crossfade : ảnh gốc mờ dần trong 

khi ảnh mới dần hiện ra 

Blend with layer: chỉ định layer để đc phối hợp với layer gốc 

Mode: chỉ định chế độ blend muốn sử dụng 

Cossfade: mờ dần giữa ảnh gốc và ảnh thứ 2 

Color only: hóa màu từng pixel trong ảnh gốc dựa trên màu từng px tương ứng 

trong ảnh thứ 2. 

Blend with layer:  layer để đc phối hợp với layer gốc 

Mode: chỉ định chế độ blend muốn sử dụng 

Cossfade: mờ dần giữa ảnh gốc và ảnh thứ 2 

Color only: hóa màu từng pixel trong ảnh gốc dựa trên màu từng px tương ứng 

trong ảnh thứ 2. 

Tint only: giống Color only nhưng chỉ tính những px trong ảnh gốc khi nào 

chúng đã đc tô màu. 

Darken Only: làm sẫm những px trong ảnh gốc đang ở tình trạng nhạt hơn px 
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tương ứng trong ảnh thứ 2. 

Lighten Only: làm nhạt những px trong ảnh gốc đang ở tình trạng đậm hơn px 

tương ứng trong ảnh thứ 2. 

Blend with original: chỉ định mức độ mờ dần giữa ảnh đã phối hợp với ảnh gốc. 

Ví dụ: Layer ảnh 1 và ảnh 2. 

Chọn layer ảnh 1, chọn hiệu ứng Blend. 

Blend with layer=None (ko áp dụn chuyển cảnh giữa 2 layer) 

Mode= Color only 

Blend with original= 100% tại thời điểm đầu, tại thời điểm cuối chọn 0% 

 

*Caculation: phối hợp các kênh của 2 ảnh với nhau 

*Chanel combiner: hiệu chỉnh những kênh màu khác nhau trog ảnh 

*Compound arithmetic: phối hợp về mặt toán học layer mà nó đc áp dụng với 

1 layer khác. 

*Invert: nghịch đảo giá trị màu của ảnh 

*Minimax: mở rộng hoặc thu nhỏ 1 matte dành cho 1 kênh cụ thể hoặc tất cả 

các kênh. 

*Set channels: thiết đặt các kênh màu từ những layer khác vào những kênh red, 

green, blue và alpha của layer hiện hành. 

*Set matte: thay thế kênh alpha của 1 layer với 1 kênh từ 1 layer khác phía trên 
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nó. 

*Shift channels: thay thế những kênh red, green, blue và alpha trong ảnh bằng 

những kênh khác. Take channel from: chỉ định kênh nguồn. 

 

7.3.3. Color Correction: hiệu chỉnh cân bằng màu sắc. 

*Brightness&Contrast: điều chỉnh độ sáng và độ tương phản của toàn bộ layer 

*Channel Mixer: sửa đổi kênh màu bằng cách phối hợp các kênh màu hiện hành. 

*Color Balance: thay đổi các màu R, G, B trong 1 layer 

*Change to color: làm thay đổi màu chọn trong ảnh thành 1 màu khác mà ko ảnh 

hưởng đến màu khác. 

 

7.3.4.Generate 

*4-Color gradient: tạo chuyển sắc 4 màu 

*Avanced lightning: tạo các hiệu ứng phóng sét 

*beam effect: tạo chuyển động của tia laser( bắn tia laser hoặc bắn của đũa thần) 
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Công cụ Mask. 

1. Mask Là gì? 

Mask là một công cụ được tích hợp sẵn trên Menu Bar của phần mềm after 

effects, tính năng chính của Mask là tạo ra lớp mặt nạ, khi lớp Layer được áp 

dụng bởi mask chúng ta chỉ có thể quan sát được một phần của lớp layer nằm 

trong vùng ảnh hưởng của Mask, phần còn lại của layer nằm ngoài vùng anh 

hưởng của Mask sẽ bị triệt thoát khỏi vùng nhìn. 

2. Mask Được hình thành bởi yếu tố gì? 

Cấu tạo của Mask được hình thành bởi một đường Path khép kín, được kết nối 

bởi các node gắn liền với nhau, Mask chỉ hiện hữu khi các Node được đóng lại 

thành một khối liền mạch. Ngoài ra Mask có thể di chuyển theo chuyển động 

của Keys Frame. 

 

 

 

 

 

 

 


